Ubuntu 6374 Published by

A PHP security update has been released for Ubuntu Linux 21.10.



==========================================================================
Ubuntu Security Notice USN-5300-3
March 07, 2022

php8.0 vulnerabilities
==========================================================================

A security issue affects these releases of Ubuntu and its derivatives:

- Ubuntu 21.10

Summary:

Several security issues were fixed in PHP.

Software Description:
- php8.0: HTML-embedded scripting language interpreter

Details:

USN-5300-1 fixed vulnerabilities in PHP. This update provides the
corresponding updates for Ubuntu 21.10.

Original advisory details:

It was discovered that PHP incorrectly handled certain scripts.
An attacker could possibly use this issue to cause a denial of service.
(CVE-2015-9253, CVE-2017-8923, CVE-2017-9118, CVE-2017-9120)
It was discovered that PHP incorrectly handled certain inputs.
An attacker could possibly use this issue to cause a denial of service,
or possibly obtain sensitive information. (CVE-2017-9119)
It was discovered that PHP incorrectly handled certain scripts with XML
parsing functions.
An attacker could possibly use this issue to obtain sensitive information.
(CVE-2021-21707)

Update instructions:

The problem can be corrected by updating your system to the following
package versions:

Ubuntu 21.10:
php8.0-cgi 8.0.8-1ubuntu0.3
php8.0-cli 8.0.8-1ubuntu0.3
php8.0-fpm 8.0.8-1ubuntu0.3

In general, a standard system update will make all the necessary changes.

References:
  https://ubuntu.com/security/notices/USN-5300-3
  https://ubuntu.com/security/notices/USN-5300-1
CVE-2017-8923, CVE-2017-9118, CVE-2017-9120, CVE-2021-21707

Package Information:
  https://launchpad.net/ubuntu/+source/php8.0/8.0.8-1ubuntu0.3