SUSE 5054 Published by

A libqb security update has been released for openSUSE Leap 15.4 and SUSE Linux Enterprise.



SUSE-SU-2023:3728-1: moderate: Security update for libqb


# Security update for libqb

Announcement ID: SUSE-SU-2023:3728-1
Rating: moderate
References:

* #1214066

Cross-References:

* CVE-2023-39976

CVSS scores:

* CVE-2023-39976 ( SUSE ): 5.9 CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H
* CVE-2023-39976 ( NVD ): 9.8 CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Affected Products:

* openSUSE Leap 15.4
* SUSE Linux Enterprise High Availability Extension 15 SP1
* SUSE Linux Enterprise High Availability Extension 15 SP2
* SUSE Linux Enterprise High Performance Computing 15 SP1
* SUSE Linux Enterprise High Performance Computing 15 SP2
* SUSE Linux Enterprise Server 15 SP1
* SUSE Linux Enterprise Server 15 SP1 Business Critical Linux 15-SP1
* SUSE Linux Enterprise Server 15 SP2
* SUSE Linux Enterprise Server 15 SP2 Business Critical Linux 15-SP2
* SUSE Linux Enterprise Server for SAP Applications 15 SP1
* SUSE Linux Enterprise Server for SAP Applications 15 SP2
* SUSE Manager Proxy 4.0
* SUSE Manager Proxy 4.1
* SUSE Manager Retail Branch Server 4.0
* SUSE Manager Retail Branch Server 4.1
* SUSE Manager Server 4.0
* SUSE Manager Server 4.1

An update that solves one vulnerability can now be installed.

## Description:

This update for libqb fixes the following issues:

* CVE-2023-39976: Fixed potential buffer overflow with long log messages
(bsc#1214066).

## Patch Instructions:

To install this SUSE update use the SUSE recommended installation methods like
YaST online_update or "zypper patch".
Alternatively you can run the command listed for your product:

* openSUSE Leap 15.4
zypper in -t patch openSUSE-SLE-15.4-2023-3728=1

* SUSE Linux Enterprise High Availability Extension 15 SP1
zypper in -t patch SUSE-SLE-Product-HA-15-SP1-2023-3728=1

* SUSE Linux Enterprise High Availability Extension 15 SP2
zypper in -t patch SUSE-SLE-Product-HA-15-SP2-2023-3728=1

## Package List:

* openSUSE Leap 15.4 (aarch64 ppc64le s390x x86_64)
* libqb20-debuginfo-1.0.3+20190326.a521604-150100.3.9.1
* libqb20-1.0.3+20190326.a521604-150100.3.9.1
* openSUSE Leap 15.4 (x86_64)
* libqb20-32bit-debuginfo-1.0.3+20190326.a521604-150100.3.9.1
* libqb20-32bit-1.0.3+20190326.a521604-150100.3.9.1
* SUSE Linux Enterprise High Availability Extension 15 SP1 (aarch64 ppc64le
s390x x86_64)
* libqb-tools-1.0.3+20190326.a521604-150100.3.9.1
* libqb-tools-debuginfo-1.0.3+20190326.a521604-150100.3.9.1
* libqb-tests-debuginfo-1.0.3+20190326.a521604-150100.3.9.1
* libqb-debugsource-1.0.3+20190326.a521604-150100.3.9.1
* libqb20-debuginfo-1.0.3+20190326.a521604-150100.3.9.1
* libqb-devel-1.0.3+20190326.a521604-150100.3.9.1
* libqb20-1.0.3+20190326.a521604-150100.3.9.1
* libqb-tests-1.0.3+20190326.a521604-150100.3.9.1
* SUSE Linux Enterprise High Availability Extension 15 SP2 (aarch64 ppc64le
s390x x86_64)
* libqb-tools-1.0.3+20190326.a521604-150100.3.9.1
* libqb-tools-debuginfo-1.0.3+20190326.a521604-150100.3.9.1
* libqb-tests-debuginfo-1.0.3+20190326.a521604-150100.3.9.1
* libqb-debugsource-1.0.3+20190326.a521604-150100.3.9.1
* libqb20-debuginfo-1.0.3+20190326.a521604-150100.3.9.1
* libqb-devel-1.0.3+20190326.a521604-150100.3.9.1
* libqb20-1.0.3+20190326.a521604-150100.3.9.1
* libqb-tests-1.0.3+20190326.a521604-150100.3.9.1

## References:

* https://www.suse.com/security/cve/CVE-2023-39976.html
* https://bugzilla.suse.com/show_bug.cgi?id=1214066