SUSE 5056 Published by

A kubernetes1.18 security update has been released for openSUSE Leap 15.4/15.5 and SUSE Linux Enterprise.



SUSE-SU-2023:3532-1: important: Security update for kubernetes1.18


# Security update for kubernetes1.18

Announcement ID: SUSE-SU-2023:3532-1
Rating: important
References:

* #1212475

Affected Products:

* Containers Module 15-SP4
* openSUSE Leap 15.4
* openSUSE Leap 15.5
* SUSE Enterprise Storage 7
* SUSE Enterprise Storage 7.1
* SUSE Linux Enterprise High Performance Computing 15 SP2
* SUSE Linux Enterprise High Performance Computing 15 SP2 LTSS 15-SP2
* SUSE Linux Enterprise High Performance Computing 15 SP3
* SUSE Linux Enterprise High Performance Computing 15 SP4
* SUSE Linux Enterprise High Performance Computing ESPOS 15 SP3
* SUSE Linux Enterprise High Performance Computing LTSS 15 SP3
* SUSE Linux Enterprise Real Time 15 SP4
* SUSE Linux Enterprise Server 15 SP2
* SUSE Linux Enterprise Server 15 SP2 LTSS 15-SP2
* SUSE Linux Enterprise Server 15 SP3
* SUSE Linux Enterprise Server 15 SP3 LTSS 15-SP3
* SUSE Linux Enterprise Server 15 SP4
* SUSE Linux Enterprise Server for SAP Applications 15 SP2
* SUSE Linux Enterprise Server for SAP Applications 15 SP3
* SUSE Linux Enterprise Server for SAP Applications 15 SP4
* SUSE Manager Proxy 4.3
* SUSE Manager Retail Branch Server 4.3
* SUSE Manager Server 4.3

An update that has one security fix can now be installed.

## Description:

This update of kubernetes1.18 fixes the following issues:

* rebuild the package with the go 1.21 security release (bsc#1212475).

## Patch Instructions:

To install this SUSE update use the SUSE recommended installation methods like
YaST online_update or "zypper patch".
Alternatively you can run the command listed for your product:

* openSUSE Leap 15.4
zypper in -t patch openSUSE-SLE-15.4-2023-3532=1

* openSUSE Leap 15.5
zypper in -t patch openSUSE-SLE-15.5-2023-3532=1

* Containers Module 15-SP4
zypper in -t patch SUSE-SLE-Module-Containers-15-SP4-2023-3532=1

* SUSE Linux Enterprise High Performance Computing 15 SP2 LTSS 15-SP2
zypper in -t patch SUSE-SLE-Product-HPC-15-SP2-LTSS-2023-3532=1

* SUSE Linux Enterprise High Performance Computing ESPOS 15 SP3
zypper in -t patch SUSE-SLE-Product-HPC-15-SP3-ESPOS-2023-3532=1

* SUSE Linux Enterprise High Performance Computing LTSS 15 SP3
zypper in -t patch SUSE-SLE-Product-HPC-15-SP3-LTSS-2023-3532=1

* SUSE Linux Enterprise Server 15 SP2 LTSS 15-SP2
zypper in -t patch SUSE-SLE-Product-SLES-15-SP2-LTSS-2023-3532=1

* SUSE Linux Enterprise Server 15 SP3 LTSS 15-SP3
zypper in -t patch SUSE-SLE-Product-SLES-15-SP3-LTSS-2023-3532=1

* SUSE Linux Enterprise Server for SAP Applications 15 SP2
zypper in -t patch SUSE-SLE-Product-SLES_SAP-15-SP2-2023-3532=1

* SUSE Linux Enterprise Server for SAP Applications 15 SP3
zypper in -t patch SUSE-SLE-Product-SLES_SAP-15-SP3-2023-3532=1

* SUSE Enterprise Storage 7.1
zypper in -t patch SUSE-Storage-7.1-2023-3532=1

* SUSE Enterprise Storage 7
zypper in -t patch SUSE-Storage-7-2023-3532=1

## Package List:

* openSUSE Leap 15.4 (aarch64 ppc64le s390x x86_64)
* kubernetes1.18-client-common-1.18.10-150200.5.17.1
* kubernetes1.18-client-1.18.10-150200.5.17.1
* openSUSE Leap 15.4 (ppc64le)
* kubernetes1.18-client-debuginfo-1.18.10-150200.5.17.1
* openSUSE Leap 15.5 (aarch64 ppc64le s390x x86_64)
* kubernetes1.18-client-common-1.18.10-150200.5.17.1
* kubernetes1.18-client-1.18.10-150200.5.17.1
* openSUSE Leap 15.5 (ppc64le)
* kubernetes1.18-client-debuginfo-1.18.10-150200.5.17.1
* Containers Module 15-SP4 (aarch64 ppc64le s390x)
* kubernetes1.18-client-common-1.18.10-150200.5.17.1
* kubernetes1.18-client-1.18.10-150200.5.17.1
* Containers Module 15-SP4 (ppc64le)
* kubernetes1.18-client-debuginfo-1.18.10-150200.5.17.1
* SUSE Linux Enterprise High Performance Computing 15 SP2 LTSS 15-SP2
(aarch64)
* kubernetes1.18-client-common-1.18.10-150200.5.17.1
* kubernetes1.18-client-1.18.10-150200.5.17.1
* SUSE Linux Enterprise High Performance Computing ESPOS 15 SP3 (aarch64)
* kubernetes1.18-client-common-1.18.10-150200.5.17.1
* kubernetes1.18-client-1.18.10-150200.5.17.1
* SUSE Linux Enterprise High Performance Computing LTSS 15 SP3 (aarch64)
* kubernetes1.18-client-common-1.18.10-150200.5.17.1
* kubernetes1.18-client-1.18.10-150200.5.17.1
* SUSE Linux Enterprise Server 15 SP2 LTSS 15-SP2 (aarch64 ppc64le s390x)
* kubernetes1.18-client-common-1.18.10-150200.5.17.1
* kubernetes1.18-client-1.18.10-150200.5.17.1
* SUSE Linux Enterprise Server 15 SP3 LTSS 15-SP3 (aarch64 ppc64le s390x)
* kubernetes1.18-client-common-1.18.10-150200.5.17.1
* kubernetes1.18-client-1.18.10-150200.5.17.1
* SUSE Linux Enterprise Server 15 SP3 LTSS 15-SP3 (ppc64le)
* kubernetes1.18-client-debuginfo-1.18.10-150200.5.17.1
* SUSE Linux Enterprise Server for SAP Applications 15 SP2 (ppc64le)
* kubernetes1.18-client-common-1.18.10-150200.5.17.1
* kubernetes1.18-client-1.18.10-150200.5.17.1
* SUSE Linux Enterprise Server for SAP Applications 15 SP3 (ppc64le)
* kubernetes1.18-client-debuginfo-1.18.10-150200.5.17.1
* kubernetes1.18-client-common-1.18.10-150200.5.17.1
* kubernetes1.18-client-1.18.10-150200.5.17.1
* SUSE Enterprise Storage 7.1 (aarch64)
* kubernetes1.18-client-common-1.18.10-150200.5.17.1
* kubernetes1.18-client-1.18.10-150200.5.17.1
* SUSE Enterprise Storage 7 (aarch64)
* kubernetes1.18-client-common-1.18.10-150200.5.17.1
* kubernetes1.18-client-1.18.10-150200.5.17.1

## References:

* https://bugzilla.suse.com/show_bug.cgi?id=1212475