SUSE 5001 Published by

A libvirt security update has been released for openSUSE Leap 15.5 and SUSE Linux Enterprise 15 SP5.



SUSE-SU-2023:3043-1: moderate: Security update for libvirt


# Security update for libvirt

Announcement ID: SUSE-SU-2023:3043-1
Rating: moderate
References:

* #1213352
* #1213447

Cross-References:

* CVE-2023-3750

CVSS scores:

* CVE-2023-3750 ( SUSE ): 5.5 CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H
* CVE-2023-3750 ( NVD ): 6.5 CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H

Affected Products:

* Basesystem Module 15-SP5
* openSUSE Leap 15.5
* Server Applications Module 15-SP5
* SUSE Linux Enterprise Desktop 15 SP5
* SUSE Linux Enterprise High Performance Computing 15 SP5
* SUSE Linux Enterprise Real Time 15 SP5
* SUSE Linux Enterprise Server 15 SP5
* SUSE Linux Enterprise Server for SAP Applications 15 SP5

An update that solves one vulnerability and has one fix can now be installed.

## Description:

This update for libvirt fixes the following issues:

Security fixes:

* CVE-2023-3750: Fixed mproper locking in virStoragePoolObjListSearch that may
lead to denial of service (bsc#1213447).

Other fixes:

* build library with support for modular daemons (bsc#1213352).

## Patch Instructions:

To install this SUSE Moderate update use the SUSE recommended installation
methods like YaST online_update or "zypper patch".
Alternatively you can run the command listed for your product:

* openSUSE Leap 15.5
zypper in -t patch SUSE-2023-3043=1 openSUSE-SLE-15.5-2023-3043=1

* Basesystem Module 15-SP5
zypper in -t patch SUSE-SLE-Module-Basesystem-15-SP5-2023-3043=1

* Server Applications Module 15-SP5
zypper in -t patch SUSE-SLE-Module-Server-Applications-15-SP5-2023-3043=1

## Package List:

* openSUSE Leap 15.5 (aarch64 ppc64le s390x x86_64 i586)
* libvirt-daemon-driver-nwfilter-9.0.0-150500.6.11.1
* libvirt-client-9.0.0-150500.6.11.1
* libvirt-9.0.0-150500.6.11.1
* libvirt-daemon-9.0.0-150500.6.11.1
* libvirt-client-qemu-9.0.0-150500.6.11.1
* libvirt-devel-9.0.0-150500.6.11.1
* libvirt-daemon-driver-storage-core-9.0.0-150500.6.11.1
* libvirt-daemon-driver-qemu-debuginfo-9.0.0-150500.6.11.1
* libvirt-daemon-hooks-9.0.0-150500.6.11.1
* libvirt-daemon-qemu-9.0.0-150500.6.11.1
* libvirt-daemon-config-nwfilter-9.0.0-150500.6.11.1
* libvirt-daemon-driver-interface-debuginfo-9.0.0-150500.6.11.1
* libvirt-daemon-debuginfo-9.0.0-150500.6.11.1
* wireshark-plugin-libvirt-9.0.0-150500.6.11.1
* libvirt-daemon-driver-storage-core-debuginfo-9.0.0-150500.6.11.1
* libvirt-daemon-driver-nwfilter-debuginfo-9.0.0-150500.6.11.1
* libvirt-daemon-driver-storage-gluster-debuginfo-9.0.0-150500.6.11.1
* libvirt-daemon-driver-storage-logical-9.0.0-150500.6.11.1
* libvirt-nss-9.0.0-150500.6.11.1
* libvirt-daemon-driver-storage-iscsi-debuginfo-9.0.0-150500.6.11.1
* libvirt-daemon-driver-storage-iscsi-direct-debuginfo-9.0.0-150500.6.11.1
* libvirt-daemon-driver-secret-debuginfo-9.0.0-150500.6.11.1
* libvirt-nss-debuginfo-9.0.0-150500.6.11.1
* libvirt-daemon-driver-nodedev-9.0.0-150500.6.11.1
* libvirt-daemon-driver-storage-logical-debuginfo-9.0.0-150500.6.11.1
* libvirt-daemon-driver-storage-scsi-9.0.0-150500.6.11.1
* libvirt-daemon-driver-lxc-debuginfo-9.0.0-150500.6.11.1
* libvirt-libs-9.0.0-150500.6.11.1
* libvirt-daemon-driver-nodedev-debuginfo-9.0.0-150500.6.11.1
* libvirt-daemon-driver-storage-mpath-debuginfo-9.0.0-150500.6.11.1
* libvirt-daemon-driver-secret-9.0.0-150500.6.11.1
* libvirt-daemon-driver-storage-disk-9.0.0-150500.6.11.1
* libvirt-lock-sanlock-debuginfo-9.0.0-150500.6.11.1
* libvirt-daemon-driver-network-9.0.0-150500.6.11.1
* libvirt-libs-debuginfo-9.0.0-150500.6.11.1
* libvirt-client-debuginfo-9.0.0-150500.6.11.1
* libvirt-daemon-driver-network-debuginfo-9.0.0-150500.6.11.1
* libvirt-daemon-driver-interface-9.0.0-150500.6.11.1
* libvirt-daemon-driver-storage-disk-debuginfo-9.0.0-150500.6.11.1
* libvirt-lock-sanlock-9.0.0-150500.6.11.1
* libvirt-daemon-config-network-9.0.0-150500.6.11.1
* wireshark-plugin-libvirt-debuginfo-9.0.0-150500.6.11.1
* libvirt-daemon-driver-storage-iscsi-9.0.0-150500.6.11.1
* libvirt-debugsource-9.0.0-150500.6.11.1
* libvirt-daemon-lxc-9.0.0-150500.6.11.1
* libvirt-daemon-driver-storage-iscsi-direct-9.0.0-150500.6.11.1
* libvirt-daemon-driver-storage-gluster-9.0.0-150500.6.11.1
* libvirt-daemon-driver-storage-scsi-debuginfo-9.0.0-150500.6.11.1
* libvirt-daemon-driver-storage-9.0.0-150500.6.11.1
* libvirt-daemon-driver-lxc-9.0.0-150500.6.11.1
* libvirt-daemon-driver-storage-mpath-9.0.0-150500.6.11.1
* libvirt-daemon-driver-qemu-9.0.0-150500.6.11.1
* openSUSE Leap 15.5 (x86_64)
* libvirt-client-32bit-debuginfo-9.0.0-150500.6.11.1
* libvirt-daemon-xen-9.0.0-150500.6.11.1
* libvirt-daemon-driver-libxl-debuginfo-9.0.0-150500.6.11.1
* libvirt-devel-32bit-9.0.0-150500.6.11.1
* libvirt-daemon-driver-libxl-9.0.0-150500.6.11.1
* openSUSE Leap 15.5 (noarch)
* libvirt-doc-9.0.0-150500.6.11.1
* openSUSE Leap 15.5 (aarch64 x86_64)
* libvirt-daemon-driver-storage-rbd-debuginfo-9.0.0-150500.6.11.1
* libvirt-daemon-driver-storage-rbd-9.0.0-150500.6.11.1
* openSUSE Leap 15.5 (aarch64_ilp32)
* libvirt-devel-64bit-9.0.0-150500.6.11.1
* libvirt-client-64bit-debuginfo-9.0.0-150500.6.11.1
* Basesystem Module 15-SP5 (aarch64 ppc64le s390x x86_64)
* libvirt-debugsource-9.0.0-150500.6.11.1
* libvirt-libs-debuginfo-9.0.0-150500.6.11.1
* libvirt-libs-9.0.0-150500.6.11.1
* Server Applications Module 15-SP5 (aarch64 ppc64le s390x x86_64)
* libvirt-daemon-driver-nwfilter-9.0.0-150500.6.11.1
* libvirt-client-9.0.0-150500.6.11.1
* libvirt-9.0.0-150500.6.11.1
* libvirt-daemon-9.0.0-150500.6.11.1
* libvirt-client-qemu-9.0.0-150500.6.11.1
* libvirt-devel-9.0.0-150500.6.11.1
* libvirt-daemon-driver-storage-core-9.0.0-150500.6.11.1
* libvirt-daemon-driver-qemu-debuginfo-9.0.0-150500.6.11.1
* libvirt-daemon-hooks-9.0.0-150500.6.11.1
* libvirt-daemon-qemu-9.0.0-150500.6.11.1
* libvirt-daemon-config-nwfilter-9.0.0-150500.6.11.1
* libvirt-daemon-driver-interface-debuginfo-9.0.0-150500.6.11.1
* libvirt-daemon-debuginfo-9.0.0-150500.6.11.1
* libvirt-daemon-driver-storage-core-debuginfo-9.0.0-150500.6.11.1
* libvirt-daemon-driver-nwfilter-debuginfo-9.0.0-150500.6.11.1
* libvirt-daemon-driver-storage-logical-9.0.0-150500.6.11.1
* libvirt-nss-9.0.0-150500.6.11.1
* libvirt-daemon-driver-storage-iscsi-debuginfo-9.0.0-150500.6.11.1
* libvirt-daemon-driver-storage-iscsi-direct-debuginfo-9.0.0-150500.6.11.1
* libvirt-daemon-driver-secret-debuginfo-9.0.0-150500.6.11.1
* libvirt-nss-debuginfo-9.0.0-150500.6.11.1
* libvirt-daemon-driver-nodedev-9.0.0-150500.6.11.1
* libvirt-daemon-driver-storage-logical-debuginfo-9.0.0-150500.6.11.1
* libvirt-daemon-driver-storage-scsi-9.0.0-150500.6.11.1
* libvirt-daemon-driver-nodedev-debuginfo-9.0.0-150500.6.11.1
* libvirt-daemon-driver-storage-mpath-debuginfo-9.0.0-150500.6.11.1
* libvirt-daemon-driver-secret-9.0.0-150500.6.11.1
* libvirt-daemon-driver-storage-disk-9.0.0-150500.6.11.1
* libvirt-lock-sanlock-debuginfo-9.0.0-150500.6.11.1
* libvirt-daemon-driver-network-9.0.0-150500.6.11.1
* libvirt-client-debuginfo-9.0.0-150500.6.11.1
* libvirt-daemon-driver-network-debuginfo-9.0.0-150500.6.11.1
* libvirt-daemon-driver-interface-9.0.0-150500.6.11.1
* libvirt-daemon-driver-storage-disk-debuginfo-9.0.0-150500.6.11.1
* libvirt-lock-sanlock-9.0.0-150500.6.11.1
* libvirt-daemon-config-network-9.0.0-150500.6.11.1
* libvirt-daemon-driver-storage-iscsi-9.0.0-150500.6.11.1
* libvirt-debugsource-9.0.0-150500.6.11.1
* libvirt-daemon-driver-storage-iscsi-direct-9.0.0-150500.6.11.1
* libvirt-daemon-driver-storage-scsi-debuginfo-9.0.0-150500.6.11.1
* libvirt-daemon-driver-storage-9.0.0-150500.6.11.1
* libvirt-daemon-driver-storage-mpath-9.0.0-150500.6.11.1
* libvirt-daemon-driver-qemu-9.0.0-150500.6.11.1
* Server Applications Module 15-SP5 (aarch64 x86_64)
* libvirt-daemon-driver-storage-rbd-debuginfo-9.0.0-150500.6.11.1
* libvirt-daemon-driver-storage-rbd-9.0.0-150500.6.11.1
* Server Applications Module 15-SP5 (noarch)
* libvirt-doc-9.0.0-150500.6.11.1
* Server Applications Module 15-SP5 (x86_64)
* libvirt-daemon-driver-libxl-9.0.0-150500.6.11.1
* libvirt-daemon-xen-9.0.0-150500.6.11.1
* libvirt-daemon-driver-libxl-debuginfo-9.0.0-150500.6.11.1

## References:

* https://www.suse.com/security/cve/CVE-2023-3750.html
* https://bugzilla.suse.com/show_bug.cgi?id=1213352
* https://bugzilla.suse.com/show_bug.cgi?id=1213447