Gentoo 2477 Published by

The following security updates have been released for Gentoo Linux:

[ GLSA 202401-27 ] Ruby: Multiple vulnerabilities
[ GLSA 202401-28 ] GOCR: Multiple Vulnerabilities
[ GLSA 202401-29 ] sudo: Memory Manipulation



[ GLSA 202401-27 ] Ruby: Multiple vulnerabilities


- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory GLSA 202401-27
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
https://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Severity: Normal
Title: Ruby: Multiple vulnerabilities
Date: January 24, 2024
Bugs: #747007, #801061, #827251, #838073, #882893, #903630
ID: 202401-27

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
========

Multiple vulnerabilities have been discovered in Ruby, the worst of
which could lead to execution of arbitrary code.

Background
==========

Ruby is an interpreted scripting language for quick and easy object-
oriented programming. It comes bundled with a HTTP server ("WEBrick").

Affected packages
=================

Package Vulnerable Unaffected
------------- ------------ ------------
dev-lang/ruby < 2.5.9:2.5 Vulnerable!
< 2.6.10:2.6 Vulnerable!
< 2.7.8:2.7 Vulnerable!
< 3.0.6:3.0 Vulnerable!
< 3.1.4:3.1 >= 3.1.4:3.1
< 3.2.2:3.2 >= 3.2.2:3.2

Description
===========

Multiple vulnerabilities have been discovered in Ruby. Please review the
CVE identifiers referenced below for details.

Impact
======

Please review the referenced CVE identifiers for details.

Workaround
==========

There is no known workaround at this time.

Resolution
==========

All Ruby users should upgrade to the latest version:

# emerge --sync
# emerge --ask --depclean ruby:2.5 ruby:2.6 ruby:2.7 ruby:3.0
# emerge --ask --oneshot --verbose ">=dev-lang/ruby-3.1.4:3.1"
# emerge --ask --oneshot --verbose ">=dev-lang/ruby-3.2.2:3.2"

References
==========

[ 1 ] CVE-2020-25613
https://nvd.nist.gov/vuln/detail/CVE-2020-25613
[ 2 ] CVE-2021-31810
https://nvd.nist.gov/vuln/detail/CVE-2021-31810
[ 3 ] CVE-2021-32066
https://nvd.nist.gov/vuln/detail/CVE-2021-32066
[ 4 ] CVE-2021-33621
https://nvd.nist.gov/vuln/detail/CVE-2021-33621
[ 5 ] CVE-2021-41816
https://nvd.nist.gov/vuln/detail/CVE-2021-41816
[ 6 ] CVE-2021-41817
https://nvd.nist.gov/vuln/detail/CVE-2021-41817
[ 7 ] CVE-2021-41819
https://nvd.nist.gov/vuln/detail/CVE-2021-41819
[ 8 ] CVE-2022-28738
https://nvd.nist.gov/vuln/detail/CVE-2022-28738
[ 9 ] CVE-2022-28739
https://nvd.nist.gov/vuln/detail/CVE-2022-28739
[ 10 ] CVE-2023-28755
https://nvd.nist.gov/vuln/detail/CVE-2023-28755
[ 11 ] CVE-2023-28756
https://nvd.nist.gov/vuln/detail/CVE-2023-28756

Availability
============

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

https://security.gentoo.org/glsa/202401-27

Concerns?
=========

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users' machines is of utmost
importance to us. Any security concerns should be addressed to
security@gentoo.org or alternatively, you may file a bug at
https://bugs.gentoo.org.

License
=======

Copyright 2024 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

https://creativecommons.org/licenses/by-sa/2.5



[ GLSA 202401-28 ] GOCR: Multiple Vulnerabilities


- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory GLSA 202401-28
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
https://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Severity: High
Title: GOCR: Multiple Vulnerabilities
Date: January 24, 2024
Bugs: #824290
ID: 202401-28

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
========

Multiple vulnerabilities have been discovered in GOCR, the worst of
which could lead to arbitrary code execution.

Background
==========

GOCR is an OCR (Optical Character Recognition) program, developed under
the GNU Public License. It converts scanned images of text back to text
files.

Affected packages
=================

Package Vulnerable Unaffected
------------- ------------ ------------
app-text/gocr