Red Hat 8826 Published by

A Red Hat OpenStack Platform (etcd) security update has been released.



RHSA-2023:1275-01: Important: Red Hat OpenStack Platform (etcd) security update



=====================================================================
Red Hat Security Advisory

Synopsis: Important: Red Hat OpenStack Platform (etcd) security update
Advisory ID: RHSA-2023:1275-01
Product: Red Hat OpenStack Platform
Advisory URL:   https://access.redhat.com/errata/RHSA-2023:1275
Issue date: 2023-03-15
CVE Names: CVE-2022-1705 CVE-2022-2880 CVE-2022-3064
CVE-2022-27664 CVE-2022-30629 CVE-2022-30630
CVE-2022-30632 CVE-2022-30635 CVE-2022-32148
CVE-2022-32189 CVE-2022-41715 CVE-2022-41717
=====================================================================

1. Summary:

An update for etcd is now available for Red Hat OpenStack Platform.

Red Hat Product Security has rated this update as having a security impact
of Important. A Common Vulnerability Scoring System (CVSS) base score,
which gives a detailed severity rating, is available for each vulnerability
from the CVE link(s) in the References section.

2. Relevant releases/architectures:

Red Hat OpenStack Platform 16.1 - ppc64le, x86_64
Red Hat OpenStack Platform 16.2 - ppc64le, x86_64

3. Description:

etcd is a highly-available key value store for shared configuration.

The following Important impact security fix(es) are applicable to Red Hat
OpenStack Platform 17.0 (Wallaby), 16.2 (Train), and 16.1 (Train):

* Improve heuristics preventing CPU/memory abuse by parsing malicious or
large YAML documents (CVE-2022-3064)

As a result of being built by golang 1.18.9, the following Moderate impact
security fix(es) are applicable to Red Hat OpenStack Platform 16.2 and
16.1:

* golang: net/http: improper sanitization of Transfer-Encoding header
(CVE-2022-1705)
* golang: net/http/httputil: ReverseProxy should not forward unparseable
query parameters (CVE-2022-2880)
* golang: net/http: handle server errors after sending GOAWAY
(CVE-2022-27664)
* golang: io/fs: stack exhaustion in Glob (CVE-2022-30630)
* golang: path/filepath: stack exhaustion in Glob (CVE-2022-30632)
* golang: encoding/gob: stack exhaustion in Decoder.Decode (CVE-2022-30635)
* golang: net/http/httputil: NewSingleHostReverseProxy - omit
X-Forwarded-For not working (CVE-2022-32148)
* golang: regexp/syntax: limit memory used by parsing regexps
(CVE-2022-41715)
* golang: net/http: An attacker can cause excessive memory growth in a Go
server accepting HTTP/2 requests (CVE-2022-41717)

As a result of being built by golang 1.18.9, the following Low impact
security fix(es) are applicable to Red Hat OpenStack Platform 16.2 and
16.1:

* golang: crypto/tls: session tickets lack random ticket_age_add
(CVE-2022-30629)
* golang: math/big: decoding big.Float and big.Rat types can panic if the
encoded message is too short, potentially allowing a denial of service
(CVE-2022-32189)

For more details about the security issue(s), including the impact, a CVSS
score, acknowledgments, and other related information, refer to the CVE
page listed in the References section.

4. Solution:

Before applying this update, make sure all previously released errata
relevant to your system have been applied.

For details on how to apply this update, refer to:

  https://access.redhat.com/articles/11258

5. Bugs fixed (  https://bugzilla.redhat.com/):

2092793 - CVE-2022-30629 golang: crypto/tls: session tickets lack random ticket_age_add
2107371 - CVE-2022-30630 golang: io/fs: stack exhaustion in Glob
2107374 - CVE-2022-1705 golang: net/http: improper sanitization of Transfer-Encoding header
2107383 - CVE-2022-32148 golang: net/http/httputil: NewSingleHostReverseProxy - omit X-Forwarded-For not working
2107386 - CVE-2022-30632 golang: path/filepath: stack exhaustion in Glob
2107388 - CVE-2022-30635 golang: encoding/gob: stack exhaustion in Decoder.Decode
2113814 - CVE-2022-32189 golang: math/big: decoding big.Float and big.Rat types can panic if the encoded message is too short, potentially allowing a denial of service
2124669 - CVE-2022-27664 golang: net/http: handle server errors after sending GOAWAY
2132868 - CVE-2022-2880 golang: net/http/httputil: ReverseProxy should not forward unparseable query parameters
2132872 - CVE-2022-41715 golang: regexp/syntax: limit memory used by parsing regexps
2161274 - CVE-2022-41717 golang: net/http: An attacker can cause excessive memory growth in a Go server accepting HTTP/2 requests
2163037 - CVE-2022-3064 go-yaml: Improve heuristics preventing CPU/memory abuse by parsing malicious or large YAML documents

6. Package List:

Red Hat OpenStack Platform 16.1:

Source:
etcd-3.3.23-12.el8ost.src.rpm

ppc64le:
etcd-3.3.23-12.el8ost.ppc64le.rpm
etcd-debuginfo-3.3.23-12.el8ost.ppc64le.rpm
etcd-debugsource-3.3.23-12.el8ost.ppc64le.rpm

x86_64:
etcd-3.3.23-12.el8ost.x86_64.rpm
etcd-debuginfo-3.3.23-12.el8ost.x86_64.rpm
etcd-debugsource-3.3.23-12.el8ost.x86_64.rpm

Red Hat OpenStack Platform 16.2:

Source:
etcd-3.3.23-12.el8ost.src.rpm

ppc64le:
etcd-3.3.23-12.el8ost.ppc64le.rpm
etcd-debuginfo-3.3.23-12.el8ost.ppc64le.rpm
etcd-debugsource-3.3.23-12.el8ost.ppc64le.rpm

x86_64:
etcd-3.3.23-12.el8ost.x86_64.rpm
etcd-debuginfo-3.3.23-12.el8ost.x86_64.rpm
etcd-debugsource-3.3.23-12.el8ost.x86_64.rpm

These packages are GPG signed by Red Hat for security. Our key and
details on how to verify the signature are available from
  https://access.redhat.com/security/team/key/

7. References:

  https://access.redhat.com/security/cve/CVE-2022-1705
  https://access.redhat.com/security/cve/CVE-2022-2880
  https://access.redhat.com/security/cve/CVE-2022-3064
  https://access.redhat.com/security/cve/CVE-2022-27664
  https://access.redhat.com/security/cve/CVE-2022-30629
  https://access.redhat.com/security/cve/CVE-2022-30630
  https://access.redhat.com/security/cve/CVE-2022-30632
  https://access.redhat.com/security/cve/CVE-2022-30635
  https://access.redhat.com/security/cve/CVE-2022-32148
  https://access.redhat.com/security/cve/CVE-2022-32189
  https://access.redhat.com/security/cve/CVE-2022-41715
  https://access.redhat.com/security/cve/CVE-2022-41717
  https://access.redhat.com/security/updates/classification/#important

8. Contact:

The Red Hat security contact is . More contact
details at   https://access.redhat.com/security/team/contact/

Copyright 2023 Red Hat, Inc.