Ubuntu 6347 Published by

Updated Request Tracker packages has been released for Ubuntu Linux 18.04, 20.04 LTS, 22.04, 23.04, and 23.10.



[USN-6529-1] Request Tracker vulnerabilities


==========================================================================
Ubuntu Security Notice USN-6529-1
December 04, 2023

request-tracker4 vulnerabilities
==========================================================================

A security issue affects these releases of Ubuntu and its derivatives:

- Ubuntu 23.10
- Ubuntu 23.04
- Ubuntu 22.04 LTS
- Ubuntu 20.04 LTS
- Ubuntu 18.04 LTS (Available with Ubuntu Pro)

Summary:

Several security issues were fixed in Request Tracker.

Software Description:
- request-tracker4: An enterprise-grade issue tracking system

Details:

It was discovered that Request Tracker incorrectly handled certain inputs. If
a user or an automated system were tricked into opening a specially crafted
input file, a remote attacker could possibly use this issue to obtain
sensitive information. (CVE-2021-38562, CVE-2022-25802, CVE-2023-41259,
CVE-2023-41260)

Update instructions:

The problem can be corrected by updating your system to the following
package versions:

Ubuntu 23.10:
request-tracker4 4.4.4+dfsg-2ubuntu1.23.10.1
rt4-apache2 4.4.4+dfsg-2ubuntu1.23.10.1
rt4-clients 4.4.4+dfsg-2ubuntu1.23.10.1
rt4-db-mysql 4.4.4+dfsg-2ubuntu1.23.10.1
rt4-db-postgresql 4.4.4+dfsg-2ubuntu1.23.10.1
rt4-db-sqlite 4.4.4+dfsg-2ubuntu1.23.10.1
rt4-fcgi 4.4.4+dfsg-2ubuntu1.23.10.1
rt4-standalone 4.4.4+dfsg-2ubuntu1.23.10.1

Ubuntu 23.04:
request-tracker4 4.4.4+dfsg-2ubuntu1.23.04.1
rt4-apache2 4.4.4+dfsg-2ubuntu1.23.04.1
rt4-clients 4.4.4+dfsg-2ubuntu1.23.04.1
rt4-db-mysql 4.4.4+dfsg-2ubuntu1.23.04.1
rt4-db-postgresql 4.4.4+dfsg-2ubuntu1.23.04.1
rt4-db-sqlite 4.4.4+dfsg-2ubuntu1.23.04.1
rt4-fcgi 4.4.4+dfsg-2ubuntu1.23.04.1
rt4-standalone 4.4.4+dfsg-2ubuntu1.23.04.1

Ubuntu 22.04 LTS:
request-tracker4 4.4.4+dfsg-2ubuntu1.22.04.1
rt4-apache2 4.4.4+dfsg-2ubuntu1.22.04.1
rt4-clients 4.4.4+dfsg-2ubuntu1.22.04.1
rt4-db-mysql 4.4.4+dfsg-2ubuntu1.22.04.1
rt4-db-postgresql 4.4.4+dfsg-2ubuntu1.22.04.1
rt4-db-sqlite 4.4.4+dfsg-2ubuntu1.22.04.1
rt4-fcgi 4.4.4+dfsg-2ubuntu1.22.04.1
rt4-standalone 4.4.4+dfsg-2ubuntu1.22.04.1

Ubuntu 20.04 LTS:
request-tracker4 4.4.3-2+deb10u3build0.20.04.1
rt4-apache2 4.4.3-2+deb10u3build0.20.04.1
rt4-clients 4.4.3-2+deb10u3build0.20.04.1
rt4-db-mysql 4.4.3-2+deb10u3build0.20.04.1
rt4-db-postgresql 4.4.3-2+deb10u3build0.20.04.1
rt4-db-sqlite 4.4.3-2+deb10u3build0.20.04.1
rt4-fcgi 4.4.3-2+deb10u3build0.20.04.1
rt4-standalone 4.4.3-2+deb10u3build0.20.04.1

Ubuntu 18.04 LTS (Available with Ubuntu Pro):
request-tracker4 4.4.2-2ubuntu0.1~esm1
rt4-apache2 4.4.2-2ubuntu0.1~esm1
rt4-clients 4.4.2-2ubuntu0.1~esm1
rt4-db-mysql 4.4.2-2ubuntu0.1~esm1
rt4-db-postgresql 4.4.2-2ubuntu0.1~esm1
rt4-db-sqlite 4.4.2-2ubuntu0.1~esm1
rt4-fcgi 4.4.2-2ubuntu0.1~esm1
rt4-standalone 4.4.2-2ubuntu0.1~esm1

In general, a standard system update will make all the necessary changes.

References:
https://ubuntu.com/security/notices/USN-6529-1
CVE-2021-38562, CVE-2022-25802, CVE-2023-41259, CVE-2023-41260

Package Information:
https://launchpad.net/ubuntu/+source/request-tracker4/4.4.4+dfsg-2ubuntu1.23.10.1
https://launchpad.net/ubuntu/+source/request-tracker4/4.4.4+dfsg-2ubuntu1.23.04.1
https://launchpad.net/ubuntu/+source/request-tracker4/4.4.4+dfsg-2ubuntu1.22.04.1

https://launchpad.net/ubuntu/+source/request-tracker4/4.4.3-2+deb10u3build0.20.04.1