Debian 10025 Published by

The following security updates are available for Debian GNU/Linux:

ELA-1039-1 postfix security update
[DLA 3728-1] openjdk-11 security update
[DLA 3727-1] firefox-esr security update
[DLA 3730-1] python-asyncssh security update
[DLA 3729-1] debian-security-support security update
ELA-1040-1 xorg-server security update




ELA-1039-1 postfix security update

Package : postfix
Version : 2.11.3-1+deb8u3 (jessie), 3.1.15-0+deb9u2 (stretch)

Related CVEs :
CVE-2023-51764

Postfix, a popular mail server, was vulnerable.
Postfix allowed SMTP smuggling unless configured with
smtpd_data_restrictions=reject_unauth_pipelining and
smtpd_discard_ehlo_keywords=chunking.
Remote attackers can use a published exploitation technique
to inject e-mail messages with a spoofed MAIL FROM address, allowing bypass
of an SPF protection mechanism.
This occurs because Postfix supports . but some other popular e-mail servers do not.
To prevent attack variants (by always disallowing without ),
a different solution is required, such as using the backported smtpd_forbid_bare_newline=yes option.

ELA-1039-1 postfix security update


[DLA 3728-1] openjdk-11 security update


- -------------------------------------------------------------------------
Debian LTS Advisory DLA-3728-1 debian-lts@lists.debian.org
https://www.debian.org/lts/security/ Emilio Pozuelo Monfort
January 31, 2024 https://wiki.debian.org/LTS
- -------------------------------------------------------------------------

Package : openjdk-11
Version : 11.0.22+7-1~deb10u1
CVE ID : CVE-2024-20918 CVE-2024-20919 CVE-2024-20921 CVE-2024-20926
CVE-2024-20945 CVE-2024-20952

Several vulnerabilities have been discovered in the OpenJDK Java runtime,
which may result in side channel attacks, leaking sensitive data to log
files, denial of service or bypass of sandbox restrictions.

For Debian 10 buster, these problems have been fixed in version
11.0.22+7-1~deb10u1.

We recommend that you upgrade your openjdk-11 packages.

For the detailed security status of openjdk-11 please refer to
its security tracker page at:
https://security-tracker.debian.org/tracker/openjdk-11

Further information about Debian LTS security advisories, how to apply
these updates to your system and frequently asked questions can be
found at: https://wiki.debian.org/LTS



[DLA 3727-1] firefox-esr security update


- -------------------------------------------------------------------------
Debian LTS Advisory DLA-3727-1 debian-lts@lists.debian.org
https://www.debian.org/lts/security/ Emilio Pozuelo Monfort
January 31, 2024 https://wiki.debian.org/LTS
- -------------------------------------------------------------------------

Package : firefox-esr
Version : 115.7.0esr-1~deb10u1
CVE ID : CVE-2024-0741 CVE-2024-0742 CVE-2024-0746 CVE-2024-0747
CVE-2024-0749 CVE-2024-0750 CVE-2024-0751 CVE-2024-0753
CVE-2024-0755

Multiple security issues have been found in the Mozilla Firefox web
browser, which could potentially result in the execution of arbitrary
code, phishing, clickjacking, privilege escalation, HSTS bypass or
bypass of content security policies.

For Debian 10 buster, these problems have been fixed in version
115.7.0esr-1~deb10u1.

We recommend that you upgrade your firefox-esr packages.

For the detailed security status of firefox-esr please refer to
its security tracker page at:
https://security-tracker.debian.org/tracker/firefox-esr

Further information about Debian LTS security advisories, how to apply
these updates to your system and frequently asked questions can be
found at: https://wiki.debian.org/LTS



[DLA 3730-1] python-asyncssh security update


-------------------------------------------------------------------------
Debian LTS Advisory DLA-3730-1                debian-lts@lists.debian.org
https://www.debian.org/lts/security/                       Daniel Leidert
February 01, 2024                             https://wiki.debian.org/LTS
-------------------------------------------------------------------------

Package        : python-asyncssh
Version        : 1.12.2-1+deb10u1
CVE ID         : CVE-2023-48795
Debian Bug     : 1059007

AsyncSSH is a Python package which provides an asynchronous client and server
implementation of the SSHv2 protocol. It has been discovered that it is also
vulnerable to a prefix truncation attack, better known as Terrapin attack. 

For Debian 10 buster, this problem has been fixed in version
1.12.2-1+deb10u1.

We recommend that you upgrade your python-asyncssh packages.

For the detailed security status of python-asyncssh please refer to
its security tracker page at:
https://security-tracker.debian.org/tracker/python-asyncssh

Further information about Debian LTS security advisories, how to apply
these updates to your system and frequently asked questions can be
found at: https://wiki.debian.org/LTS



[DLA 3729-1] debian-security-support security update


-------------------------------------------------------------------------
Debian LTS Advisory DLA-3729-1 debian-lts@lists.debian.org
https://www.debian.org/lts/security/ Holger Levsen
January 31, 2024 https://wiki.debian.org/LTS
-------------------------------------------------------------------------

Package : debian-security-support
Version : 1:10+2024.01.31

debian-security-support, the Debian security support coverage checker, has been
updated in buster-security to mark the end of life of the following package:

* salt: see MR: debian/debian-security-support!22

Additionally another package has now been marked with limited support:

* tiles: see https://bugs.debian.org/#1057343

For Debian 10 buster, this problem has been fixed in version 1:10+2024.01.31.

We recommend that you upgrade your debian-security-support packages.

For the detailed security status of debian-security-support please refer to
its security tracker page at:
https://security-tracker.debian.org/tracker/debian-security-support

Further information about Debian LTS security advisories, how to apply
these updates to your system and frequently asked questions can be
found at: https://wiki.debian.org/LTS



ELA-1040-1 xorg-server security update

Package : xorg-server
Version : 2:1.19.2-1+deb9u18 (stretch)

Related CVEs :
CVE-2023-6816
CVE-2024-0229
CVE-2024-0408
CVE-2024-0409
CVE-2024-21885
CVE-2024-21886

Several vulnerabilities were discovered in the Xorg X server, which may
result in privilege escalation if the X server is running privileged
or denial of service.

ELA-1040-1 xorg-server security update