Fedora Linux 8640 Published by

Remi Collet has released PHP 8.0.30, 8.1.22, and 8.2.9 packages for Linux distributions based on Fedora and RHEL.



PHP version 8.0.30, 8.1.22 and 8.2.9

RPMs of PHP version 8.2.9 are available in remi-modular repository for Fedora ≥ 36 and Enterprise Linux ≥ 8 (RHEL, Alma, CentOS, Rocky...) and in remi-php82 repository for EL 7.

RPMs of PHP version 8.1.22 are available in remi-modular repository for Fedora ≥ 36 and Enterprise Linux ≥ 8 (RHEL, Alma, CentOS, Rocky...) and in remi-php81 repository for EL 7.

RPMs of PHP version 8.0.30 are available in remi-modular repository for Fedora ≥ 36 and Enterprise Linux ≥ 8 (RHEL, Alma, CentOS, Rocky...) and in remi-php80 repository for EL 7.

The modules for EL-9 are available for x86_64 and aarch64.

  PHP version 7.4 have reached its end of life and is no longer maintained by the  PHP project.

These versions are also available as Software Collections in the remi-safe repository.

These Versions fix 2 security bugs, so update is strongly recommended.

Version announcements:

Installation: use the  Configuration Wizard and choose your version and installation mode.

Replacement of default PHP by version 8.2 installation (simplest):

dnf module reset php
dnf module enable php:remi-8.2
dnf update php\*

or, the old EL-7 way:

yum-config-manager --enable remi-php82
yum update

Parallel installation of version 8.2 as  Software Collection

yum install php82

Replacement of default PHP by version 8.1 installation (simplest):

dnf module reset php
dnf module enable php:remi-8.1
dnf update php\*

or, the old EL-7 way:

yum-config-manager --enable remi-php81
yum update php\*

Parallel installation of version 8.1 as  Software Collection

yum install php81

And soon in the official updates:

To be noticed :

  • EL-9 RPMs are build using RHEL-9.2
  • EL-8 RPMs are build using RHEL-8.8
  • EL-7 RPMs are build using RHEL-7.9
  • intl extension now uses libicu72 (version 72.1)
  • mbstring extension (EL builds) now uses oniguruma5php (version 6.9.8, instead of the outdated system library)
  • oci8 extension now uses Oracle Client version 21.10
  • a lot of extensions are also available, see the  PHP extensions RPM status (from PECL and other sources) page

Information:

Gnome_shell_screenshot_09fnu0

PHP version 8.0.30, 8.1.22 and 8.2.9