Debian 10031 Published by

An osslsigncode security update has been released for Debian GNU/Linux 10 LTS to address a buffer overflow vulnerability.



[DLA 3693-1] osslsigncode security update

-------------------------------------------------------------------------
Debian LTS Advisory DLA-3693-1 debian-lts@lists.debian.org
https://www.debian.org/lts/security/ Tobias Frost
December 23, 2023 https://wiki.debian.org/LTS
-------------------------------------------------------------------------

Package : osslsigncode
Version : 2.0+really2.5-4+deb10u1
CVE ID : CVE-2023-36377
Debian Bug : 1035875

A Buffer Overflow vulnerability has been found in osslsigncode, a
OpenSSL based Authenticode signing tool for PE/MSI/Java CAB files, which
possibly allows an malicious attacker to execute arbitrary code when
signing a crafted file.

For Debian 10 buster, this problem has been fixed in version
2.0+really2.5-4+deb10u1.

We recommend that you upgrade your osslsigncode packages.

For the detailed security status of osslsigncode please refer to
its security tracker page at:
https://security-tracker.debian.org/tracker/osslsigncode

Further information about Debian LTS security advisories, how to apply
these updates to your system and frequently asked questions can be
found at: https://wiki.debian.org/LTS