SUSE 5037 Published by

The following updates are available for SUSE:

openSUSE-SU-2024:0122-1: important: Security update for opera
openSUSE-SU-2024:0125-1: important: Security update for python-Pillow




openSUSE-SU-2024:0122-1: important: Security update for opera


openSUSE Security Update: Security update for opera
_______________________________

Announcement ID: openSUSE-SU-2024:0122-1
Rating: important
References:
Cross-References: CVE-2024-2883 CVE-2024-2885 CVE-2024-2886
CVE-2024-2887
Affected Products:
openSUSE Leap 15.6:NonFree
_______________________________

An update that fixes four vulnerabilities is now available.

Description:

Opera was updated to fix the following issues:

Update to 109.0.5097.45

* CHR-9416 Updating Chromium on desktop-stable-* branches
* DNA-114737 [Search box] It's getting blurred when click
on it, also lower corners are not rounded sometimes
* DNA-115042 '+' button is not responsive when 30+ tabs opened
* DNA-115326 Wrong fonts and padding after intake
* DNA-115392 [Badges] Text displayed in red
* DNA-115501 'Review your payment' native popup has wrong colors
* DNA-115809 Enable #show-duplicate-indicator-on-link on all streams

Update to 109.0.5097.38

* CHR-9695 Update Chromium on desktop-stable-123-5097 to 123.0.6312.87
* DNA-115156 [Login and Password suggestion] Suggestions are bolded and
highlight doesn`t fill all area
* DNA-115313 No video playback on skyshowtime.com
* DNA-115639 [Version 109][Detached window] Missing functions names in
light mode
* DNA-115812 Enable #startpage-opening-animation on all streams
* DNA-115836 Lucid mode visual issues on H264 videos
- The update to chromium 109.0.5097.38 fixes following issues:
CVE-2024-2883, CVE-2024-2885, CVE-2024-2886, CVE-2024-2887

Update to 109.0.5097.33

* CHR-9674 Update Chromium on desktop-stable-123-5097 to 123.0.6312.46
* DNA-115357 [Settings] Search toolbar has wrong position
* DNA-115396 Bolded camera icon when camera access is allowed
* DNA-115478 AI Prompts in text highlight popup not displayed properly
* DNA-115563 Wallet selector not working
* DNA-115601 Remove 'moving text' animation in the tab cycler
* DNA-115645 Internal pages icons unreadable when highlight
* DNA-115717 'Your extension was disabled because it is corrupted'
message is displayed to user
* DNA-115770 Promote 109 to stable
- Complete Opera 109 changelog at:
https://blogs.opera.com/desktop/changelog-for-109/

Patch Instructions:

To install this openSUSE Security Update use the SUSE recommended installation methods
like YaST online_update or "zypper patch".

Alternatively you can run the command listed for your product:

- openSUSE Leap 15.6:NonFree:

zypper in -t patch openSUSE-2024-122=1

Package List:

- openSUSE Leap 15.6:NonFree (x86_64):

opera-109.0.5097.45-lp156.2.3.1

References:

https://www.suse.com/security/cve/CVE-2024-2883.html
https://www.suse.com/security/cve/CVE-2024-2885.html
https://www.suse.com/security/cve/CVE-2024-2886.html
https://www.suse.com/security/cve/CVE-2024-2887.html



openSUSE-SU-2024:0125-1: important: Security update for python-Pillow


openSUSE Security Update: Security update for python-Pillow
_______________________________

Announcement ID: openSUSE-SU-2024:0125-1
Rating: important
References: #1219048
Cross-References: CVE-2023-50447
CVSS scores:
CVE-2023-50447 (NVD) : 8.1 CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H
CVE-2023-50447 (SUSE): 8.4 CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Affected Products:
openSUSE Backports SLE-15-SP5
_______________________________

An update that fixes one vulnerability is now available.

Description:

This update for python-Pillow fixes the following issues:

- CVE-2023-50447: Fixed arbitrary code execution via the environment
parameter (boo#1219048)

Patch Instructions:

To install this openSUSE Security Update use the SUSE recommended installation methods
like YaST online_update or "zypper patch".

Alternatively you can run the command listed for your product:

- openSUSE Backports SLE-15-SP5:

zypper in -t patch openSUSE-2024-125=1

Package List:

- openSUSE Backports SLE-15-SP5 (aarch64 i586 ppc64le s390x x86_64):

python3-Pillow-8.4.0-bp155.3.3.1
python3-Pillow-tk-8.4.0-bp155.3.3.1

References:

https://www.suse.com/security/cve/CVE-2023-50447.html
https://bugzilla.suse.com/1219048