SUSE 5044 Published by

An exim security update has been released for SUSE Linux Enterprise 15 SP4.



openSUSE-SU-2023:0304-1: critical: Security update for exim


openSUSE Security Update: Security update for exim
_______________________________

Announcement ID: openSUSE-SU-2023:0304-1
Rating: critical
References: #1215787 #1215789
Cross-References: CVE-2023-42117 CVE-2023-42119
Affected Products:
openSUSE Backports SLE-15-SP4
_______________________________

An update that fixes two vulnerabilities is now available.

Description:

This update for exim fixes the following issues:

- CVE-2023-42117: Fixes Improper Neutralization of Special Elements Remote
Code Execution Vulnerability (boo#1215787)
- CVE-2023-42119: Fixes dnsdb Out-Of-Bounds Read Information Disclosure
Vulnerability (boo#1215789)

Patch Instructions:

To install this openSUSE Security Update use the SUSE recommended installation methods
like YaST online_update or "zypper patch".

Alternatively you can run the command listed for your product:

- openSUSE Backports SLE-15-SP4:

zypper in -t patch openSUSE-2023-304=1

Package List:

- openSUSE Backports SLE-15-SP4 (aarch64 ppc64le s390x x86_64):

exim-4.94.2-bp154.2.9.1
eximon-4.94.2-bp154.2.9.1
eximstats-html-4.94.2-bp154.2.9.1

References:

https://www.suse.com/security/cve/CVE-2023-42117.html
https://www.suse.com/security/cve/CVE-2023-42119.html
https://bugzilla.suse.com/1215787
https://bugzilla.suse.com/1215789