SUSE 5000 Published by

A zabbix security update has been released for SUSE Linux Enterprise 15 SP4/5.



openSUSE-SU-2023:0191-1: moderate: Security update for zabbix


openSUSE Security Update: Security update for zabbix
_______________________________

Announcement ID: openSUSE-SU-2023:0191-1
Rating: moderate
References: #1213338
Cross-References: CVE-2023-29454
CVSS scores:
CVE-2023-29454 (NVD) : 5.4 CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:U/C:H/I:L/A:N

Affected Products:
openSUSE Backports SLE-15-SP4
openSUSE Backports SLE-15-SP5
_______________________________

An update that fixes one vulnerability is now available.

Description:

This update for zabbix fixes the following issues:

Updated to latest release 4.0.47, this version fixes CVE-2023-29454
(boo#1213338):

- New Features and Improvements
+ ZBXNEXT-7694 Added "utf8mb3" character set support for MySQL database
+ ZBX-20946 Enabled Bulgarian, Chinese (zh_TW), German, Greek,
Indonesian, Romanian, Spanish and Vietnamese languages in frontend
- Bug Fixes
+ ZBX-22987 Fixed inefficient URL schema validation
+ ZBX-22688 Fixed AlertScriptPath not allowing links
+ ZBX-22386 Fixed encoding of HTML entities in the user interface
+ ZBX-22858 Fixed xss vulnerability in graph item properties
+ ZBX-22859 Fixed validation of input parameters in action configuration
form
+ ZBX-22622 Fixed alert script path validation
+ ZBX-22520 Fixed versions of integrations
+ ZBX-22026 Fixed SNMP agent item going to unsupported state on NULL
result
+ ZBX-22050 Fixed spoofing X-Forwarded-For request header allowing to
access Zabbix frontend in maintenance mode
+ ZBX-21416 Fixed check now not working on calculated items, aggregate
checks and some internal items
+ ZBX-21449 Fixed accessibility attributes
+ ZBX-21306 Fixed xss in discovery rules
+ ZBX-21305 Fixed xss in graph
+ ZBX-20600 Fixed vmware hv.datastore.latency item when multiple
datastores with duplicate name
+ ZBX-20844 Fixed external check becoming unsupported when Zabbix server
or Zabbix proxy is stopped
+ ZBX-19789 Added SourceIP support to ldap simple checks
+ ZBX-20680 Fixed reflected XSS issues
+ ZBX-20387 Fixed default language of the setup routine for logged in
superadmin users
+ ZBX-19652 Fixed JavaScript syntax for Internet Explorer 11
compatibility

Patch Instructions:

To install this openSUSE Security Update use the SUSE recommended installation methods
like YaST online_update or "zypper patch".

Alternatively you can run the command listed for your product:

- openSUSE Backports SLE-15-SP5:

zypper in -t patch openSUSE-2023-191=1

- openSUSE Backports SLE-15-SP4:

zypper in -t patch openSUSE-2023-191=1

Package List:

- openSUSE Backports SLE-15-SP5 (aarch64 i586 ppc64le s390x x86_64):

zabbix-agent-4.0.47-bp155.3.3.1
zabbix-agent-debuginfo-4.0.47-bp155.3.3.1
zabbix-debuginfo-4.0.47-bp155.3.3.1
zabbix-debugsource-4.0.47-bp155.3.3.1
zabbix-java-gateway-4.0.47-bp155.3.3.1
zabbix-phpfrontend-4.0.47-bp155.3.3.1
zabbix-proxy-4.0.47-bp155.3.3.1
zabbix-proxy-mysql-4.0.47-bp155.3.3.1
zabbix-proxy-mysql-debuginfo-4.0.47-bp155.3.3.1
zabbix-proxy-postgresql-4.0.47-bp155.3.3.1
zabbix-proxy-postgresql-debuginfo-4.0.47-bp155.3.3.1
zabbix-proxy-sqlite-4.0.47-bp155.3.3.1
zabbix-proxy-sqlite-debuginfo-4.0.47-bp155.3.3.1
zabbix-server-4.0.47-bp155.3.3.1
zabbix-server-debuginfo-4.0.47-bp155.3.3.1
zabbix-server-mysql-4.0.47-bp155.3.3.1
zabbix-server-mysql-debuginfo-4.0.47-bp155.3.3.1
zabbix-server-postgresql-4.0.47-bp155.3.3.1
zabbix-server-postgresql-debuginfo-4.0.47-bp155.3.3.1

- openSUSE Backports SLE-15-SP4 (aarch64 i586 ppc64le s390x x86_64):

zabbix-agent-4.0.47-bp154.2.3.1
zabbix-java-gateway-4.0.47-bp154.2.3.1
zabbix-phpfrontend-4.0.47-bp154.2.3.1
zabbix-proxy-4.0.47-bp154.2.3.1
zabbix-proxy-mysql-4.0.47-bp154.2.3.1
zabbix-proxy-postgresql-4.0.47-bp154.2.3.1
zabbix-proxy-sqlite-4.0.47-bp154.2.3.1
zabbix-server-4.0.47-bp154.2.3.1
zabbix-server-mysql-4.0.47-bp154.2.3.1
zabbix-server-postgresql-4.0.47-bp154.2.3.1

References:

https://www.suse.com/security/cve/CVE-2023-29454.html
https://bugzilla.suse.com/1213338