Gentoo 2477 Published by

The following two security updates are available for Gentoo Linux:

[ GLSA 202401-23 ] libuv: Buffer Overread
[ GLSA 202401-24 ] Nettle: Denial of Service




[ GLSA 202401-23 ] libuv: Buffer Overread


- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory GLSA 202401-23
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
https://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Severity: Low
Title: libuv: Buffer Overread
Date: January 16, 2024
Bugs: #800986
ID: 202401-23

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
========

A buffer overread vulnerability has been found in libuv.

Background
==========

libuv is a multi-platform support library with a focus on asynchronous
I/O.

Affected packages
=================

Package Vulnerable Unaffected
-------------- ------------ ------------
dev-libs/libuv < 1.41.1 >= 1.41.1

Description
===========

libuv fails to ensure that a pointer lies within the bounds of a defined
buffer in the uv__idna_toascii() function before reading and
manipulating the memory at that address.

Impact
======

The overread can result in information disclosure or application crash.

Workaround
==========

There is no known workaround at this time.

Resolution
==========

All libuv users should upgrade to the latest version:

# emerge --sync
# emerge --ask --oneshot --verbose ">=dev-libs/libuv-1.41.1"

References
==========

[ 1 ] CVE-2021-22918
https://nvd.nist.gov/vuln/detail/CVE-2021-22918

Availability
============

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

https://security.gentoo.org/glsa/202401-23

Concerns?
=========

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users' machines is of utmost
importance to us. Any security concerns should be addressed to
security@gentoo.org or alternatively, you may file a bug at
https://bugs.gentoo.org.

License
=======

Copyright 2024 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

https://creativecommons.org/licenses/by-sa/2.5



[ GLSA 202401-24 ] Nettle: Denial of Service


- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory GLSA 202401-24
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
https://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Severity: Normal
Title: Nettle: Denial of Service
Date: January 16, 2024
Bugs: #806839, #907673
ID: 202401-24

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
========

Multiple denial of service vulnerabilities have been discovered in
Nettle.

Background
==========

Nettle is a cryptographic library that is designed to fit easily in
almost any context: In cryptographic toolkits for object-oriented
languages, such as C++, Python, or Pike, in applications like lsh or
GnuPG, or even in kernel space.

Affected packages
=================

Package Vulnerable Unaffected
--------------- ------------ ------------
dev-libs/nettle < 3.9.1 >= 3.9.1

Description
===========

Multiple vulnerabilities have been discovered in Nettle. Please review
the CVE identifiers referenced below for details.

Impact
======

A flaw was found in the way nettle's RSA decryption functions handled
specially crafted ciphertext. An attacker could use this flaw to provide
a manipulated ciphertext leading to application crash and denial of
service.

Workaround
==========

There is no known workaround at this time.

Resolution
==========

All Nettle users should upgrade to the latest version:

# emerge --sync
# emerge --ask --oneshot --verbose ">=dev-libs/nettle-3.9.1"

References
==========

[ 1 ] CVE-2021-3580
https://nvd.nist.gov/vuln/detail/CVE-2021-3580
[ 2 ] CVE-2023-36660
https://nvd.nist.gov/vuln/detail/CVE-2023-36660

Availability
============

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

https://security.gentoo.org/glsa/202401-24

Concerns?
=========

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users' machines is of utmost
importance to us. Any security concerns should be addressed to
security@gentoo.org or alternatively, you may file a bug at
https://bugs.gentoo.org.

License
=======

Copyright 2024 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

https://creativecommons.org/licenses/by-sa/2.5