Debian 9956 Published by

Updated ncurses and webkit2gtk updates are available for Debian GNU/Linux:

ELA-1022-1 ncurses security update
[DSA 5580-1] webkit2gtk security update




ELA-1022-1 ncurses security update

Package : ncurses
Version : 5.9+20140913-1+deb8u6 (jessie), 6.0+20161126-1+deb9u5 (stretch)

Related CVEs :
CVE-2023-29491

Loading of custom terminfo entries in setuid/setgid programs has been disabled to mitigate memory corruption via malformed data in terminfo database files.

ELA-1022-1 ncurses security update


[DSA 5580-1] webkit2gtk security update


- -------------------------------------------------------------------------
Debian Security Advisory DSA-5580-1 security@debian.org
https://www.debian.org/security/ Alberto Garcia
December 18, 2023 https://www.debian.org/security/faq
- -------------------------------------------------------------------------

Package : webkit2gtk
CVE ID : CVE-2023-42883

The following vulnerabilities have been discovered in the WebKitGTK
web engine:

CVE-2023-42883

The Zoom Offensive Security Team discovered that processing a SVG
image may lead to a denial-of-service.

For the oldstable distribution (bullseye), this problem has been fixed
in version 2.42.4-1~deb11u1.

For the stable distribution (bookworm), this problem has been fixed in
version 2.42.4-1~deb12u1.

We recommend that you upgrade your webkit2gtk packages.

For the detailed security status of webkit2gtk please refer to
its security tracker page at:
https://security-tracker.debian.org/tracker/webkit2gtk

Further information about Debian Security Advisories, how to apply
these updates to your system and frequently asked questions can be
found at: https://www.debian.org/security/