Gentoo 2495 Published by

A wpa_supplicant, hostapd security update has been released for Gentoo Linux.



[ GLSA 202309-16 ] wpa_supplicant, hostapd: Multiple Vulnerabilities


- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory GLSA 202309-16
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
https://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Severity: Normal
Title: wpa_supplicant, hostapd: Multiple Vulnerabilities
Date: September 30, 2023
Bugs: #768759, #780135, #780138, #831332
ID: 202309-16

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
========

Multiple vulnerabilities have been discovered in wpa_supplicant and
hostapd, the worst of which could result in arbitrary code execution.

Background
==========

wpa_supplicant is a WPA Supplicant with support for WPA and WPA2 (IEEE
802.11i / RSN). hostapd is a user space daemon for access point and
authentication servers.

Affected packages
=================

Package Vulnerable Unaffected
--------------------------- ------------ ------------
net-wireless/hostapd < 2.10 >= 2.10
net-wireless/wpa_supplicant < 2.10 >= 2.10

Description
===========

Multiple vulnerabilities have been discovered in hostapd and
wpa_supplicant. Please review the CVE identifiers referenced below for
details.

Impact
======

Please review the referenced CVE identifiers for details.

Workaround
==========

There is no known workaround at this time.

Resolution
==========

All wpa_supplicant users should upgrade to the latest version:

# emerge --sync
# emerge --ask --oneshot --verbose ">=net-wireless/wpa_supplicant-2.10"

All hostapd users should upgrade to the latest version:

# emerge --sync
# emerge --ask --oneshot --verbose ">=net-wireless/hostapd-2.10"

References
==========

[ 1 ] CVE-2021-30004
https://nvd.nist.gov/vuln/detail/CVE-2021-30004
[ 2 ] CVE-2022-23303
https://nvd.nist.gov/vuln/detail/CVE-2022-23303
[ 3 ] CVE-2022-23304
https://nvd.nist.gov/vuln/detail/CVE-2022-23304

Availability
============

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

https://security.gentoo.org/glsa/202309-16

Concerns?
=========

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users' machines is of utmost
importance to us. Any security concerns should be addressed to
security@gentoo.org or alternatively, you may file a bug at
https://bugs.gentoo.org.

License
=======

Copyright 2023 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

https://creativecommons.org/licenses/by-sa/2.5