Gentoo 2399 Published by

A RAR, UnRAR security update has been released for Gentoo Linux.



[ GLSA 202309-04 ] RAR, UnRAR: Arbitrary File Overwrite


- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory GLSA 202309-04
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
https://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Severity: Normal
Title: RAR, UnRAR: Arbitrary File Overwrite
Date: September 17, 2023
Bugs: #843611, #849686, #912652
ID: 202309-04

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
========

An arbitrary file overwrite vulnerability has been discovered in RAR and
UnRAR, potentially resulting in arbitrary code execution.

Background
==========

RAR and UnRAR provide command line interfaces for compressing and
decompressing RAR files.

Affected packages
=================

Package Vulnerable Unaffected
-------------- ------------ ------------
app-arch/rar < 6.23 >= 6.23
app-arch/unrar < 6.2.10 >= 6.2.10

Description
===========

Due to an error in the validation of symbolic links within archives, RAR
and UnRAR can potentially write files to a directory which is outside of
the intended unpack directory.

Impact
======

If the user running RAR or UnRAR extracts a malicious archive, the
archive could overwrite a file such as the user's shell initialization
scripts, potentially resulting in arbitrary code execution in the
context of that user.

Workaround
==========

There is no known workaround at this time.

Resolution
==========

All RAR users should upgrade to the latest version:

# emerge --sync
# emerge --ask --oneshot --verbose ">=app-arch/rar-6.23"

All UnRAR users should upgrade to the latest version:

# emerge --sync
# emerge --ask --oneshot --verbose ">=app-arch/unrar-6.2.10"

References
==========

[ 1 ] CVE-2022-30333
https://nvd.nist.gov/vuln/detail/CVE-2022-30333

[ 2 ] CVE-2023-40477
https://nvd.nist.gov/vuln/detail/CVE-2023-40477

Availability
============

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

https://security.gentoo.org/glsa/202309-04

Concerns?
=========

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users' machines is of utmost
importance to us. Any security concerns should be addressed to
security@gentoo.org or alternatively, you may file a bug at
https://bugs.gentoo.org [4].

License
=======

Copyright 2023 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

https://creativecommons.org/licenses/by-sa/2.5