Debian 9819 Published by

A python-git security update has been released for Debian GNU/Linux 10 LTS to address a possible shell injection due to improper user input validation.



[SECURITY] [DLA 3502-1] python-git security update


- -------------------------------------------------------------------------
Debian LTS Advisory DLA-3502-1 debian-lts@lists.debian.org
https://www.debian.org/lts/security/ Sylvain Beucler
July 25, 2023 https://wiki.debian.org/LTS
- -------------------------------------------------------------------------

Package : python-git
Version : 2.1.11-1+deb10u1
CVE ID : CVE-2022-24439
Debian Bug : 1027163

Sam Wheating discovered that python-git, a Python library to interact
with Git repositories, is vulnerable to shell injection due to
improper user input validation, which makes it possible to inject a
maliciously crafted remote URL into the clone command.

For Debian 10 buster, this problem has been fixed in version
2.1.11-1+deb10u1.

We recommend that you upgrade your python-git packages.

For the detailed security status of python-git please refer to
its security tracker page at:
https://security-tracker.debian.org/tracker/python-git

Further information about Debian LTS security advisories, how to apply
these updates to your system and frequently asked questions can be
found at: https://wiki.debian.org/LTS