AlmaLinux 2249 Published by

A .NET 7.0 security, bug fix, and enhancement update has been released for AlmaLinux 9.



ALSA-2023:4642 Important: .NET 7.0 security, bug fix, and enhancement update


Type:
security

Severity:
important

Release date:
2023-08-15

Description
New versions of .NET that address a security vulnerability are now available. The updated versions are .NET SDK 7.0.110 and .NET Runtime 7.0.10.
Security Fix(es):
* dotnet: RCE under dotnet commands (CVE-2023-35390)
* dotnet: Kestrel vulnerability to slow read attacks leading to Denial of Service attack (CVE-2023-38180)
For more details about the security issue(s), including the impact, a CVSS score, acknowledgments, and other related information, refer to the CVE page(s) listed in the References section.

References:
CVE-2023-35390
CVE-2023-38180
RHSA-2023:4642
ALSA-2023:4642

Updates packages:
dotnet-apphost-pack-7.0-7.0.10-1.el9_2.x86_64.rpm
aspnetcore-targeting-pack-7.0-7.0.10-1.el9_2.aarch64.rpm
dotnet-runtime-7.0-7.0.10-1.el9_2.x86_64.rpm
aspnetcore-targeting-pack-7.0-7.0.10-1.el9_2.x86_64.rpm
dotnet-hostfxr-7.0-7.0.10-1.el9_2.x86_64.rpm
dotnet-targeting-pack-7.0-7.0.10-1.el9_2.s390x.rpm
dotnet-apphost-pack-7.0-7.0.10-1.el9_2.aarch64.rpm
dotnet-hostfxr-7.0-7.0.10-1.el9_2.s390x.rpm
dotnet-sdk-7.0-source-built-artifacts-7.0.110-1.el9_2.s390x.rpm
dotnet-host-7.0.10-1.el9_2.aarch64.rpm
dotnet-runtime-7.0-7.0.10-1.el9_2.ppc64le.rpm
dotnet-host-7.0.10-1.el9_2.ppc64le.rpm
netstandard-targeting-pack-2.1-7.0.110-1.el9_2.ppc64le.rpm
dotnet-sdk-7.0-7.0.110-1.el9_2.x86_64.rpm
dotnet-templates-7.0-7.0.110-1.el9_2.s390x.rpm
dotnet-host-7.0.10-1.el9_2.x86_64.rpm
dotnet-apphost-pack-7.0-7.0.10-1.el9_2.s390x.rpm
netstandard-targeting-pack-2.1-7.0.110-1.el9_2.s390x.rpm
aspnetcore-runtime-7.0-7.0.10-1.el9_2.aarch64.rpm
dotnet-targeting-pack-7.0-7.0.10-1.el9_2.ppc64le.rpm
dotnet-sdk-7.0-7.0.110-1.el9_2.ppc64le.rpm
dotnet-host-7.0.10-1.el9_2.s390x.rpm
dotnet-hostfxr-7.0-7.0.10-1.el9_2.aarch64.rpm
dotnet-sdk-7.0-source-built-artifacts-7.0.110-1.el9_2.ppc64le.rpm
dotnet-templates-7.0-7.0.110-1.el9_2.aarch64.rpm
dotnet-runtime-7.0-7.0.10-1.el9_2.s390x.rpm
dotnet-targeting-pack-7.0-7.0.10-1.el9_2.x86_64.rpm
aspnetcore-runtime-7.0-7.0.10-1.el9_2.s390x.rpm
netstandard-targeting-pack-2.1-7.0.110-1.el9_2.aarch64.rpm
dotnet-sdk-7.0-7.0.110-1.el9_2.s390x.rpm
dotnet-sdk-7.0-source-built-artifacts-7.0.110-1.el9_2.aarch64.rpm
dotnet-hostfxr-7.0-7.0.10-1.el9_2.ppc64le.rpm
dotnet-sdk-7.0-7.0.110-1.el9_2.aarch64.rpm
dotnet-targeting-pack-7.0-7.0.10-1.el9_2.aarch64.rpm
dotnet-apphost-pack-7.0-7.0.10-1.el9_2.ppc64le.rpm
aspnetcore-runtime-7.0-7.0.10-1.el9_2.ppc64le.rpm
dotnet-sdk-7.0-source-built-artifacts-7.0.110-1.el9_2.x86_64.rpm
aspnetcore-runtime-7.0-7.0.10-1.el9_2.x86_64.rpm
aspnetcore-targeting-pack-7.0-7.0.10-1.el9_2.s390x.rpm
netstandard-targeting-pack-2.1-7.0.110-1.el9_2.x86_64.rpm
dotnet-templates-7.0-7.0.110-1.el9_2.ppc64le.rpm
aspnetcore-targeting-pack-7.0-7.0.10-1.el9_2.ppc64le.rpm
dotnet-runtime-7.0-7.0.10-1.el9_2.aarch64.rpm
dotnet-templates-7.0-7.0.110-1.el9_2.x86_64.rpm

Notes:
This page is generated automatically from Red Hat security data and has not been checked for errors. For clarification or corrections please contact the AlmaLinux Packaging Team.

  ALSA-2023:4642 Important: .NET 7.0 security, bug fix, and enhancement update