AlmaLinux 2242 Published by

A: nodejs:16 security, bug fix, and enhancement update has been released for AlmaLinux 8.



ALSA-2023:4537 Moderate: nodejs:16 security, bug fix, and enhancement update


Type:
security

Severity:
moderate

Release date:
2023-08-09

Description
The package has been upgraded to a later upstream version: nodejs (16.20.1). (BZ#2223678, BZ#2223680, BZ#2223682, BZ#2223684, BZ#2223686, BZ#2223688)
Security Fix(es):
* nodejs: mainModule.proto bypass experimental policy mechanism (CVE-2023-30581)
* nodejs: process interuption due to invalid Public Key information in x509 certificates (CVE-2023-30588)
* nodejs: HTTP Request Smuggling via Empty headers separated by CR (CVE-2023-30589)
* nodejs: DiffieHellman do not generate keys after setting a private key (CVE-2023-30590)
For more details about the security issue(s), including the impact, a CVSS score, acknowledgments, and other related information, refer to the CVE page(s) listed in the References section.

References:
CVE-2023-30581
CVE-2023-30588
CVE-2023-30589
CVE-2023-30590
RHSA-2023:4537
ALSA-2023:4537

Updates packages:
nodejs-devel-16.20.1-1.module_el8.8.0+3594+e74fe53f.s390x.rpm
nodejs-16.20.1-1.module_el8.8.0+3594+e74fe53f.ppc64le.rpm
nodejs-full-i18n-16.20.1-1.module_el8.8.0+3594+e74fe53f.ppc64le.rpm
nodejs-devel-16.20.1-1.module_el8.8.0+3594+e74fe53f.aarch64.rpm
npm-8.19.4-1.16.20.1.1.module_el8.8.0+3594+e74fe53f.x86_64.rpm
nodejs-devel-16.20.1-1.module_el8.8.0+3594+e74fe53f.ppc64le.rpm
nodejs-full-i18n-16.20.1-1.module_el8.8.0+3594+e74fe53f.x86_64.rpm
nodejs-16.20.1-1.module_el8.8.0+3594+e74fe53f.x86_64.rpm
nodejs-docs-16.20.1-1.module_el8.8.0+3594+e74fe53f.noarch.rpm
nodejs-16.20.1-1.module_el8.8.0+3594+e74fe53f.aarch64.rpm
nodejs-full-i18n-16.20.1-1.module_el8.8.0+3594+e74fe53f.s390x.rpm
npm-8.19.4-1.16.20.1.1.module_el8.8.0+3594+e74fe53f.ppc64le.rpm
nodejs-full-i18n-16.20.1-1.module_el8.8.0+3594+e74fe53f.aarch64.rpm
npm-8.19.4-1.16.20.1.1.module_el8.8.0+3594+e74fe53f.s390x.rpm
Packages/nodejs-packaging-25-1.module_el8.5.0+2605+45d748af.noarch.rpm
nodejs-16.20.1-1.module_el8.8.0+3594+e74fe53f.s390x.rpm
nodejs-devel-16.20.1-1.module_el8.8.0+3594+e74fe53f.x86_64.rpm
npm-8.19.4-1.16.20.1.1.module_el8.8.0+3594+e74fe53f.aarch64.rpm
nodejs-nodemon-2.0.20-3.module_el8.8.0+3586+d4fc0b72.noarch.rpm

Notes:
This page is generated automatically from Red Hat security data and has not been checked for errors. For clarification or corrections please contact the AlmaLinux Packaging Team.

  ALSA-2023:4537 Moderate: nodejs:16 security, bug fix, and enhancement update