AlmaLinux 2227 Published by

An Image Builder security, bug fix, and enhancement update has been released for AlmaLinux 9.



ALSA-2023:2204 Moderate: Image Builder security, bug fix, and enhancement update


Type:
security

Severity:
moderate

Release date:
2023-05-12

Description
Security Fix(es):
* golang: archive/tar: unbounded memory consumption when reading headers (CVE-2022-2879)
* golang: net/http/httputil: ReverseProxy should not forward unparseable query parameters (CVE-2022-2880)
* golang: net/http: handle server errors after sending GOAWAY (CVE-2022-27664)
* golang: regexp/syntax: limit memory used by parsing regexps (CVE-2022-41715)
* golang: net/http: An attacker can cause excessive memory growth in a Go server accepting HTTP/2 requests (CVE-2022-41717)
For more details about the security issue(s), including the impact, a CVSS score, acknowledgments, and other related information, refer to the CVE page(s) listed in the References section.
Additional Changes:
For detailed information on changes in this release, see the AlmaLinux Release Notes linked from the References section.

References:
RHSA-2023:2204
CVE-2022-27664
CVE-2022-2879
CVE-2022-2880
CVE-2022-41715
CVE-2022-41717
ALSA-2023:2204

Updates packages:
osbuild-composer-core-76-2.el9_2.alma.x86_64.rpm
weldr-client-35.9-1.el9.x86_64.rpm
osbuild-composer-worker-76-2.el9_2.alma.x86_64.rpm
osbuild-composer-76-2.el9_2.alma.x86_64.rpm
osbuild-composer-dnf-json-76-2.el9_2.alma.x86_64.rpm
osbuild-composer-dnf-json-76-2.el9_2.alma.ppc64le.rpm
osbuild-composer-core-76-2.el9_2.alma.ppc64le.rpm
weldr-client-35.9-1.el9.ppc64le.rpm
osbuild-composer-76-2.el9_2.alma.ppc64le.rpm
osbuild-composer-worker-76-2.el9_2.alma.ppc64le.rpm
osbuild-composer-76-2.el9_2.alma.s390x.rpm
weldr-client-35.9-1.el9.s390x.rpm
osbuild-composer-core-76-2.el9_2.alma.s390x.rpm
osbuild-composer-dnf-json-76-2.el9_2.alma.s390x.rpm
osbuild-composer-worker-76-2.el9_2.alma.s390x.rpm
osbuild-composer-worker-76-2.el9_2.alma.aarch64.rpm
osbuild-composer-core-76-2.el9_2.alma.aarch64.rpm
osbuild-composer-76-2.el9_2.alma.aarch64.rpm
weldr-client-35.9-1.el9.aarch64.rpm
osbuild-composer-dnf-json-76-2.el9_2.alma.aarch64.rpm

Notes:
This page is generated automatically from Red Hat security data and has not been checked for errors. For clarification or corrections please contact the AlmaLinux Packaging Team.

  ALSA-2023:2204 Moderate: Image Builder security, bug fix, and enhancement update