AlmaLinux 2227 Published by

A firefox security update has been released for AlmaLinux 8.



ALSA-2023:0808 Important: firefox security update


Type:
security

Severity:
important

Release date:
2023-02-21

Description
This update upgrades Firefox to version 102.8.0 ESR.
Security Fix(es):
* Mozilla: Arbitrary memory write via PKCS 12 in NSS (CVE-2023-0767)
* Mozilla: Content security policy leak in violation reports using iframes (CVE-2023-25728)
* Mozilla: Screen hijack via browser fullscreen mode (CVE-2023-25730)
* Mozilla: Potential use-after-free from compartment mismatch in SpiderMonkey (CVE-2023-25735)
* Mozilla: Invalid downcast in SVGUtils::SetupStrokeGeometry (CVE-2023-25737)
* Mozilla: Use-after-free in mozilla::dom::ScriptLoadContext::~ScriptLoadContext (CVE-2023-25739)
* Mozilla: Fullscreen notification not shown in Firefox Focus (CVE-2023-25743)
* Mozilla: Memory safety bugs fixed in Firefox 110 and Firefox ESR 102.8 (CVE-2023-25744)
* Mozilla: Memory safety bugs fixed in Firefox ESR 102.8 (CVE-2023-25746)
* Mozilla: Extensions could have opened external schemes without user knowledge (CVE-2023-25729)
* Mozilla: Out of bounds memory write from EncodeInputStream (CVE-2023-25732)
* Mozilla: Web Crypto ImportKey crashes tab (CVE-2023-25742)
For more details about the security issue(s), including the impact, a CVSS score, acknowledgments, and other related information, refer to the CVE page(s) listed in the References section.

References:
RHSA-2023:0808
CVE-2023-0767
CVE-2023-25728
CVE-2023-25729
CVE-2023-25730
CVE-2023-25732
CVE-2023-25735
CVE-2023-25737
CVE-2023-25739
CVE-2023-25742
CVE-2023-25743
CVE-2023-25744
CVE-2023-25746
ALSA-2023:0808

Updates packages:
firefox-102.8.0-2.el8_7.alma.aarch64.rpm
firefox-102.8.0-2.el8_7.alma.s390x.rpm
firefox-102.8.0-2.el8_7.alma.ppc64le.rpm
firefox-102.8.0-2.el8_7.alma.x86_64.rpm

Notes:
This page is generated automatically from Red Hat security data and has not been checked for errors. For clarification or corrections please contact the AlmaLinux Packaging Team.

  ALSA-2023:0808 Important: firefox security update