stop: c000021a {Fatal System Error} -- newb meets minor heart attack... seeks me

The Session Manager Initialization system process terminated unexpectedly with a status of 0xc000003a (0x00000000 0x00000000). The system has been shut down. that's the whole error message. . . and all I see on the infamous blue screen.

Linux Customization Tweaking 106 This topic was started by ,


2 Posts
Location -
Joined 2005-02-24
The Session Manager Initialization system process terminated unexpectedly with a status of 0xc000003a (0x00000000 0x00000000). The system has been shut down."
that's the whole error message... and all I see on the infamous blue screen... though I refuse to acknowledge it has anything to do with death :-):
Here we go...
I'm a newbie to Linux and this is one of those times when I feel like I should just regress and submit to the powers of M$, but I'm stubborn and actually care about civil liberties, invasion of privacy, etc, so I'm in this one to win it.
I have searched through th existing threads on this one as well as having done some poking around on the net for a solution and hereby throw myself upon the mercy of greater minds and experience (and have been pointed to linuxcompatible by a few seasoned vets):
Here's how the boys at M$ describe my problem -- that is, this is almost EXACTLY it:;en-us;317189
There are 2 things that don't fit
1) they seem to imply it's only an NT thing -- my system is XP Pro (specs follow)
2) their message is for 0xc0000017 status - mine is 0xc000003a
-BRAND new (if it had ears, it would still be wet behind them - I'm talkin' this-week new, factory-direct)
-IBM Thinkpad T42, Pentium M 1.7 GHZ, 60GB, 7200 RPM HDD, 1GB PC2700 DDR SDRAM, Intel Pro Wireless 2200 integrated wireless B/G
It's been partitioned successfully using Partition Magic and all was well with XP... then I installed Ubuntu ( - latest stable of Warty Warthog): my Linux distro of choice. The concept all along was to buy this machine with the express intent of running Windows parallel with Linux. No I'm starting to feel like it might be cheaper to pay programmers to write scripts for every non compatible peripheral that sparked this fine mess...
Now, I have a machine that loads to the GRUB boot loader beautifully, gives me 5 options (1 Ubuntu and one Windows safe, 1 Ubuntu and one Windows normal, and memory test, although the windows options both appear to be the same since neither says "safe", I imagine one is supposed to be safe... either way, neither works. ) The Ubuntu system works perfectly (of course, it WOULD be Windows with issues... ug.)
Regarding a post I read in the threads of similar topic, if the solution is to take the CDs tht came with it and do a "fixboot" or a "non-destructive reinstall", please provide some detail as I have no idea what the implications are / what I should expect during the process...
Here's another twist: If there are other Distros that make life easier, I'm willing to consider anything. I've used fluxbox (not my cup of tea), Mandrake (liked it) and a couple others... Since I'm just making the switch, Ubuntu is wonderful because the GUI is familiar, etc... still, I'm open.
Thank you in advance for your time!

Participate on our website and join the conversation

You have already an account on our website? Use the link below to login.
Create a new user account. Registration is free and takes only a few seconds.
This topic is archived. New comments cannot be posted and votes cannot be cast.

Responses to this topic


68 Posts
Location -
Joined 2005-01-24
Hi Biggaloo,
Glad to hear you have made the jump to Linux. FYI M$oft often refers to NT when looking at XP documents, problems etc.. XP is built on NT technology and has many of the same internals, hence the reference.
The M$ page you reference suggests performing a parallel install. I strongly suggest that you do not. Any install of XP will write the MBR or Master Boot Record. What you will end up with is an XP machine with a small(er) than 70 GB drive. You would find it difficult to recover.
Yes, everybody, It can be done. But I don't suggest newbies start down that path. This is the road to endless frustration.
As your machine is new, if it were me, I would reinstall XP, but not allocate the whole drive. XP will run in as little as 4 GB (too small for much interesting) so maybe 30-40 GB is good. Run this a bit, make sure it works (HA HA, as well as any M$ product is supposed to -- LOL).
Then, install Linux. I would strongly recomend Fedora Core 3. I know your laptop and know that FC3 will see all your hardware and configure correctly.
When you install, pay attention to the partitioning question at the beginning of the install. Let FC partition your system, but do not select the option "Delete all partitions" -- for obvious reasons. I suggest you do an "Custom Installation" and, at the bottom of the options list, select "Everything". This way you will have all the bells and whistles. You can always remove stuff later.
Sorry if I sound like I am just suggesting the easy way out, I am. I think you would be much happier getting a system up and running. Yes?
Good luck and have fun with Linux !


336 Posts
Location -
Joined 2004-07-09
you don't appear to have a boot problem.
you seem to have a WinXP start-up problem.
can you boot WinXP in Safe mode?
you'll need to type F8 just after selecting either Windows grub entry
and before the WinXP "green caterpillar" appears. Choose "Safe Mode".
The equivalent registry keys for the ones mentioned in the referenced
Microsoft KB317189 are:
(Note that in WinXP the 'hive' loading and unloading is unnecessary)
1. for finding the current control set (HKLM == HKEY_LOCAL_MACHINE)
- check value of Current
2. for finding pending file rename operations
- HKLM\SYSTEM\ControlSetNNN\Control\Session Manager\FileRenameOperations
- (where NNN is the three digit leading zero decimal value of 'Current' above)
3. for finding the RunOnce and RunOnceEx entries
- HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\RunOnce
- HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\RunOnceEx
It seems a software upgrade or OS patch install of yours has gone awry.
Standard warnings about editing the Windows Registry apply, but then
your system doesn't start up WinXP properly, now does it?
Can't make it too much worse... ;(


2 Posts
Location -
Joined 2005-02-24
BSchindler -- thanks for the suggestion -- I will take the FC3 way out if things don't pan out the martouf way :-):
(although I must admit some trepadation)
Alright, martouf, I'm on board -- I tried your suggestions, booting and trying to get into safe mode using F8... no dice
There is another message that comes up briefly before the error message I detailed before (as follows):
"autochk program not found - skipping AUTOCHECK"
bottom-line, the answer is "nope", I can't boot XP in safe mode.
Where to now? (assume I will browse through all links you provided)


336 Posts
Location -
Joined 2004-07-09
did you by any chance actually make the WinXP emergency recovery disks (ERD)?
umm, before you modified the disk partitions with Partition Magic?
I'm thinking your partition table was changed and the disk geometry it now
has is not what it had when WinXP could run.. autochk is a vital and necessary
part of WinXP start up. If it's 'missing', then something is quite wrong.
You did the right thing to use Partition Magic to set up the new disk layout,
but I'm thinking the Ubuntu installation updated the partition table.
That would have unfortunately undone all of your efforts to preserve your
disk geometry.
Did you have the option to 'use existing partition' when setting up Ubuntu?
..and you made sure to select it?


1 Posts
Location -
Joined 2005-05-03
Just solved this one for my situation. I found information elsewhere that your NTFS or FAT32 partition can become marked 'hidden' in this Linux/Windows mess. Using the Partition Magic boot floppies I selected my 'hidden' NTFS partition, went to 'Advanced' and I believe it was 'unhide'.
After that, GRUB would start both Fedora and WinXP with no problems.
Hope this helps somebody else.


1 Posts
Location -
Joined 2005-08-14
Blackbird 45's answer works only if you have a bios that supports LBA. However, if your system doesn't I just got something that worked well for me. Here’s the problem:
Install Fedora on the same drive as Windows XP. You have no XP disks to do a recovery. Fedora has a bug that installs itself on the MBR meaning your NTFS system is inoperable. So, now you cannot boot to the XP partition. Well, after you bang your head against the wall because you didn't just read installing Fedora for 2 hours but should have looked it up to see what other difficulties others were having, I’ve got the fix for it Even after you get the blue screen of “pain in the ass” and message:
[sTOP c000021a{Fatal System Error} … 0xC000003a the system has been shut down]
So, here’s what I did that worked. I actually did quite a bit which had no effect but that’s neither here nor 3 hours in the past. On a file sharer such as Emule download “Ultimate Boot Disk Ghost” about 16.5 mb iso file. Obviously use the Linux OS or a secondary cpu. Boot from the CD (make sure under BIOS your priority for booting disk is before HD) then run to the C prompt. Enter “ fdisk /mbr” (NOTE- other options are “fixboot” or “bootcfg/rebuild”. Both SHOULD work but fixboot will rewrite the whole boot record not just MBR thus I think “ fdisk/mbr” is best) This will fix the MBR which Fedora writes over. Now, your Linux is inaccessible. So, you have to reboot again to the disk and go down to Partition Magic. Under partition magic you will find the NTFS file system is hidden and the Linux is Active (eg. 1st Boot). So, change the NTFS system that’s hidden which SHOULD be the original partition where your Windows XP is stored. Reboot and you will come back to the Windows OS. Linux is still installed but inactive. To make it active use THIS guide and NOT the one on the Fedora CD. The bug lies in GRUB which typically either writes over the MBR making windows inaccessible or it ends on a partition that is too far (+8.5 GB) for your BIOS to read because it doesn’t use LBA. Thanks to ED for the guide for setting up Linux/Windows correctly.


1 Posts
Location -
Joined 2005-09-08
I just found this post from Google after searching around a bit to get my system working. Y'see, I'd reformatted my EXT3 and SWAP partitions (and left Windows' NTFS alone) during a recent install of FC4 over RedHat 9, and everything was fine and dandy with both oh-esses.
Until I started to get clever and tried to hide the NTFS partition (via grub.conf command HIDE (hd0,0)) when FC4 booted, and the EXT3 and SWAP partitions when Windows booted. Being a bit of a twunt, I thought that the HIDE command was per-session, and didn't actually 'hide' anything permanently. You guessed it, forgot to include the UNHIDE command in the opposite OS' boot string. D'oh!
I soon realised this as far as FC4 was concerned and fixed it using command line grub, but since I hadn't booted into Windows for a few days I forgot about unhiding some partition that Windows needed to see once it started up. Hence the blue screen.
In summary, before you reach for any recovery disks, emergency boot disks, Windows installation CD or impact maintenance tools, try entering this at the grub command line:
unhide (hd0,0)
unhide (hd0,1)
unhide (hd0,2) .. and so on until you run out of partitions.
My Windows and FC4 are now both booting happily, and I didn't have to go anywhere near the Ghost image I made before starting the FC4 upgrade process. Which, by the way, is a practice one highly recommends.
Thanks to all the other forum members for giving me the inspiration to put two and two together, and thanks to Mr. William Gates for my cold dinner. ;P


1 Posts
Location -
Joined 2005-09-27
I love you... seriously. I've been looking for an answer to this problem for two weeks. I was about to pay $100 and let someone else fix it. How could it have been so simple!?!?! *sigh* Well, thanks again!


1 Posts
Location -
Joined 2005-10-18
thanks to you guys, i have my system winxp running, your right guys the partition was hidden and i was able to unhide using the unhide, but before that i was a newbie and not able to do grub thing... so to give a step to other newbie like me, if your ubuntu is working properly and winxp is display an error like autochk blahblah... first boot to Ubuntu then locate the Root Terminal to open the grub, once in the root terminal type "grub", grub prompt open then type "unhide (hd0,0)" follow the instruction given by muppet, another tip is that while not finishing the word unhide, try clicking the Tab key, this is a good help and for hd0....hope this helpppp to newbies like me..


1 Posts
Location -
Joined 2005-12-26
Thank you thank you thank you thank you thank you.
After about two hours of hitting my head against the wall, I found my Knoppix boot CD, googled my error message, found this page, booted to my boot utilities CD, ran grub and unhid my hidden drive. I am now back in XP and will:
(1) Not be monkeying around with Partition Magic any time soon
(2) Resolve to answer THREE questions online in the next week to save other people with stuff I know.
(3) Thank martouf profusely from the bottom of my heart every time my computer boots up!
SERIOUSLY -- I thought I was in a pickle. You have no idea how happy I am. Thank you google and thank you linuxcompatible message boards!!!


1 Posts
Location -
Joined 2006-07-24
Wow, my problem was EXACTLY as described by the starting post. I booted into single user mode as recommended, logged in as root, and typed in grub, and then unhide (hd0,0) and hit enter, typed in quit, and exit, and restarted and BAM! IT WORKS!
Thanks MUPPET!


6 Posts
Location -
Joined 2006-08-11
hi all
i'm having a problem along these lines. (and am very much a newbie!)
I have a windows xp partition and an ubuntu partition. I've been using the ubuntu for a week or so and am absolutely loving it.
I formatted the partitions using the windows and ubuntu installers, not partition magic.
I have the autocheck problem with xp as mentioned above.
However, the method described is not so simple for me!
In grub, I am getting this:
grub> unhide (hd0,0)
Error 21: Selected disk does not exist
so I noted that my windows drive is referred to as sda1 and tried this:
grub> unhide (sda1)
Error 23: Error while parsing number
What am I doing wrong? I hope my problem is as simple to fix as the others here.


2895 Posts
Location -
Joined 2002-08-30
Grub uses different syntax then what the partition is actually in Linux.

Quote:so I noted that my windows drive is referred to as sda1 and tried this:  
grub> unhide (sda1)
sda1 is the actual partition, not the grub command syntax, so this is why you are getting the Error 23: Error while parsing number. It doesn;t know sda1, but the drives are seen in order of (hd0,0), for example. Where hd0 is the first drive in the system and ,0 is the first partition.
Do you have one hard drive on the system, or two?
If two, is Ubuntu installed on the same hard drive as your Windows installation?
Let's look at this logically. If you get into Ubuntu, go to a terminal window, as root user and type the following;
fdisk -l
Where i is the small letter "L", not the number 1.
This should give you an output of your drives and their partitions.
Can you post the result here?
HINT: if you don't know. To copy and paste the output of the result, highlight the result text. Choose from the dropdown menu...edit-->copy
Move to the post quick reply window and hold down <ctrl> then "v" (on the keyboard).


6 Posts
Location -
Joined 2006-08-11
Hi Danleff, thanks for the response!
After doing what you said, I get this:
Disk /dev/sda: 160.0 GB, 160040803840 bytes
255 heads, 63 sectors/track, 19457 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Device Boot Start End Blocks Id System
/dev/sda1 * 1 15298 122881153+ 82 Linux swap / Solaris
/dev/sda2 15300 19457 33399135 5 Extended
/dev/sda5 15301 19424 33126030 83 Linux
/dev/sda6 19425 19457 265041 82 Linux swap / Solaris
Disk /dev/sdb: 203.9 GB, 203927027200 bytes
255 heads, 63 sectors/track, 24792 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Device Boot Start End Blocks Id System
/dev/sdb1 1 24792 199141708+ 7 HPFS/NTFS
I have two SATA drives. One (160Gb) is with a 120Gb Xp partition and rest (40ishGb) is for Ubuntu Linux. The other drive is a 200Gb drive for general stuff.


2895 Posts
Location -
Joined 2002-08-30
Take a look at the partitions designated for sda. Note that sda1 is marked as a swap partition. Is it possible that you accidently marked (formatted) this partition as a swap file when installing Ubuntu?
sda1 = (hd0,0), that is, if you did not change the bios boot order, or the designation of the sata cables to the motherboard.
I assume sdb is just a data drive of NTFS type?


6 Posts
Location -
Joined 2006-08-11
I hope that I didn't format the XP partition. It asked me for a swap partition and I made a small one in the space I reserved for linux.
Earlier, I tried typing unhide (hd1,x) where x was 0 to 3. It accepted these commands. Although the problem remains - when XP boots, autocheck.exe is not found...
Yes, sdb is exactly that, a data drive of NTFS type.
I haven't changed any cables or BIOS stuff, main OS drive is first and DATA drive is second.


6 Posts
Location -
Joined 2006-08-11
i've worked out that /dev/sda1 is the 117Gb windows partition,
sda5 is Ubuntu, (Ext3 system)
sda6 is a 259Mb swap partition.
(I also have 15Mb of free space for some reason...)
sdb is the data drive


5 Posts
Location -
Joined 2007-04-19
hi, i also have the same problems as the first post states however i haven't split my hard drive and i am new to all of this. Can any of you please help me?
Thanks in advance


2895 Posts
Location -
Joined 2002-08-30
Can you be more specific?
When you say that you did not split your hard drive, what do you mean?
The previous posts refer to users with Windows XP and Linux installed on their systems, when they encountered the error. Is this the case for you? If so, what distro of Linux did you install...and do you have a dual boot situation right now?