Xrdp security update for Debian 7 LTS
Posted on: 12/11/2017 01:30 PM

Updated xrdp packages has been released for Debian GNU/Linux 7

Xrdp security update for Debian 7 LTS


Package : xrdp
Version : 0.5.0-2+deb7u2
CVE ID : CVE-2017-16927

The scp_v0s_accept function in sesman/libscp/libscp_v0.c in the session manager
in xrdp uses an untrusted integer as a write length, which allows local users
to cause a denial of service (buffer overflow and application crash) or
possibly have unspecified other impact via a crafted input stream.

For Debian 7 "Wheezy", these problems have been fixed in version
0.5.0-2+deb7u2.

We recommend that you upgrade your xrdp packages.

Further information about Debian LTS security advisories, how to apply
these updates to your system and frequently asked questions can be
found at: https://wiki.debian.org/LTS



Printed from Linux Compatible (https://www.linuxcompatible.org/news/story/xrdp_security_update_for_debian_7_lts_16b3.html)