Wget, Flash Player, BURP, Quassel Updates for Gentoo Linux
Posted on: 06/14/2018 06:21 AM

The following updates has been released for Gentoo Linux:

GLSA 201806-01 : GNU Wget: Cookie injection
GLSA 201806-02 : Adobe Flash Player: Multiple vulnerabilities
GLSA 201806-03 : BURP: Multiple vulnerabilities
GLSA 201806-04 : Quassel: Multiple vulnerabilities

GLSA 201806-01 : GNU Wget: Cookie injection
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory GLSA 201806-01
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
https://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Severity: Normal
Title: GNU Wget: Cookie injection
Date: June 13, 2018
Bugs: #655216
ID: 201806-01

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
========

A vulnerablity in GNU Wget could allow arbitrary cookies to be
injected.

Background
==========

GNU Wget is a free software package for retrieving files using HTTP,
HTTPS and FTP, the most widely-used Internet protocols.

Affected packages
=================

-------------------------------------------------------------------
Package / Vulnerable / Unaffected
-------------------------------------------------------------------
1 net-misc/wget < 1.19.5 >= 1.19.5

Description
===========

A vulnerability was discovered in GNU Wget's resp_new function which
does not validate \r\n sequences in continuation lines.

Impact
======

A remote attacker could inject arbitrary cookie entry requests.

Workaround
==========

There is no known workaround at this time.

Resolution
==========

All GNU Wget users should upgrade to the latest version:

# emerge --sync
# emerge --ask --oneshot --verbose ">=net-misc/wget-1.19.5"

References
==========

[ 1 ] CVE-2018-0494
https://nvd.nist.gov/vuln/detail/CVE-2018-0494

Availability
============

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

https://security.gentoo.org/glsa/201806-01

Concerns?
=========

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users' machines is of utmost
importance to us. Any security concerns should be addressed to
security@gentoo.org or alternatively, you may file a bug at
https://bugs.gentoo.org.

License
=======

Copyright 2018 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

https://creativecommons.org/licenses/by-sa/2.5



GLSA 201806-02 : Adobe Flash Player: Multiple vulnerabilities
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory GLSA 201806-02
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
https://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Severity: Normal
Title: Adobe Flash Player: Multiple vulnerabilities
Date: June 13, 2018
Bugs: #656230, #657564
ID: 201806-02

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
========

Multiple vulnerabilities have been found in Adobe Flash Player, the
worst of which allows remote attackers to execute arbitrary code.

Background
==========

The Adobe Flash Player is a renderer for the SWF file format, which is
commonly used to provide interactive websites.

Affected packages
=================

-------------------------------------------------------------------
Package / Vulnerable / Unaffected
-------------------------------------------------------------------
1 www-plugins/adobe-flash < 30.0.0.113 >= 30.0.0.113

Description
===========

Multiple vulnerabilities have been discovered in Adobe Flash Player.
Please review the CVE identifiers referenced below for details.

Impact
======

A remote attacker could possibly execute arbitrary code with the
privileges of the process or obtain sensitive information.

Workaround
==========

There is no known workaround at this time.

Resolution
==========

All Adobe Flash Player users should upgrade to the latest version:

# emerge --sync
# emerge --ask --oneshot -v ">=www-plugins/adobe-flash-30.0.0.113"

References
==========

[ 1 ] CVE-2018-4944
https://nvd.nist.gov/vuln/detail/CVE-2018-4944
[ 2 ] CVE-2018-4945
https://nvd.nist.gov/vuln/detail/CVE-2018-4945
[ 3 ] CVE-2018-5000
https://nvd.nist.gov/vuln/detail/CVE-2018-5000
[ 4 ] CVE-2018-5001
https://nvd.nist.gov/vuln/detail/CVE-2018-5001
[ 5 ] CVE-2018-5002
https://nvd.nist.gov/vuln/detail/CVE-2018-5002

Availability
============

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

https://security.gentoo.org/glsa/201806-02

Concerns?
=========

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users' machines is of utmost
importance to us. Any security concerns should be addressed to
security@gentoo.org or alternatively, you may file a bug at
https://bugs.gentoo.org.

License
=======

Copyright 2018 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

https://creativecommons.org/licenses/by-sa/2.5



GLSA 201806-03 : BURP: Multiple vulnerabilities
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory GLSA 201806-03
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
https://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Severity: Normal
Title: BURP: Multiple vulnerabilities
Date: June 13, 2018
Bugs: #628770, #641842
ID: 201806-03

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
========

Multiple vulnerabilities were discovered in BURP's Gentoo ebuild, the
worst of which could lead to root privilege escalation.

Background
==========

A network backup and restore program.

Affected packages
=================

-------------------------------------------------------------------
Package / Vulnerable / Unaffected
-------------------------------------------------------------------
1 app-backup/burp < 2.1.32 >= 2.1.32

Description
===========

It was discovered that Gentoo's BURP ebuild does not properly set
permissions or place the pid file in a safe directory.

Impact
======

A local attacker could escalate privileges.

Workaround
==========

Users should ensure the proper permissions are set as discussed in the
referenced bugs.

Resolution
==========

All BURP users should upgrade to the latest version:

# emerge --sync
# emerge --ask --oneshot --verbose ">=app-backup/burp-2.1.32"

References
==========

[ 1 ] CVE-2017-18284
https://nvd.nist.gov/vuln/detail/CVE-2017-18284
[ 2 ] CVE-2017-18285
https://nvd.nist.gov/vuln/detail/CVE-2017-18285

Availability
============

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

https://security.gentoo.org/glsa/201806-03

Concerns?
=========

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users' machines is of utmost
importance to us. Any security concerns should be addressed to
security@gentoo.org or alternatively, you may file a bug at
https://bugs.gentoo.org.

License
=======

Copyright 2018 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

https://creativecommons.org/licenses/by-sa/2.5



GLSA 201806-04 : Quassel: Multiple vulnerabilities
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory GLSA 201806-04
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
https://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Severity: Normal
Title: Quassel: Multiple vulnerabilities
Date: June 14, 2018
Bugs: #653834
ID: 201806-04

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
========

Multiple vulnerabilities have been found in Quassel, the worst of which
could allow remote attackers to execute arbitrary code.

Background
==========

Quassel is a Qt4/KDE4 IRC client suppporting a remote daemon for 24/7
connectivity.

Affected packages
=================

-------------------------------------------------------------------
Package / Vulnerable / Unaffected
-------------------------------------------------------------------
1 net-irc/quassel < 0.12.5 >= 0.12.5

Description
===========

Multiple vulnerabilities have been discovered in Quassel. Please review
the CVE identifiers referenced below for details.

Impact
======

A remote attacker could cause arbitrary code execution or a Denial of
Service condition.

Workaround
==========

There is no known workaround at this time.

Resolution
==========

All Quassel users should upgrade to the latest version:

# emerge --sync
# emerge --ask --oneshot --verbose ">=net-irc/quassel-0.12.5"

References
==========

[ 1 ] CVE-2018-1000178
https://nvd.nist.gov/vuln/detail/CVE-2018-1000178
[ 2 ] CVE-2018-1000179
https://nvd.nist.gov/vuln/detail/CVE-2018-1000179

Availability
============

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

https://security.gentoo.org/glsa/201806-04

Concerns?
=========

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users' machines is of utmost
importance to us. Any security concerns should be addressed to
security@gentoo.org or alternatively, you may file a bug at
https://bugs.gentoo.org.

License
=======

Copyright 2018 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

https://creativecommons.org/licenses/by-sa/2.5






Printed from Linux Compatible (https://www.linuxcompatible.org/news/story/wgetflash_playerburpquassel_updates_for_gentoo_linux.html)