Wget/Curl Updates for Debian
Posted on: 10/28/2017 07:59 AM

The following updates has been released for Debian GNU/Linux:

Debian GNU/Linux 7 LTS:
DLA 1149-1: wget security update

Debian GNU/Linux 8 and 9:
DSA 4007-1: curl security update

DLA 1149-1: wget security update



Package : wget
Version : 1.13.4-3+deb7u5
CVE ID : CVE-2017-13089 CVE-2017-13090

CVE-2017-13089
Fix stack overflow in HTTP protocol handling.

CVE-2017-13090
Fix heap overflow in HTTP protocol handling.


For Debian 7 "Wheezy", these problems have been fixed in version
1.13.4-3+deb7u5.

We recommend that you upgrade your wget packages.

Further information about Debian LTS security advisories, how to apply
these updates to your system and frequently asked questions can be
found at: https://wiki.debian.org/LTS




DSA 4007-1: curl security update



- -------------------------------------------------------------------------
Debian Security Advisory DSA-4007-1 security@debian.org
https://www.debian.org/security/ Alessandro Ghedini
October 27, 2017 https://www.debian.org/security/faq
- -------------------------------------------------------------------------

Package : curl
CVE ID : CVE-2017-1000257

Brian Carpenter, Geeknik Labs and 0xd34db347 discovered that cURL, an URL
transfer library, incorrectly parsed an IMAP FETCH response with size 0,
leading to an out-of-bounds read.

For the oldstable distribution (jessie), this problem has been fixed
in version 7.38.0-4+deb8u7.

For the stable distribution (stretch), this problem has been fixed in
version 7.52.1-5+deb9u2.

For the unstable distribution (sid), this problem has been fixed in
version 7.56.1-1.

We recommend that you upgrade your curl packages.

Further information about Debian Security Advisories, how to apply
these updates to your system and frequently asked questions can be
found at: https://www.debian.org/security/







Printed from Linux Compatible (https://www.linuxcompatible.org/news/story/wgetcurl_updates_for_debian.html)