WebKitGTK+ and Tomcat Updates for Ubuntu Linux
Posted on: 10/11/2018 07:27 AM

The following updates has been released for Ubuntu Linux:

USN-3781-2: WebKitGTK+ regression
USN-3787-1: Tomcat vulnerability

USN-3781-2: WebKitGTK+ regression

==========================================================================
Ubuntu Security Notice USN-3781-2
October 10, 2018

webkit2gtk regression
==========================================================================

A security issue affects these releases of Ubuntu and its derivatives:

- Ubuntu 18.04 LTS

Summary:

USN-3781-1 introduced a regression in WebKitGTK+.

Software Description:
- webkit2gtk: Web content engine library for GTK+

Details:

USN-3781-1 fixed vulnerabilities in WebKitGTK+. The updated package was
missing some header files, preventing certain applications from building.
This update fixes the problem.

We apologize for the inconvenience.

Original advisory details:

A large number of security issues were discovered in the WebKitGTK+ Web and
JavaScript engines. If a user were tricked into viewing a malicious
website, a remote attacker could exploit a variety of issues related to web
browser security, including cross-site scripting attacks, denial of service
attacks, and arbitrary code execution.

Update instructions:

The problem can be corrected by updating your system to the following
package versions:

Ubuntu 18.04 LTS:
libjavascriptcoregtk-4.0-18 2.22.2-0ubuntu0.18.04.2
libwebkit2gtk-4.0-37 2.22.2-0ubuntu0.18.04.2

This update uses a new upstream release, which includes additional bug
fixes. After a standard system update you need to restart any applications
that use WebKitGTK+, such as Epiphany, to make all the necessary changes.

References:
https://usn.ubuntu.com/usn/usn-3781-2
https://usn.ubuntu.com/usn/usn-3781-1
https://launchpad.net/bugs/1795901

Package Information:
https://launchpad.net/ubuntu/+source/webkit2gtk/2.22.2-0ubuntu0.18.04.2


USN-3787-1: Tomcat vulnerability

==========================================================================
Ubuntu Security Notice USN-3787-1
October 10, 2018

tomcat7, tomcat8 vulnerability
==========================================================================

A security issue affects these releases of Ubuntu and its derivatives:

- Ubuntu 16.04 LTS
- Ubuntu 14.04 LTS

Summary:

Tomcat could be made to redirect to arbitrary locations.

Software Description:
- tomcat8: Servlet and JSP engine
- tomcat7: Servlet and JSP engine

Details:

It was discovered that Tomcat incorrectly handled returning redirects to a
directory. A remote attacker could possibly use this issue with a specially
crafted URL to redirect to arbitrary URIs.

Update instructions:

The problem can be corrected by updating your system to the following
package versions:

Ubuntu 16.04 LTS:
libtomcat8-java 8.0.32-1ubuntu1.8
tomcat8 8.0.32-1ubuntu1.8

Ubuntu 14.04 LTS:
libtomcat7-java 7.0.52-1ubuntu0.16
tomcat7 7.0.52-1ubuntu0.16

In general, a standard system update will make all the necessary changes.

References:
https://usn.ubuntu.com/usn/usn-3787-1
CVE-2018-11784

Package Information:
https://launchpad.net/ubuntu/+source/tomcat8/8.0.32-1ubuntu1.8
https://launchpad.net/ubuntu/+source/tomcat7/7.0.52-1ubuntu0.16





Printed from Linux Compatible (https://www.linuxcompatible.org/news/story/webkitgtk_and_tomcat_updates_for_ubuntu_linux.html)