Waagent and Xmltooling Updates for Debian 9
Posted on: 03/13/2019 07:27 AM

The following security updates has been released for Debian GNU/Linux 9:

DSA 4406-1: waagent security update
DSA 4407-1: xmltooling security update

DSA 4406-1: waagent security update



- -------------------------------------------------------------------------
Debian Security Advisory DSA-4406-1 security@debian.org
https://www.debian.org/security/ Moritz Muehlenhoff
March 12, 2019 https://www.debian.org/security/faq
- -------------------------------------------------------------------------

Package : waagent
CVE ID : CVE-2019-0804

Francis McBratney discovered that the Windows Azure Linux Agent created
swap files with world-readable permissions, resulting in information
disclosure.

For the stable distribution (stretch), this problem has been fixed in
version 2.2.18-3~deb9u2.

We recommend that you upgrade your waagent packages.

For the detailed security status of waagent please refer to
its security tracker page at:
https://security-tracker.debian.org/tracker/waagent

Further information about Debian Security Advisories, how to apply
these updates to your system and frequently asked questions can be
found at: https://www.debian.org/security/




DSA 4407-1: xmltooling security update



- -------------------------------------------------------------------------
Debian Security Advisory DSA-4407-1 security@debian.org
https://www.debian.org/security/ Moritz Muehlenhoff
March 12, 2019 https://www.debian.org/security/faq
- -------------------------------------------------------------------------

Package : xmltooling
CVE ID : CVE-2019-9628

Ross Geerlings discovered that the XMLTooling library didn't correctly
handle exceptions on malformed XML declarations, which could result in
denial of service against the application using XMLTooling.

For the stable distribution (stretch), this problem has been fixed in
version 1.6.0-4+deb9u2.

We recommend that you upgrade your xmltooling packages.

For the detailed security status of xmltooling please refer to
its security tracker page at:
https://security-tracker.debian.org/tracker/xmltooling

Further information about Debian Security Advisories, how to apply
these updates to your system and frequently asked questions can be
found at: https://www.debian.org/security/







Printed from Linux Compatible (https://www.linuxcompatible.org/news/story/waagent_and_xmltooling_updates_for_debian_9.html)