VIM (SSA:2017-100-01) Update for Slackware
Posted on: 04/11/2017 09:24 AM

New vim packages are available for Slackware 14.0 and 14.1 to fix a security issue

VIM (SSA:2017-100-01) Update for Slackware


Here are the details from the Slackware 14.1 ChangeLog:
+--------------------------+
patches/packages/vim-7.4.399-i486-1_slack14.1.txz: Upgraded.
In Vim 7.3+ but prior to 7.4.399, blowfish encryption is weak.
Upgrade to Vim 7.4.399 to address this issue.
For more information, see:
https://dgl.cx/2014/10/vim-blowfish
(* Security fix *)
patches/packages/vim-gvim-7.4.399-i486-1_slack14.1.txz: Upgraded.
+--------------------------+


Where to find the new packages:
+-----------------------------+

Thanks to the friendly folks at the OSU Open Source Lab
(http://osuosl.org) for donating FTP and rsync hosting
to the Slackware project! :-)

Also see the "Get Slack" section on http://slackware.com for
additional mirror sites near you.

Updated packages for Slackware 14.0:
ftp://ftp.slackware.com/pub/slackware/slackware-14.0/patches/packages/vim-7.4.399-i486-1_slack14.0.txz
ftp://ftp.slackware.com/pub/slackware/slackware-14.0/patches/packages/vim-gvim-7.4.399-i486-1_slack14.0.txz

Updated packages for Slackware x86_64 14.0:
ftp://ftp.slackware.com/pub/slackware/slackware64-14.0/patches/packages/vim-7.4.399-x86_64-1_slack14.0.txz
ftp://ftp.slackware.com/pub/slackware/slackware64-14.0/patches/packages/vim-gvim-7.4.399-x86_64-1_slack14.0.txz

Updated packages for Slackware 14.1:
ftp://ftp.slackware.com/pub/slackware/slackware-14.1/patches/packages/vim-7.4.399-i486-1_slack14.1.txz
ftp://ftp.slackware.com/pub/slackware/slackware-14.1/patches/packages/vim-gvim-7.4.399-i486-1_slack14.1.txz

Updated packages for Slackware x86_64 14.1:
ftp://ftp.slackware.com/pub/slackware/slackware64-14.1/patches/packages/vim-7.4.399-x86_64-1_slack14.1.txz
ftp://ftp.slackware.com/pub/slackware/slackware64-14.1/patches/packages/vim-gvim-7.4.399-x86_64-1_slack14.1.txz


MD5 signatures:
+-------------+

Slackware 14.0 packages:
21a80997408229ddeb4890f7f23c132d vim-7.4.399-i486-1_slack14.0.txz
49ae67d217ff76984956c77dcb2ab9c7 vim-gvim-7.4.399-i486-1_slack14.0.txz

Slackware x86_64 14.0 packages:
a57fb5404c917c5c57a1ed1e71b0fb59 vim-7.4.399-x86_64-1_slack14.0.txz
0c6d3bb6ce48fa164dccdc47bd79abd5 vim-gvim-7.4.399-x86_64-1_slack14.0.txz

Slackware 14.1 packages:
88a931719416ee4ac8215edcea33dd97 vim-7.4.399-i486-1_slack14.1.txz
84e81ae1bf120296428a5483f3ca5e44 vim-gvim-7.4.399-i486-1_slack14.1.txz

Slackware x86_64 14.1 packages:
ec253ff56d8633065f90bdb0207b8051 vim-7.4.399-x86_64-1_slack14.1.txz
5925fa810029997d450e2b598eed8b06 vim-gvim-7.4.399-x86_64-1_slack14.1.txz


Installation instructions:
+------------------------+

Upgrade the packages as root:
# upgradepkg vim-7.4.399-i486-1_slack14.1.txz vim-gvim-7.4.399-i486-1_slack14.1.txz



Printed from Linux Compatible (https://www.linuxcompatible.org/news/story/vim_(ssa2017_100_01)_update_for_slackware.html)