Unzip and Ghostscript Updates for Debian
Posted on: 09/09/2019 04:56 PM

The following updates has been released for Debian GNU/Linux:

Debian GNU/Linux 7 Extended LTS:
ELA-141-2: unzip regression update

Debian GNU/Linux 8 LTS:
DLA 1915-1: ghostscript security update

ELA-141-2: unzip regression update
Package: unzip
Version: 6.0-8+deb7u8
Related CVE: CVE-2019-13232
The unzip security update issued as ELA 141-1 caused a regression when extracting some non-standard zip files.

For instance there is a zip-like file in the Firefox distribution, omni.ja, which is a zip container with the central directory placed at the start of the file instead of after the local entries as required by the zip standard. This update now permits such containers to not raise a zip bomb alert, where in fact there are no overlaps.

For Debian 7 Wheezy, these problems have been fixed in version 6.0-8+deb7u8.

We recommend that you upgrade your unzip packages.

Further information about Extended LTS security advisories can be found at: https://deb.freexian.com/extended-lts/

DLA 1915-1: ghostscript security update
Package : ghostscript
Version : 9.26a~dfsg-0+deb8u5
CVE ID : CVE-2019-14811 CVE-2019-14812 CVE-2019-14813 CVE-2019-14817

It was discovered that various procedures in Ghostscript, the GPL
PostScript/PDF interpreter, do not properly restrict privileged calls,
which could result in bypass of file system restrictions of the dSAFER
sandbox.

For Debian 8 "Jessie", these problems have been fixed in version
9.26a~dfsg-0+deb8u5.

We recommend that you upgrade your ghostscript packages.

Further information about Debian LTS security advisories, how to apply
these updates to your system and frequently asked questions can be
found at: https://wiki.debian.org/LTS



Printed from Linux Compatible (https://www.linuxcompatible.org/news/story/unzip_and_ghostscript_updates_for_debian.html)