Tar, Polkit, Elfutils Updates for Arch Linux
Posted on: 01/09/2019 08:51 AM

The following updates has been released for Arch Linux:

ASA-201901-1: tar: denial of service
ASA-201901-2: polkit: privilege escalation
ASA-201901-3: elfutils: denial of service

ASA-201901-1: tar: denial of service
Arch Linux Security Advisory ASA-201901-1
=========================================

Severity: Low
Date : 2019-01-08
CVE-ID : CVE-2018-20482
Package : tar
Type : denial of service
Remote : No
Link : https://security.archlinux.org/AVG-841

Summary
=======

The package tar before version 1.31-1 is vulnerable to denial of
service.

Resolution
==========

Upgrade to 1.31-1.

# pacman -Syu "tar>=1.31-1"

The problem has been fixed upstream in version 1.31.

Workaround
==========

None.

Description
===========

A denial of service issue has been found in GNU Tar versions up to and
including 1.30. When creating archives with the --sparse option, tar
would loop endlessly if a sparse file had been truncated while being
archived.

Impact
======

An attacker might be able to cause a denial of service via an archive
created with the --sparse option.

References
==========

https://lists.gnu.org/archive/html/bug-tar/2018-12/msg00023.html
https://git.savannah.gnu.org/cgit/tar.git/commit/?id=c15c42c
https://utcc.utoronto.ca/~cks/space/blog/sysadmin/TarFindingTruncateBug
https://security.archlinux.org/CVE-2018-20482



ASA-201901-2: polkit: privilege escalation
Arch Linux Security Advisory ASA-201901-2
=========================================

Severity: High
Date : 2019-01-08
CVE-ID : CVE-2018-19788
Package : polkit
Type : privilege escalation
Remote : No
Link : https://security.archlinux.org/AVG-828

Summary
=======

The package polkit before version 0.115+24+g5230646-1 is vulnerable to
privilege escalation.

Resolution
==========

Upgrade to 0.115+24+g5230646-1.

# pacman -Syu "polkit>=0.115+24+g5230646-1"

The problem has been fixed upstream but no release is available yet.

Workaround
==========

None.

Description
===========

A security issue has been found in polkit <= 0.115, where an
unprivileged user with a UID > INT_MAX can successfully execute any
systemctl command.

Impact
======

A local, unprivileged user whose UID is larger than INT_MAX can
escalate privileges.

References
==========

https://seclists.org/oss-sec/2018/q4/198
https://gitlab.freedesktop.org/polkit/polkit/issues/74
https://gitlab.freedesktop.org/polkit/polkit/commit/2cb40c4d5feeaa09325522bd7d97910f1b59e379
https://security.archlinux.org/CVE-2018-19788



ASA-201901-3: elfutils: denial of service
Arch Linux Security Advisory ASA-201901-3
=========================================

Severity: Medium
Date : 2019-01-08
CVE-ID : CVE-2018-18310 CVE-2018-18520 CVE-2018-18521
Package : elfutils
Type : denial of service
Remote : Yes
Link : https://security.archlinux.org/AVG-785

Summary
=======

The package elfutils before version 0.175-1 is vulnerable to denial of
service.

Resolution
==========

Upgrade to 0.175-1.

# pacman -Syu "elfutils>=0.175-1"

The problems have been fixed upstream in version 0.175.

Workaround
==========

None.

Description
===========

- CVE-2018-18310 (denial of service)

An invalid memory address dereference was discovered in
dwfl_segment_report_module.c in libdwfl in elfutils through v0.174. The
vulnerability allows attackers to cause a denial of service
(application crash) with a crafted ELF file.

- CVE-2018-18520 (denial of service)

An Invalid Memory Address Dereference exists in the function elf_end in
libelf in elfutils through v0.174. Although eu-size is intended to
support ar files inside ar files, handle_ar in size.c closes the outer
ar file before handling all inner entries. The vulnerability allows
attackers to cause a denial of service (application crash) with a
crafted ELF file.

- CVE-2018-18521 (denial of service)

Divide-by-zero vulnerabilities in the function arlib_add_symbols() in
arlib.c in elfutils 0.174 allow remote attackers to cause a denial of
service (application crash) with a crafted ELF file, as demonstrated by
eu-ranlib, because a zero sh_entsize is mishandled.

Impact
======

An attacker can crash an application using one of the elfutils
libraries to parse files via a crafted ELF file.

References
==========

https://sourceware.org/bugzilla/show_bug.cgi?id=23752
https://sourceware.org/ml/elfutils-devel/2018-q4/msg00022.html
https://sourceware.org/bugzilla/show_bug.cgi?id=23787
https://sourceware.org/ml/elfutils-devel/2018-q4/msg00057.html
https://sourceware.org/bugzilla/show_bug.cgi?id=23786
https://sourceware.org/ml/elfutils-devel/2018-q4/msg00055.html
https://security.archlinux.org/CVE-2018-18310
https://security.archlinux.org/CVE-2018-18520
https://security.archlinux.org/CVE-2018-18521






Printed from Linux Compatible (https://www.linuxcompatible.org/news/story/tarpolkitelfutils_updates_for_arch_linux.html)