Sssd and File Updates for openSUSE
Posted on: 03/19/2019 07:18 AM

The following updates has been released for openSUSE:

openSUSE-SU-2019:0344-1: moderate: Security update for sssd
openSUSE-SU-2019:0345-1: moderate: Security update for file

openSUSE-SU-2019:0344-1: moderate: Security update for sssd
openSUSE Security Update: Security update for sssd
______________________________________________________________________________

Announcement ID: openSUSE-SU-2019:0344-1
Rating: moderate
References: #1004220 #1087320 #1120852 #1121759 #1125277

Cross-References: CVE-2019-3811
Affected Products:
openSUSE Leap 15.0
______________________________________________________________________________

An update that solves one vulnerability and has four fixes
is now available.

Description:

This update for sssd fixes the following issues:

Security vulnerability addresed:

- CVE-2019-3811: Fix fallback_homedir returning '/' for empty home
directories (bsc#1121759)

Other bug fixes and changes:

- Install logrotate configuration (bsc#1004220)
- Align systemd service file with upstream, run interactive and change
service type to notify (bsc#1120852)
- Fix sssd not starting in foreground mode (bsc#1125277)
- Strip whitespaces in netgroup triples (bsc#1087320)

This update was imported from the SUSE:SLE-15:Update update project.


Patch Instructions:

To install this openSUSE Security Update use the SUSE recommended installation methods
like YaST online_update or "zypper patch".

Alternatively you can run the command listed for your product:

- openSUSE Leap 15.0:

zypper in -t patch openSUSE-2019-344=1



Package List:

- openSUSE Leap 15.0 (i586 x86_64):

adcli-0.8.2-lp150.4.1
adcli-debuginfo-0.8.2-lp150.4.1
adcli-debugsource-0.8.2-lp150.4.1
adcli-doc-0.8.2-lp150.4.1
libipa_hbac-devel-1.16.1-lp150.2.9.1
libipa_hbac0-1.16.1-lp150.2.9.1
libipa_hbac0-debuginfo-1.16.1-lp150.2.9.1
libnfsidmap-sss-1.16.1-lp150.2.9.1
libnfsidmap-sss-debuginfo-1.16.1-lp150.2.9.1
libsss_certmap-devel-1.16.1-lp150.2.9.1
libsss_certmap0-1.16.1-lp150.2.9.1
libsss_certmap0-debuginfo-1.16.1-lp150.2.9.1
libsss_idmap-devel-1.16.1-lp150.2.9.1
libsss_idmap0-1.16.1-lp150.2.9.1
libsss_idmap0-debuginfo-1.16.1-lp150.2.9.1
libsss_nss_idmap-devel-1.16.1-lp150.2.9.1
libsss_nss_idmap0-1.16.1-lp150.2.9.1
libsss_nss_idmap0-debuginfo-1.16.1-lp150.2.9.1
libsss_simpleifp-devel-1.16.1-lp150.2.9.1
libsss_simpleifp0-1.16.1-lp150.2.9.1
libsss_simpleifp0-debuginfo-1.16.1-lp150.2.9.1
python3-ipa_hbac-1.16.1-lp150.2.9.1
python3-ipa_hbac-debuginfo-1.16.1-lp150.2.9.1
python3-sss-murmur-1.16.1-lp150.2.9.1
python3-sss-murmur-debuginfo-1.16.1-lp150.2.9.1
python3-sss_nss_idmap-1.16.1-lp150.2.9.1
python3-sss_nss_idmap-debuginfo-1.16.1-lp150.2.9.1
python3-sssd-config-1.16.1-lp150.2.9.1
python3-sssd-config-debuginfo-1.16.1-lp150.2.9.1
sssd-1.16.1-lp150.2.9.1
sssd-ad-1.16.1-lp150.2.9.1
sssd-ad-debuginfo-1.16.1-lp150.2.9.1
sssd-dbus-1.16.1-lp150.2.9.1
sssd-dbus-debuginfo-1.16.1-lp150.2.9.1
sssd-debuginfo-1.16.1-lp150.2.9.1
sssd-debugsource-1.16.1-lp150.2.9.1
sssd-ipa-1.16.1-lp150.2.9.1
sssd-ipa-debuginfo-1.16.1-lp150.2.9.1
sssd-krb5-1.16.1-lp150.2.9.1
sssd-krb5-common-1.16.1-lp150.2.9.1
sssd-krb5-common-debuginfo-1.16.1-lp150.2.9.1
sssd-krb5-debuginfo-1.16.1-lp150.2.9.1
sssd-ldap-1.16.1-lp150.2.9.1
sssd-ldap-debuginfo-1.16.1-lp150.2.9.1
sssd-proxy-1.16.1-lp150.2.9.1
sssd-proxy-debuginfo-1.16.1-lp150.2.9.1
sssd-tools-1.16.1-lp150.2.9.1
sssd-tools-debuginfo-1.16.1-lp150.2.9.1
sssd-wbclient-1.16.1-lp150.2.9.1
sssd-wbclient-debuginfo-1.16.1-lp150.2.9.1
sssd-wbclient-devel-1.16.1-lp150.2.9.1
sssd-winbind-idmap-1.16.1-lp150.2.9.1
sssd-winbind-idmap-debuginfo-1.16.1-lp150.2.9.1

- openSUSE Leap 15.0 (x86_64):

sssd-32bit-1.16.1-lp150.2.9.1
sssd-32bit-debuginfo-1.16.1-lp150.2.9.1


References:

https://www.suse.com/security/cve/CVE-2019-3811.html
https://bugzilla.suse.com/1004220
https://bugzilla.suse.com/1087320
https://bugzilla.suse.com/1120852
https://bugzilla.suse.com/1121759
https://bugzilla.suse.com/1125277

--



openSUSE-SU-2019:0345-1: moderate: Security update for file
openSUSE Security Update: Security update for file
______________________________________________________________________________

Announcement ID: openSUSE-SU-2019:0345-1
Rating: moderate
References: #1096974 #1096984 #1126117 #1126118 #1126119

Cross-References: CVE-2018-10360 CVE-2019-8905 CVE-2019-8906
CVE-2019-8907
Affected Products:
openSUSE Leap 15.0
______________________________________________________________________________

An update that solves four vulnerabilities and has one
errata is now available.

Description:

This update for file fixes the following issues:

The following security vulnerabilities were addressed:

- CVE-2018-10360: Fixed an out-of-bounds read in the function do_core_note
in readelf.c, which allowed remote attackers to cause a denial of
service (application crash) via a crafted ELF file (bsc#1096974)
- CVE-2019-8905: Fixed a stack-based buffer over-read in do_core_note in
readelf.c (bsc#1126118)
- CVE-2019-8906: Fixed an out-of-bounds read in do_core_note in readelf. c
(bsc#1126119)
- CVE-2019-8907: Fixed a stack corruption in do_core_note in readelf.c
(bsc#1126117)

This update was imported from the SUSE:SLE-15:Update update project.


Patch Instructions:

To install this openSUSE Security Update use the SUSE recommended installation methods
like YaST online_update or "zypper patch".

Alternatively you can run the command listed for your product:

- openSUSE Leap 15.0:

zypper in -t patch openSUSE-2019-345=1



Package List:

- openSUSE Leap 15.0 (i586 x86_64):

file-5.32-lp150.6.3.1
file-debuginfo-5.32-lp150.6.3.1
file-debugsource-5.32-lp150.6.3.1
file-devel-5.32-lp150.6.3.1
libmagic1-5.32-lp150.6.3.1
libmagic1-debuginfo-5.32-lp150.6.3.1
python2-magic-5.32-lp150.6.3.1
python3-magic-5.32-lp150.6.3.1

- openSUSE Leap 15.0 (x86_64):

file-devel-32bit-5.32-lp150.6.3.1
libmagic1-32bit-5.32-lp150.6.3.1
libmagic1-32bit-debuginfo-5.32-lp150.6.3.1

- openSUSE Leap 15.0 (noarch):

file-magic-5.32-lp150.6.3.1


References:

https://www.suse.com/security/cve/CVE-2018-10360.html
https://www.suse.com/security/cve/CVE-2019-8905.html
https://www.suse.com/security/cve/CVE-2019-8906.html
https://www.suse.com/security/cve/CVE-2019-8907.html
https://bugzilla.suse.com/1096974
https://bugzilla.suse.com/1096984
https://bugzilla.suse.com/1126117
https://bugzilla.suse.com/1126118
https://bugzilla.suse.com/1126119

--






Printed from Linux Compatible (https://www.linuxcompatible.org/news/story/sssd_and_file_updates_for_opensuse.html)