Squid and Libmspack Updates for Ubuntu Linux
Posted on: 07/19/2019 06:58 AM

Updated Squid and Libmspack packages has been released for Ubuntu Linux:

USN-4065-1: Squid vulnerabilities
USN-4066-1: libmspack vulnerability

USN-4065-1: Squid vulnerabilities

==========================================================================
Ubuntu Security Notice USN-4065-1
July 18, 2019

squid, squid3 vulnerabilities
==========================================================================

A security issue affects these releases of Ubuntu and its derivatives:

- Ubuntu 19.04
- Ubuntu 18.04 LTS
- Ubuntu 16.04 LTS

Summary:

Several security issues were fixed in Squid.

Software Description:
- squid: Web proxy cache server
- squid3: Web proxy cache server

Details:

It was discovered that Squid incorrectly handled Digest authentication. A
remote attacker could possibly use this issue to cause Squid to crash,
resulting in a denial of service. (CVE-2019-12525)

It was discovered that Squid incorrectly handled Basic authentication. A
remote attacker could use this issue to cause Squid to crash, resulting in
a denial of service, or possibly execute arbitrary code. This issue only
affected Ubuntu 19.04. (CVE-2019-12527)

It was discovered that Squid incorrectly handled Basic authentication. A
remote attacker could possibly use this issue to cause Squid to crash,
resulting in a denial of service. (CVE-2019-12529)

Update instructions:

The problem can be corrected by updating your system to the following
package versions:

Ubuntu 19.04:
squid 4.4-1ubuntu2.2

Ubuntu 18.04 LTS:
squid3 3.5.27-1ubuntu1.3

Ubuntu 16.04 LTS:
squid3 3.5.12-1ubuntu7.8

In general, a standard system update will make all the necessary changes.

References:
https://usn.ubuntu.com/4065-1
CVE-2019-12525, CVE-2019-12527, CVE-2019-12529

Package Information:
https://launchpad.net/ubuntu/+source/squid/4.4-1ubuntu2.2
https://launchpad.net/ubuntu/+source/squid3/3.5.27-1ubuntu1.3
https://launchpad.net/ubuntu/+source/squid3/3.5.12-1ubuntu7.8

USN-4066-1: libmspack vulnerability
=========================================================================
Ubuntu Security Notice USN-4066-1
July 18, 2019

libmspack vulnerability
=========================================================================
A security issue affects these releases of Ubuntu and its derivatives:

- Ubuntu 18.04 LTS
- Ubuntu 16.04 LTS

Summary:

libmspack could be made to expose sensitive information if it received
a specially crafted CHM file.

Software Description:
- libmspack: library for Microsoft compression formats

Details:

It was discovered that libmspack incorrectly handled certain CHM files.
A remote attacker could possibly use this issue to access sensitive information.

Update instructions:

The problem can be corrected by updating your system to the following
package versions:

Ubuntu 18.04 LTS:
libmspack0 0.6-3ubuntu0.3

Ubuntu 16.04 LTS:
libmspack0 0.5-1ubuntu0.16.04.4

In general, a standard system update will make all the necessary changes.

References:
https://usn.ubuntu.com/4066-1
CVE-2019-1010305

Package Information:
https://launchpad.net/ubuntu/+source/libmspack/0.6-3ubuntu0.3
https://launchpad.net/ubuntu/+source/libmspack/0.5-1ubuntu0.16.04.4





Printed from Linux Compatible (https://www.linuxcompatible.org/news/story/squid_and_libmspack_updates_for_ubuntu_linux.html)