SQlite3, SDL, Blktrace, Flac, Xen, Lxc, Pspp, Aubio Updates for openSUSE
Posted on: 04/18/2019 06:06 AM

The following updates has been released for openSUSE:

openSUSE-SU-2019:1222-1: moderate: Security update for sqlite3
openSUSE-SU-2019:1223-1: moderate: Security update for SDL
openSUSE-SU-2019:1224-1: Security update for blktrace
openSUSE-SU-2019:1225-1: Security update for flac
openSUSE-SU-2019:1226-1: important: Security update for xen
openSUSE-SU-2019:1227-1: important: Security update for lxc, lxcfs
openSUSE-SU-2019:1228-1: moderate: Security update for pspp
openSUSE-SU-2019:1229-1: moderate: Security update for aubio

openSUSE-SU-2019:1222-1: moderate: Security update for sqlite3
openSUSE Security Update: Security update for sqlite3
______________________________________________________________________________

Announcement ID: openSUSE-SU-2019:1222-1
Rating: moderate
References: #1119687 #1131576
Cross-References: CVE-2018-20346 CVE-2018-20506
Affected Products:
openSUSE Leap 42.3
______________________________________________________________________________

An update that fixes two vulnerabilities is now available.

Description:

This update for sqlite3 fixes the following issues:

Security issues fixed:

- CVE-2018-20346: Fixed a remote code execution vulnerability in FTS3
(Magellan) (bsc#1119687).
- CVE-2018-20506: Fixed an integer overflow when FTS3 extension is enabled
(bsc#1131576).

This update was imported from the SUSE:SLE-12-SP1:Update update project.


Patch Instructions:

To install this openSUSE Security Update use the SUSE recommended installation methods
like YaST online_update or "zypper patch".

Alternatively you can run the command listed for your product:

- openSUSE Leap 42.3:

zypper in -t patch openSUSE-2019-1222=1



Package List:

- openSUSE Leap 42.3 (i586 x86_64):

libsqlite3-0-3.8.10.2-11.3.1
libsqlite3-0-debuginfo-3.8.10.2-11.3.1
sqlite3-3.8.10.2-11.3.1
sqlite3-debuginfo-3.8.10.2-11.3.1
sqlite3-debugsource-3.8.10.2-11.3.1
sqlite3-devel-3.8.10.2-11.3.1

- openSUSE Leap 42.3 (x86_64):

libsqlite3-0-32bit-3.8.10.2-11.3.1
libsqlite3-0-debuginfo-32bit-3.8.10.2-11.3.1

- openSUSE Leap 42.3 (noarch):

sqlite3-doc-3.8.10.2-11.3.1


References:

https://www.suse.com/security/cve/CVE-2018-20346.html
https://www.suse.com/security/cve/CVE-2018-20506.html
https://bugzilla.suse.com/1119687
https://bugzilla.suse.com/1131576

--



openSUSE-SU-2019:1223-1: moderate: Security update for SDL
openSUSE Security Update: Security update for SDL
______________________________________________________________________________

Announcement ID: openSUSE-SU-2019:1223-1
Rating: moderate
References: #1124799 #1124800 #1124802 #1124803 #1124805
#1124806 #1124824 #1124825 #1124826 #1124827
#1125099
Cross-References: CVE-2019-7572 CVE-2019-7573 CVE-2019-7574
CVE-2019-7575 CVE-2019-7576 CVE-2019-7577
CVE-2019-7578 CVE-2019-7635 CVE-2019-7636
CVE-2019-7637 CVE-2019-7638
Affected Products:
openSUSE Leap 15.0
______________________________________________________________________________

An update that fixes 11 vulnerabilities is now available.

Description:

This update for SDL fixes the following issues:

Security issues fixed:

- CVE-2019-7572: Fixed a buffer over-read in IMA_ADPCM_nibble in
audio/SDL_wave.c.(bsc#1124806).
- CVE-2019-7578: Fixed a heap-based buffer over-read in InitIMA_ADPCM in
audio/SDL_wave.c (bsc#1125099).
- CVE-2019-7576: Fixed heap-based buffer over-read in InitMS_ADPCM in
audio/SDL_wave.c (bsc#1124799).
- CVE-2019-7573: Fixed a heap-based buffer over-read in InitMS_ADPCM in
audio/SDL_wave.c (bsc#1124805).
- CVE-2019-7635: Fixed a heap-based buffer over-read in Blit1to4 in
video/SDL_blit_1.c. (bsc#1124827).
- CVE-2019-7636: Fixed a heap-based buffer over-read in SDL_GetRGB in
video/SDL_pixels.c (bsc#1124826).
- CVE-2019-7638: Fixed a heap-based buffer over-read in Map1toN in
video/SDL_pixels.c (bsc#1124824).
- CVE-2019-7574: Fixed a heap-based buffer over-read in IMA_ADPCM_decode
in audio/SDL_wave.c (bsc#1124803).
- CVE-2019-7575: Fixed a heap-based buffer overflow in MS_ADPCM_decode in
audio/SDL_wave.c (bsc#1124802).
- CVE-2019-7637: Fixed a heap-based buffer overflow in SDL_FillRect
function in SDL_surface.c (bsc#1124825).
- CVE-2019-7577: Fixed a buffer over read in SDL_LoadWAV_RW in
audio/SDL_wave.c (bsc#1124800).

This update was imported from the SUSE:SLE-15:Update update project.


Patch Instructions:

To install this openSUSE Security Update use the SUSE recommended installation methods
like YaST online_update or "zypper patch".

Alternatively you can run the command listed for your product:

- openSUSE Leap 15.0:

zypper in -t patch openSUSE-2019-1223=1



Package List:

- openSUSE Leap 15.0 (i586 x86_64):

SDL-debugsource-1.2.15-lp150.2.3.1
libSDL-1_2-0-1.2.15-lp150.2.3.1
libSDL-1_2-0-debuginfo-1.2.15-lp150.2.3.1
libSDL-devel-1.2.15-lp150.2.3.1

- openSUSE Leap 15.0 (x86_64):

libSDL-1_2-0-32bit-1.2.15-lp150.2.3.1
libSDL-1_2-0-32bit-debuginfo-1.2.15-lp150.2.3.1
libSDL-devel-32bit-1.2.15-lp150.2.3.1


References:

https://www.suse.com/security/cve/CVE-2019-7572.html
https://www.suse.com/security/cve/CVE-2019-7573.html
https://www.suse.com/security/cve/CVE-2019-7574.html
https://www.suse.com/security/cve/CVE-2019-7575.html
https://www.suse.com/security/cve/CVE-2019-7576.html
https://www.suse.com/security/cve/CVE-2019-7577.html
https://www.suse.com/security/cve/CVE-2019-7578.html
https://www.suse.com/security/cve/CVE-2019-7635.html
https://www.suse.com/security/cve/CVE-2019-7636.html
https://www.suse.com/security/cve/CVE-2019-7637.html
https://www.suse.com/security/cve/CVE-2019-7638.html
https://bugzilla.suse.com/1124799
https://bugzilla.suse.com/1124800
https://bugzilla.suse.com/1124802
https://bugzilla.suse.com/1124803
https://bugzilla.suse.com/1124805
https://bugzilla.suse.com/1124806
https://bugzilla.suse.com/1124824
https://bugzilla.suse.com/1124825
https://bugzilla.suse.com/1124826
https://bugzilla.suse.com/1124827
https://bugzilla.suse.com/1125099

--



openSUSE-SU-2019:1224-1: Security update for blktrace
openSUSE Security Update: Security update for blktrace
______________________________________________________________________________

Announcement ID: openSUSE-SU-2019:1224-1
Rating: low
References: #1091942
Cross-References: CVE-2018-10689
Affected Products:
openSUSE Leap 15.0
______________________________________________________________________________

An update that fixes one vulnerability is now available.

Description:

This update for blktrace fixes the following issues:

- CVE-2018-10689: Prevent buffer overflow in the dev_map_read function
because the device and devno arrays were too small (bsc#1091942)

This update was imported from the SUSE:SLE-15:Update update project.


Patch Instructions:

To install this openSUSE Security Update use the SUSE recommended installation methods
like YaST online_update or "zypper patch".

Alternatively you can run the command listed for your product:

- openSUSE Leap 15.0:

zypper in -t patch openSUSE-2019-1224=1



Package List:

- openSUSE Leap 15.0 (x86_64):

blktrace-1.1.0+git.20170126-lp150.2.3.1
blktrace-debuginfo-1.1.0+git.20170126-lp150.2.3.1
blktrace-debugsource-1.1.0+git.20170126-lp150.2.3.1


References:

https://www.suse.com/security/cve/CVE-2018-10689.html
https://bugzilla.suse.com/1091942

--



openSUSE-SU-2019:1225-1: Security update for flac
openSUSE Security Update: Security update for flac
______________________________________________________________________________

Announcement ID: openSUSE-SU-2019:1225-1
Rating: low
References: #1091045
Cross-References: CVE-2017-6888
Affected Products:
openSUSE Leap 15.0
______________________________________________________________________________

An update that fixes one vulnerability is now available.

Description:

This update for flac fixes the following issues:

- CVE-2017-6888: An error in the "read_metadata_vorbiscomment_()" function
could be exploited to cause a memory leak via a specially crafted FLAC
file (bsc#1091045).

This update was imported from the SUSE:SLE-15:Update update project.


Patch Instructions:

To install this openSUSE Security Update use the SUSE recommended installation methods
like YaST online_update or "zypper patch".

Alternatively you can run the command listed for your product:

- openSUSE Leap 15.0:

zypper in -t patch openSUSE-2019-1225=1



Package List:

- openSUSE Leap 15.0 (i586 x86_64):

flac-1.3.2-lp150.2.3.1
flac-debuginfo-1.3.2-lp150.2.3.1
flac-debugsource-1.3.2-lp150.2.3.1
flac-devel-1.3.2-lp150.2.3.1
libFLAC++6-1.3.2-lp150.2.3.1
libFLAC++6-debuginfo-1.3.2-lp150.2.3.1
libFLAC8-1.3.2-lp150.2.3.1
libFLAC8-debuginfo-1.3.2-lp150.2.3.1

- openSUSE Leap 15.0 (noarch):

flac-doc-1.3.2-lp150.2.3.1

- openSUSE Leap 15.0 (x86_64):

flac-devel-32bit-1.3.2-lp150.2.3.1
libFLAC++6-32bit-1.3.2-lp150.2.3.1
libFLAC++6-32bit-debuginfo-1.3.2-lp150.2.3.1
libFLAC8-32bit-1.3.2-lp150.2.3.1
libFLAC8-32bit-debuginfo-1.3.2-lp150.2.3.1


References:

https://www.suse.com/security/cve/CVE-2017-6888.html
https://bugzilla.suse.com/1091045

--



openSUSE-SU-2019:1226-1: important: Security update for xen
openSUSE Security Update: Security update for xen
______________________________________________________________________________

Announcement ID: openSUSE-SU-2019:1226-1
Rating: important
References: #1026236 #1027519 #1069468 #1105528 #1114988
#1115040 #1115045 #1115047 #1116380 #1117756
#1119161 #1123157 #1126140 #1126141 #1126192
#1126195 #1126196 #1126197 #1126198 #1126201
#1126325 #1127400 #1129623
Cross-References: CVE-2018-19665 CVE-2018-19961 CVE-2018-19962
CVE-2018-19965 CVE-2018-19966 CVE-2018-19967
CVE-2019-6778 CVE-2019-9824
Affected Products:
openSUSE Leap 42.3
______________________________________________________________________________

An update that solves 8 vulnerabilities and has 15 fixes is
now available.

Description:

This update for xen fixes the following issues:

Security issues fixed:

- CVE-2018-19967: Fixed HLE constructs that allowed guests to lock up the
host, resulting in a Denial of Service (DoS). (XSA-282) (bsc#1114988)
- CVE-2019-6778: Fixed a heap buffer overflow in tcp_emu() found in slirp
(bsc#1123157).
- Fixed an issue which could allow malicious or buggy guests with passed
through PCI devices to be able to escalate their privileges, crash the
host, or access data belonging to other guests. Additionally memory
leaks were also possible (bsc#1126140).
- Fixed a race condition issue which could allow malicious PV guests to
escalate their privilege to that
of the hypervisor (bsc#1126141).
- Fixed an issue which could allow a malicious unprivileged guest
userspace process to escalate its privilege to that of other userspace
processes in the same guest and potentially thereby to that
of the guest operating system (bsc#1126201).
- CVE-2019-9824: Fixed an information leak in SLiRP networking
implementation which could allow a user/process to read uninitialised
stack memory contents (bsc#1129623).
- CVE-2018-19961 CVE-2018-19962: Fixed insufficient TLB flushing /
improper large page mappings with AMD IOMMUs (XSA-275)(bsc#1115040).
- CVE-2018-19965: Fixed denial of service issue from attempting to use
INVPCID with a non-canonical addresses (XSA-279)(bsc#1115045).
- CVE-2018-19966: Fixed issue introduced by XSA-240 that could have caused
conflicts with shadow paging (XSA-280)(bsc#1115047).
- Fixed an issue which could allow malicious PV guests may cause a host
crash or gain access to data pertaining to other guests.Additionally,
vulnerable configurations are likely to be unstable even in the absence
of an attack (bsc#1126198).
- Fixed multiple access violations introduced by XENMEM_exchange hypercall
which could allow a single PV guest to leak arbitrary amounts of memory,
leading to a denial of service (bsc#1126192).
- Fixed an issue which could allow malicious 64bit PV guests to cause a
host crash (bsc#1127400).
- Fixed an issue which could allow malicious or buggy x86 PV guest kernels
to mount a Denial of Service attack affecting the whole system
(bsc#1126197).
- Fixed an issue which could allow an untrusted PV domain with access to a
physical device to DMA into its own pagetables leading to privilege
escalation (bsc#1126195).
- Fixed an issue which could allow a malicious or buggy x86 PV guest
kernels can mount a Denial of Service attack affecting the whole system
(bsc#1126196).

Other issues addressed:

- Upstream bug fixes (bsc#1027519)
- Fixed an issue where live migrations were failing when spectre was
enabled on xen boot cmdline (bsc#1116380).
- Fixed an issue where setup of grant_tables and other variables may fail
(bsc#1126325).
- Fixed a building issue (bsc#1119161).
- Fixed an issue where xpti=no-dom0 was not working as expected
(bsc#1105528).
- Packages should no longer use /var/adm/fillup-templates (bsc#1069468).
- Added Xen cmdline option "suse_vtsc_tolerance" to avoid TSC emulation
for HVM domUs (bsc#1026236).

This update was imported from the SUSE:SLE-12-SP3:Update update project.


Patch Instructions:

To install this openSUSE Security Update use the SUSE recommended installation methods
like YaST online_update or "zypper patch".

Alternatively you can run the command listed for your product:

- openSUSE Leap 42.3:

zypper in -t patch openSUSE-2019-1226=1



Package List:

- openSUSE Leap 42.3 (i586 x86_64):

xen-debugsource-4.9.4_02-37.1
xen-devel-4.9.4_02-37.1
xen-libs-4.9.4_02-37.1
xen-libs-debuginfo-4.9.4_02-37.1
xen-tools-domU-4.9.4_02-37.1
xen-tools-domU-debuginfo-4.9.4_02-37.1

- openSUSE Leap 42.3 (x86_64):

xen-4.9.4_02-37.1
xen-doc-html-4.9.4_02-37.1
xen-libs-32bit-4.9.4_02-37.1
xen-libs-debuginfo-32bit-4.9.4_02-37.1
xen-tools-4.9.4_02-37.1
xen-tools-debuginfo-4.9.4_02-37.1


References:

https://www.suse.com/security/cve/CVE-2018-19665.html
https://www.suse.com/security/cve/CVE-2018-19961.html
https://www.suse.com/security/cve/CVE-2018-19962.html
https://www.suse.com/security/cve/CVE-2018-19965.html
https://www.suse.com/security/cve/CVE-2018-19966.html
https://www.suse.com/security/cve/CVE-2018-19967.html
https://www.suse.com/security/cve/CVE-2019-6778.html
https://www.suse.com/security/cve/CVE-2019-9824.html
https://bugzilla.suse.com/1026236
https://bugzilla.suse.com/1027519
https://bugzilla.suse.com/1069468
https://bugzilla.suse.com/1105528
https://bugzilla.suse.com/1114988
https://bugzilla.suse.com/1115040
https://bugzilla.suse.com/1115045
https://bugzilla.suse.com/1115047
https://bugzilla.suse.com/1116380
https://bugzilla.suse.com/1117756
https://bugzilla.suse.com/1119161
https://bugzilla.suse.com/1123157
https://bugzilla.suse.com/1126140
https://bugzilla.suse.com/1126141
https://bugzilla.suse.com/1126192
https://bugzilla.suse.com/1126195
https://bugzilla.suse.com/1126196
https://bugzilla.suse.com/1126197
https://bugzilla.suse.com/1126198
https://bugzilla.suse.com/1126201
https://bugzilla.suse.com/1126325
https://bugzilla.suse.com/1127400
https://bugzilla.suse.com/1129623

--



openSUSE-SU-2019:1227-1: important: Security update for lxc, lxcfs
openSUSE Security Update: Security update for lxc, lxcfs
______________________________________________________________________________

Announcement ID: openSUSE-SU-2019:1227-1
Rating: important
References: #1122185 #1131762 #988348
Cross-References: CVE-2018-6556 CVE-2019-5736
Affected Products:
openSUSE Backports SLE-15
______________________________________________________________________________

An update that solves two vulnerabilities and has one
errata is now available.

Description:

This update for lxc, lxcfs to version 3.1.0 fixes the following issues:

Security issues fixed:

- CVE-2019-5736: Fixed a container breakout vulnerability (boo#1122185).
- CVE-2018-6556: Enable setuid bit on lxc-user-nic (boo#988348).

Non-security issues fixed:

- Update to LXC 3.1.0. The changelog is far too long to include here,
please look at https://linuxcontainers.org/. (boo#1131762)


Patch Instructions:

To install this openSUSE Security Update use the SUSE recommended installation methods
like YaST online_update or "zypper patch".

Alternatively you can run the command listed for your product:

- openSUSE Backports SLE-15:

zypper in -t patch openSUSE-2019-1227=1



Package List:

- openSUSE Backports SLE-15 (aarch64 ppc64le s390x x86_64):

liblxc-devel-3.1.0-bp150.5.3.1
liblxc1-3.1.0-bp150.5.3.1
lxc-3.1.0-bp150.5.3.1
lxcfs-3.0.3-bp150.3.3.1
lxcfs-debuginfo-3.0.3-bp150.3.3.1
lxcfs-debugsource-3.0.3-bp150.3.3.1
pam_cgfs-3.1.0-bp150.5.3.1

- openSUSE Backports SLE-15 (noarch):

lxc-bash-completion-3.1.0-bp150.5.3.1
lxcfs-hooks-lxc-3.0.3-bp150.3.3.1


References:

https://www.suse.com/security/cve/CVE-2018-6556.html
https://www.suse.com/security/cve/CVE-2019-5736.html
https://bugzilla.suse.com/1122185
https://bugzilla.suse.com/1131762
https://bugzilla.suse.com/988348

--



openSUSE-SU-2019:1228-1: moderate: Security update for pspp
openSUSE Security Update: Security update for pspp
______________________________________________________________________________

Announcement ID: openSUSE-SU-2019:1228-1
Rating: moderate
References: #1127343
Cross-References: CVE-2019-9211
Affected Products:
openSUSE Backports SLE-15
______________________________________________________________________________

An update that fixes one vulnerability is now available.

Description:

This update for pspp fixes the following issues:

- CVE-2019-9211: Handle a reachable assertion in
write_long_string_missing_values() in libdata.a that could have lead to
denial of service. (boo#1127343).

- Remove excessive -n argument to %build, and excessive %defattr lines.

This update was imported from the openSUSE:Leap:15.0:Update update project.


Patch Instructions:

To install this openSUSE Security Update use the SUSE recommended installation methods
like YaST online_update or "zypper patch".

Alternatively you can run the command listed for your product:

- openSUSE Backports SLE-15:

zypper in -t patch openSUSE-2019-1228=1



Package List:

- openSUSE Backports SLE-15 (aarch64 ppc64le s390x x86_64):

pspp-1.2.0-bp150.3.6.1
pspp-devel-1.2.0-bp150.3.6.1


References:

https://www.suse.com/security/cve/CVE-2019-9211.html
https://bugzilla.suse.com/1127343

--



openSUSE-SU-2019:1229-1: moderate: Security update for aubio
openSUSE Security Update: Security update for aubio
______________________________________________________________________________

Announcement ID: openSUSE-SU-2019:1229-1
Rating: moderate
References: #1102359 #1102364
Cross-References: CVE-2018-14522 CVE-2018-14523
Affected Products:
openSUSE Backports SLE-15
______________________________________________________________________________

An update that fixes two vulnerabilities is now available.

Description:

This update for aubio fixes the following issues:

- CVE-2018-14522: Fixed a crash in aubio_pitch_set_unit (bsc#1102359)
- CVE-2018-14523: Fixed a buffer overrread resulting in crash or
information leakage in new_aubio_pitchyinfft (bsc#1102364)

This update was imported from the openSUSE:Leap:15.0:Update update project.


Patch Instructions:

To install this openSUSE Security Update use the SUSE recommended installation methods
like YaST online_update or "zypper patch".

Alternatively you can run the command listed for your product:

- openSUSE Backports SLE-15:

zypper in -t patch openSUSE-2019-1229=1



Package List:

- openSUSE Backports SLE-15 (aarch64 ppc64le s390x x86_64):

python-aubio-debugsource-0.4.6-bp150.3.9.1
python2-aubio-0.4.6-bp150.3.9.1
python2-aubio-debuginfo-0.4.6-bp150.3.9.1
python3-aubio-0.4.6-bp150.3.9.1
python3-aubio-debuginfo-0.4.6-bp150.3.9.1

- openSUSE Backports SLE-15 (x86_64):

aubio-tools-0.4.6-bp150.3.9.1
libaubio-devel-0.4.6-bp150.3.9.1
libaubio5-0.4.6-bp150.3.9.1


References:

https://www.suse.com/security/cve/CVE-2018-14522.html
https://www.suse.com/security/cve/CVE-2018-14523.html
https://bugzilla.suse.com/1102359
https://bugzilla.suse.com/1102364

--






Printed from Linux Compatible (https://www.linuxcompatible.org/news/story/sqlite3sdlblktraceflacxenlxcpsppaubio_updates_for_opensuse.html)