Simple DirectMedia Layer and D-Bus Updates for Gentoo Linux
Posted on: 09/09/2019 07:53 AM

The following security updates has been released for Gentoo Linux:

GLSA 201909-07 : Simple DirectMedia Layer: Multiple vulnerabilities
GLSA 201909-08 : D-Bus: Authentication bypass

GLSA 201909-07 : Simple DirectMedia Layer: Multiple vulnerabilities
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory GLSA 201909-07
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
https://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Severity: Normal
Title: Simple DirectMedia Layer: Multiple vulnerabilities
Date: September 08, 2019
Bugs: #690064, #692392
ID: 201909-07

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
========

Multiple vulnerabilities have been found in Simple DirectMedia Layer,
the worst of which could result in the arbitrary execution of code.

Background
==========

Simple DirectMedia Layer is a cross-platform development library
designed to provide low level access to audio, keyboard, mouse,
joystick, and graphics hardware via OpenGL and Direct3D.

Affected packages
=================

-------------------------------------------------------------------
Package / Vulnerable / Unaffected
-------------------------------------------------------------------
1 media-libs/libsdl2 < 2.0.10 >= 2.0.10

Description
===========

Multiple vulnerabilities have been discovered in Simple DirectMedia
Layer. Please review the CVE identifiers referenced below for details.

Impact
======

A remote attacker could entice a user to process a specially crafted
audio or video, possibly resulting in execution of arbitrary code with
the privileges of the process or a Denial of Service condition.

Workaround
==========

There is no known workaround at this time.

Resolution
==========

All Simple DirectMedia Layer users should upgrade to the latest
version:

# emerge --sync
# emerge --ask --oneshot --verbose ">=media-libs/libsdl2-2.0.10"

References
==========

[ 1 ] CVE-2019-13626
https://nvd.nist.gov/vuln/detail/CVE-2019-13626
[ 2 ] CVE-2019-7572
https://nvd.nist.gov/vuln/detail/CVE-2019-7572
[ 3 ] CVE-2019-7573
https://nvd.nist.gov/vuln/detail/CVE-2019-7573
[ 4 ] CVE-2019-7574
https://nvd.nist.gov/vuln/detail/CVE-2019-7574
[ 5 ] CVE-2019-7575
https://nvd.nist.gov/vuln/detail/CVE-2019-7575
[ 6 ] CVE-2019-7576
https://nvd.nist.gov/vuln/detail/CVE-2019-7576
[ 7 ] CVE-2019-7577
https://nvd.nist.gov/vuln/detail/CVE-2019-7577
[ 8 ] CVE-2019-7578
https://nvd.nist.gov/vuln/detail/CVE-2019-7578
[ 9 ] CVE-2019-7635
https://nvd.nist.gov/vuln/detail/CVE-2019-7635
[ 10 ] CVE-2019-7636
https://nvd.nist.gov/vuln/detail/CVE-2019-7636
[ 11 ] CVE-2019-7638
https://nvd.nist.gov/vuln/detail/CVE-2019-7638

Availability
============

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

https://security.gentoo.org/glsa/201909-07

Concerns?
=========

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users' machines is of utmost
importance to us. Any security concerns should be addressed to
security@gentoo.org or alternatively, you may file a bug at
https://bugs.gentoo.org.

License
=======

Copyright 2019 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

https://creativecommons.org/licenses/by-sa/2.5



GLSA 201909-08 : D-Bus: Authentication bypass
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory GLSA 201909-08
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
https://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Severity: Normal
Title: D-Bus: Authentication bypass
Date: September 08, 2019
Bugs: #687900
ID: 201909-08

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
========

An authentication bypass was discovered in D-Bus.

Background
==========

D-Bus is a message bus system which processes can use to talk to each
other.

Affected packages
=================

-------------------------------------------------------------------
Package / Vulnerable / Unaffected
-------------------------------------------------------------------
1 sys-apps/dbus < 1.12.16 >= 1.12.16

Description
===========

It was discovered that a local attacker could manipulate symbolic links
in their own home directory to bypass authentication and connect to a
DBusServer with elevated privileges.

Impact
======

A local attacker can bypass authentication mechanisms and elevate
privileges.

Workaround
==========

There is no known workaround at this time.

Resolution
==========

All D-Bus users should upgrade to the latest version:

# emerge --sync
# emerge --ask --oneshot --verbose ">=sys-apps/dbus-1.12.16"

References
==========

[ 1 ] CVE-2019-12749
https://nvd.nist.gov/vuln/detail/CVE-2019-12749

Availability
============

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

https://security.gentoo.org/glsa/201909-08

Concerns?
=========

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users' machines is of utmost
importance to us. Any security concerns should be addressed to
security@gentoo.org or alternatively, you may file a bug at
https://bugs.gentoo.org.

License
=======

Copyright 2019 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

https://creativecommons.org/licenses/by-sa/2.5




Printed from Linux Compatible (https://www.linuxcompatible.org/news/story/simple_directmedia_layer_and_d_bus_updates_for_gentoo_linux.html)