Qutebrowser Security Update for Arch Linux
Posted on: 07/12/2018 08:31 AM

Updated qutebrowser packages has been released for Arch Linux

Qutebrowser Security Update for Arch Linux


Arch Linux Security Advisory ASA-201807-3
=========================================

Severity: Critical
Date : 2018-07-11
CVE-ID : CVE-2018-10895
Package : qutebrowser
Type : arbitrary code execution
Remote : Yes
Link : https://security.archlinux.org/AVG-735

Summary
=======

The package qutebrowser before version 1.4.1-1 is vulnerable to
arbitrary code execution.

Resolution
==========

Upgrade to 1.4.1-1.

# pacman -Syu "qutebrowser>=1.4.1-1"

The problem has been fixed upstream in version 1.4.1.

Workaround
==========

It's possible to patch out the vulnerable code via a config.py file

from qutebrowser.browser import qutescheme
qutescheme._qute_settings_set = lambda url: ('text/html', '')

Description
===========

Due to a CSRF vulnerability affecting the qute://settings page, it was
possible for websites to modify qutebrowser settings. Via settings like
editor.command, this possibly allowed websites to execute arbitrary
code.

Impact
======

A remote attacker is able to execute code with a specially crafted web
page.

References
==========

https://github.com/qutebrowser/qutebrowser/commit/43e58ac865ff862c2008c510fc5f7627e10b4660
https://github.com/qutebrowser/qutebrowser/issues/4060
https://security.archlinux.org/CVE-2018-10895



Printed from Linux Compatible (https://www.linuxcompatible.org/news/story/qutebrowser_security_update_for_arch_linux.html)