Qt4-X11 and CUPS-Filters Updates for Debian
Posted on: 05/14/2019 07:14 AM

The following updates has been released for Debian GNU/Linux:

Debian GNU/Linux 8 LTS:
DLA 1786-1: qt4-x11 security update

Debian GNU/Linux 9:
DSA 4442-2: cups-filters regression update

DLA 1786-1: qt4-x11 security update
Package : qt4-x11
Version : 4:4.8.6+git64-g5dc8b2b+dfsg-3+deb8u2
CVE ID : CVE-2018-15518 CVE-2018-19869 CVE-2018-19870 CVE-2018-19871
CVE-2018-19873
Debian Bug : #923003


Multiple issues have been addressed in Qt4.

CVE-2018-15518

A double-free or corruption during parsing of a specially crafted
illegal XML document.

CVE-2018-19869

A malformed SVG image could cause a segmentation fault in
qsvghandler.cpp.

CVE-2018-19870

A malformed GIF image might have caused a NULL pointer dereference in
QGifHandler resulting in a segmentation fault.

CVE-2018-19871

There was an uncontrolled resource consumption in QTgaFile.

CVE-2018-19873

QBmpHandler had a buffer overflow via BMP data.

For Debian 8 "Jessie", these problems have been fixed in version
4:4.8.6+git64-g5dc8b2b+dfsg-3+deb8u2.

We recommend that you upgrade your qt4-x11 packages.

Further information about Debian LTS security advisories, how to apply
these updates to your system and frequently asked questions can be
found at: https://wiki.debian.org/LTS


DSA 4442-2: cups-filters regression update
- -------------------------------------------------------------------------
Debian Security Advisory DSA-4442-2 security@debian.org
https://www.debian.org/security/ Salvatore Bonaccorso
May 13, 2019 https://www.debian.org/security/faq
- -------------------------------------------------------------------------

Package : cups-filters
Debian Bug : 926576 928936 928952

The update for ghostscript released as DSA 4442-1 uncovered an issue in
cups-filters which was using the undocumented Ghostscript internal
"pdfdict" now hidden in the ghostscript update. Updated cups-filters
packages are now available to correct this issue.

For the stable distribution (stretch), this problem has been fixed in
version 1.11.6-3+deb9u1.

We recommend that you upgrade your cups-filters packages.

For the detailed security status of cups-filters please refer to its
security tracker page at:
https://security-tracker.debian.org/tracker/cups-filters

Further information about Debian Security Advisories, how to apply
these updates to your system and frequently asked questions can be
found at: https://www.debian.org/security/







Printed from Linux Compatible (https://www.linuxcompatible.org/news/story/qt4_x11_and_cups_filters_updates_for_debian.html)