Python3.4 Security Update for Debian 8 LTS
Posted on: 07/11/2019 06:56 PM

Updated python3.4 packages has been released for Debian GNU/Linux 8 LTS

Python3.4 Security Update for Debian 8 LTS


Package : python3.4
Version : 3.4.2-1+deb8u5
CVE ID : CVE-2019-9948


The urllib library in Python ships support for a second, not well known
URL scheme for accessing local files ("local_file://"). This scheme can
be used to circumvent protections that try to block local file access
and only block the well-known "file://" schema. This update addresses
the vulnerability by disallowing the "local_file://" URL scheme.

This update also fixes another regresssion introduced in the update
issued as DLA-1835-1 that broke installation of libpython3.4-testsuite.

For Debian 8 "Jessie", this problem has been fixed in version
3.4.2-1+deb8u5.

We recommend that you upgrade your python3.4 packages.

For the detailed security status of python3.4 please refer to
its security tracker page at:
https://security-tracker.debian.org/tracker/python3.4

Further information about Debian LTS security advisories, how to apply
these updates to your system and frequently asked questions can be
found at: https://wiki.debian.org/LTS



Printed from Linux Compatible (https://www.linuxcompatible.org/news/story/python3_4_security_update_for_debian_8_lts.html)