ProcPS and Beep Updates for Gentoo Linux
Posted on: 05/30/2018 06:14 PM

The following updates has been released for Gentoo Linux:

GLSA 201805-14 : procps: Multiple vulnerabilities
GLSA 201805-15 : beep: Local privilege escalation

GLSA 201805-14 : procps: Multiple vulnerabilities
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory GLSA 201805-14
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
https://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Severity: Normal
Title: procps: Multiple vulnerabilities
Date: May 30, 2018
Bugs: #656022
ID: 201805-14

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
========

Multiple vulnerabilities have been found in procps, the worst of which
could result in the execution of arbitrary code.

Background
==========

A bunch of small useful utilities that give information about processes
using the /proc filesystem.

Affected packages
=================

-------------------------------------------------------------------
Package / Vulnerable / Unaffected
-------------------------------------------------------------------
1 sys-process/procps < 3.3.15-r1 >= 3.3.15-r1

Description
===========

Multiple vulnerabilities have been discovered in procps. Please review
the CVE identifiers referenced below for details.

Impact
======

A local attacker could execute arbitrary code, escalate privileges, or
cause a Denial of Service condition.

Workaround
==========

There is no known workaround at this time.

Resolution
==========

All procps users should upgrade to the latest version:

# emerge --sync
# emerge --ask --oneshot --verbose ">=sys-process/procps-3.3.15-r1"

References
==========

[ 1 ] CVE-2018-1120
https://nvd.nist.gov/vuln/detail/CVE-2018-1120
[ 2 ] CVE-2018-1121
https://nvd.nist.gov/vuln/detail/CVE-2018-1121
[ 3 ] CVE-2018-1122
https://nvd.nist.gov/vuln/detail/CVE-2018-1122
[ 4 ] CVE-2018-1123
https://nvd.nist.gov/vuln/detail/CVE-2018-1123
[ 5 ] CVE-2018-1124
https://nvd.nist.gov/vuln/detail/CVE-2018-1124

Availability
============

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

https://security.gentoo.org/glsa/201805-14

Concerns?
=========

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users' machines is of utmost
importance to us. Any security concerns should be addressed to
security@gentoo.org or alternatively, you may file a bug at
https://bugs.gentoo.org.

License
=======

Copyright 2018 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

https://creativecommons.org/licenses/by-sa/2.5



GLSA 201805-15 : beep: Local privilege escalation
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory GLSA 201805-15
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
https://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Severity: Normal
Title: beep: Local privilege escalation
Date: May 30, 2018
Bugs: #652330
ID: 201805-15

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
========

A vulnerability in beep could allow local attackers to escalate
privileges.

Background
==========

The advanced PC speaker beeper.

Affected packages
=================

-------------------------------------------------------------------
Package / Vulnerable / Unaffected
-------------------------------------------------------------------
1 app-misc/beep < 1.3-r3 >= 1.3-r3

Description
===========

A race condition, if setuid, was discovered in beep.

Impact
======

A local attacker could escalate privileges.

Workaround
==========

There is no known workaround at this time.

Resolution
==========

All beep users should upgrade to the latest version:

# emerge --sync
# emerge --ask --oneshot --verbose ">=app-misc/beep-1.3-r3"

References
==========

[ 1 ] CVE-2018-0492
https://nvd.nist.gov/vuln/detail/CVE-2018-0492

Availability
============

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

https://security.gentoo.org/glsa/201805-15

Concerns?
=========

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users' machines is of utmost
importance to us. Any security concerns should be addressed to
security@gentoo.org or alternatively, you may file a bug at
https://bugs.gentoo.org.

License
=======

Copyright 2018 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

https://creativecommons.org/licenses/by-sa/2.5






Printed from Linux Compatible (https://www.linuxcompatible.org/news/story/procps_and_beep_updates_for_gentoo_linux.html)