PostgreSQL Security Updates for Ubuntu Linux
Posted on: 02/10/2018 05:37 PM

Updated postgresql packages has been released for Ubuntu Linux 14.04 LTS, 16.04 LTS, and 17.10

PostgreSQL Security Updates for Ubuntu Linux


==========================================================================
Ubuntu Security Notice USN-3564-1
February 09, 2018

postgresql-9.3, postgresql-9.5, postgresql-9.6 vulnerability
==========================================================================

A security issue affects these releases of Ubuntu and its derivatives:

- Ubuntu 17.10
- Ubuntu 16.04 LTS
- Ubuntu 14.04 LTS

Summary:

PostgreSQL could be made to expose sensitive information.

Software Description:
- postgresql-9.6: Object-relational SQL database
- postgresql-9.5: Object-relational SQL database
- postgresql-9.3: Object-relational SQL database

Details:

It was discovered that PostgreSQL incorrectly handled certain temp
files. An attacker could possibly use this to access sensitive
information.

Update instructions:

The problem can be corrected by updating your system to the following
package versions:

Ubuntu 17.10:
  postgresql-9.6 9.6.7-0ubuntu0.17.10

Ubuntu 16.04 LTS:
  postgresql-9.5 9.5.11-0ubuntu0.16.04

Ubuntu 14.04 LTS:
  postgresql-9.3 9.3.21-0ubuntu0.14.04

This update uses a new upstream release, which includes additional bug
fixes. After a standard system update you need to restart PostgreSQL to
make all the necessary changes.

References:
  https://www.ubuntu.com/usn/usn-3564-1
  CVE-2018-1053

Package Information:
  https://launchpad.net/ubuntu/+source/postgresql-9.6/9.6.7-0ubuntu0.17.10
  https://launchpad.net/ubuntu/+source/postgresql-9.5/9.5.11-0ubuntu0.16.04
  https://launchpad.net/ubuntu/+source/postgresql-9.3/9.3.21-0ubuntu0.14.04



Printed from Linux Compatible (https://www.linuxcompatible.org/news/story/postgresql_security_updates_for_ubuntu_linux.html)