PostgreSQL and DHCP Updates for Ubuntu Linux
Posted on: 05/13/2019 07:05 PM

The following updates has been released for Ubuntu Linux:

USN-3972-1: PostgreSQL vulnerabilities
USN-3973-1: DHCP vulnerability

USN-3972-1: PostgreSQL vulnerabilities

==========================================================================
Ubuntu Security Notice USN-3972-1
May 13, 2019

postgresql-10, postgresql-11, postgresql-9.5 vulnerabilities
==========================================================================

A security issue affects these releases of Ubuntu and its derivatives:

- Ubuntu 19.04
- Ubuntu 18.10
- Ubuntu 18.04 LTS
- Ubuntu 16.04 LTS

Summary:

Several security issues were fixed in PostgreSQL.

Software Description:
- postgresql-11: object-relational SQL database
- postgresql-10: Object-relational SQL database
- postgresql-9.5: Object-relational SQL database

Details:

It was discovered that PostgreSQL incorrectly handled partition routing. A
remote user could possibly use this issue to read arbitrary bytes of server
memory. This issue only affected Ubuntu 19.04. (CVE-2019-10129)

Dean Rasheed discovered that PostgreSQL incorrectly handled selectivity
estimators. A remote attacker could possibly use this issue to bypass row
security policies. (CVE-2019-10130)

Update instructions:

The problem can be corrected by updating your system to the following
package versions:

Ubuntu 19.04:
postgresql-11 11.3-0ubuntu0.19.04.1

Ubuntu 18.10:
postgresql-10 10.8-0ubuntu0.18.10.1

Ubuntu 18.04 LTS:
postgresql-10 10.8-0ubuntu0.18.04.1

Ubuntu 16.04 LTS:
postgresql-9.5 9.5.17-0ubuntu0.16.04.1

This update uses a new upstream release, which includes additional bug
fixes. After a standard system update you need to restart PostgreSQL to
make all the necessary changes.

References:
https://usn.ubuntu.com/usn/usn-3972-1
CVE-2019-10129, CVE-2019-10130

Package Information:
https://launchpad.net/ubuntu/+source/postgresql-11/11.3-0ubuntu0.19.04.1
https://launchpad.net/ubuntu/+source/postgresql-10/10.8-0ubuntu0.18.10.1
https://launchpad.net/ubuntu/+source/postgresql-10/10.8-0ubuntu0.18.04.1
https://launchpad.net/ubuntu/+source/postgresql-9.5/9.5.17-0ubuntu0.16.04.1


USN-3973-1: DHCP vulnerability

==========================================================================
Ubuntu Security Notice USN-3973-1
May 13, 2019

isc-dhcp vulnerability
==========================================================================

A security issue affects these releases of Ubuntu and its derivatives:

- Ubuntu 18.10
- Ubuntu 18.04 LTS

Summary:

DHCP could be made to crash if it received specially crafted network
traffic.

Software Description:
- isc-dhcp: DHCP server and client

Details:

It was discovered that DHCP, when built with a mismatched external BIND
library, incorrectly handled certain memory operations. A remote attacker
could possibly use this issue to cause DHCP to crash, resulting in a
denial of service.

Update instructions:

The problem can be corrected by updating your system to the following
package versions:

Ubuntu 18.10:
isc-dhcp-server 4.3.5-3ubuntu9.1

Ubuntu 18.04 LTS:
isc-dhcp-server 4.3.5-3ubuntu7.1

In general, a standard system update will make all the necessary changes.

References:
https://usn.ubuntu.com/usn/usn-3973-1
CVE-2019-6470

Package Information:
https://launchpad.net/ubuntu/+source/isc-dhcp/4.3.5-3ubuntu9.1
https://launchpad.net/ubuntu/+source/isc-dhcp/4.3.5-3ubuntu7.1





Printed from Linux Compatible (https://www.linuxcompatible.org/news/story/postgresql_and_dhcp_updates_for_ubuntu_linux.html)