Polkit, Libraw, Mozilla Updates for openSUSE
Posted on: 12/30/2018 10:23 AM

The following updates has been released for openSUSE:

openSUSE-SU-2018:4282-1: moderate: Security update for polkit
openSUSE-SU-2018:4283-1: moderate: Security update for mozilla-nspr and mozilla-nss
openSUSE-SU-2018:4299-1: moderate: Security update for libraw

openSUSE-SU-2018:4282-1: moderate: Security update for polkit
openSUSE Security Update: Security update for polkit
______________________________________________________________________________

Announcement ID: openSUSE-SU-2018:4282-1
Rating: moderate
References: #1118277
Cross-References: CVE-2018-19788
Affected Products:
openSUSE Leap 42.3
______________________________________________________________________________

An update that fixes one vulnerability is now available.

Description:

This update for polkit fixes the following issues:

Security issue fixed:

- CVE-2018-19788: Fixed handling of UIDs over MAX_UINT (boo#1118277)


Patch Instructions:

To install this openSUSE Security Update use the SUSE recommended installation methods
like YaST online_update or "zypper patch".

Alternatively you can run the command listed for your product:

- openSUSE Leap 42.3:

zypper in -t patch openSUSE-2018-1617=1



Package List:

- openSUSE Leap 42.3 (i586 x86_64):

libpolkit0-0.113-14.6.1
libpolkit0-debuginfo-0.113-14.6.1
polkit-0.113-14.6.1
polkit-debuginfo-0.113-14.6.1
polkit-debugsource-0.113-14.6.1
polkit-devel-0.113-14.6.1
polkit-devel-debuginfo-0.113-14.6.1
typelib-1_0-Polkit-1_0-0.113-14.6.1

- openSUSE Leap 42.3 (noarch):

polkit-doc-0.113-14.6.1

- openSUSE Leap 42.3 (x86_64):

libpolkit0-32bit-0.113-14.6.1
libpolkit0-debuginfo-32bit-0.113-14.6.1


References:

https://www.suse.com/security/cve/CVE-2018-19788.html
https://bugzilla.suse.com/1118277

--



openSUSE-SU-2018:4283-1: moderate: Security update for mozilla-nspr and mozilla-nss
openSUSE Security Update: Security update for mozilla-nspr and mozilla-nss
______________________________________________________________________________

Announcement ID: openSUSE-SU-2018:4283-1
Rating: moderate
References: #1097410 #1119105
Cross-References: CVE-2018-0495
Affected Products:
openSUSE Leap 15.0
______________________________________________________________________________

An update that solves one vulnerability and has one errata
is now available.

Description:

This update for mozilla-nss and mozilla-nspr fixes the following issues:

Issues fixed in mozilla-nss:

- Update to NSS 3.40.1 (bsc#1119105)
- CVE-2018-12404: Fixed a cache side-channel variant of the Bleichenbacher
attack (bsc#1119069)
- CVE-2018-12384: Fixed an issue in the SSL handshake. NSS responded to an
SSLv2-compatible ClientHello with a ServerHello that had an all-zero
random. (bsc#1106873)
- CVE-2018-0495: Fixed a memory-cache side-channel attack with ECDSA
signatures (bsc#1097410)
- Fixed a decryption failure during FFDHE key exchange
- Various security fixes in the ASN.1 code

Issues fixed in mozilla-nspr:

- Update mozilla-nspr to 4.20 (bsc#1119105)

This update was imported from the SUSE:SLE-15:Update update project.


Patch Instructions:

To install this openSUSE Security Update use the SUSE recommended installation methods
like YaST online_update or "zypper patch".

Alternatively you can run the command listed for your product:

- openSUSE Leap 15.0:

zypper in -t patch openSUSE-2018-1618=1



Package List:

- openSUSE Leap 15.0 (i586 x86_64):

libfreebl3-3.40.1-lp150.2.10.2
libfreebl3-debuginfo-3.40.1-lp150.2.10.2
libsoftokn3-3.40.1-lp150.2.10.2
libsoftokn3-debuginfo-3.40.1-lp150.2.10.2
mozilla-nspr-4.20-lp150.2.3.1
mozilla-nspr-debuginfo-4.20-lp150.2.3.1
mozilla-nspr-debugsource-4.20-lp150.2.3.1
mozilla-nspr-devel-4.20-lp150.2.3.1
mozilla-nss-3.40.1-lp150.2.10.2
mozilla-nss-certs-3.40.1-lp150.2.10.2
mozilla-nss-certs-debuginfo-3.40.1-lp150.2.10.2
mozilla-nss-debuginfo-3.40.1-lp150.2.10.2
mozilla-nss-debugsource-3.40.1-lp150.2.10.2
mozilla-nss-devel-3.40.1-lp150.2.10.2
mozilla-nss-sysinit-3.40.1-lp150.2.10.2
mozilla-nss-sysinit-debuginfo-3.40.1-lp150.2.10.2
mozilla-nss-tools-3.40.1-lp150.2.10.2
mozilla-nss-tools-debuginfo-3.40.1-lp150.2.10.2

- openSUSE Leap 15.0 (x86_64):

libfreebl3-32bit-3.40.1-lp150.2.10.2
libfreebl3-32bit-debuginfo-3.40.1-lp150.2.10.2
libsoftokn3-32bit-3.40.1-lp150.2.10.2
libsoftokn3-32bit-debuginfo-3.40.1-lp150.2.10.2
mozilla-nspr-32bit-4.20-lp150.2.3.1
mozilla-nspr-32bit-debuginfo-4.20-lp150.2.3.1
mozilla-nss-32bit-3.40.1-lp150.2.10.2
mozilla-nss-32bit-debuginfo-3.40.1-lp150.2.10.2
mozilla-nss-certs-32bit-3.40.1-lp150.2.10.2
mozilla-nss-certs-32bit-debuginfo-3.40.1-lp150.2.10.2
mozilla-nss-sysinit-32bit-3.40.1-lp150.2.10.2
mozilla-nss-sysinit-32bit-debuginfo-3.40.1-lp150.2.10.2


References:

https://www.suse.com/security/cve/CVE-2018-0495.html
https://bugzilla.suse.com/1097410
https://bugzilla.suse.com/1119105

--



openSUSE-SU-2018:4299-1: moderate: Security update for libraw
openSUSE Security Update: Security update for libraw
______________________________________________________________________________

Announcement ID: openSUSE-SU-2018:4299-1
Rating: moderate
References: #1097973 #1097974 #1097975 #1118894
Cross-References: CVE-2018-5804 CVE-2018-5805 CVE-2018-5806
CVE-2018-5808 CVE-2018-5816
Affected Products:
openSUSE Leap 42.3
______________________________________________________________________________

An update that fixes 5 vulnerabilities is now available.

Description:

This update for libraw fixes the following issues:

The following security vulnerabilities were addressed:

- CVE-2018-5804: Fixed a type confusion error within the identify function
that could trigger a division by zero, leading to a denial of service
(Dos). (boo#1097975)
- CVE-2018-5805: Fixed a boundary error within the quicktake_100_load_raw
function that could cause a stack-based buffer overflow and subsequently
trigger a crash. (boo#1097973)
- CVE-2018-5806: Fixed an error within the leaf_hdr_load_raw function that
could trigger a NULL pointer deference, leading to a denial of service
(DoS). (boo#1097974)
- CVE-2018-5808: Fixed an error within the find_green function that could
cause a stack-based buffer overflow and subsequently execute arbitrary
code. (boo#1118894)
- CVE-2018-5816: Fixed a type confusion error within the identify function
that could trigger a division by zero, leading to a denial of service
(DoS). (boo#1097975)


Patch Instructions:

To install this openSUSE Security Update use the SUSE recommended installation methods
like YaST online_update or "zypper patch".

Alternatively you can run the command listed for your product:

- openSUSE Leap 42.3:

zypper in -t patch openSUSE-2018-1619=1



Package List:

- openSUSE Leap 42.3 (i586 x86_64):

libraw-debugsource-0.17.1-26.1
libraw-devel-0.17.1-26.1
libraw-devel-static-0.17.1-26.1
libraw-tools-0.17.1-26.1
libraw-tools-debuginfo-0.17.1-26.1
libraw15-0.17.1-26.1
libraw15-debuginfo-0.17.1-26.1


References:

https://www.suse.com/security/cve/CVE-2018-5804.html
https://www.suse.com/security/cve/CVE-2018-5805.html
https://www.suse.com/security/cve/CVE-2018-5806.html
https://www.suse.com/security/cve/CVE-2018-5808.html
https://www.suse.com/security/cve/CVE-2018-5816.html
https://bugzilla.suse.com/1097973
https://bugzilla.suse.com/1097974
https://bugzilla.suse.com/1097975
https://bugzilla.suse.com/1118894

--






Printed from Linux Compatible (https://www.linuxcompatible.org/news/story/polkitlibrawmozilla_updates_for_opensuse.html)