phpBB3 and Ruby-Mini-Magick Updates for Debian 8 LTS
Posted on: 10/07/2019 12:40 PM

The following updates has been released for Debian GNU/Linux 8 LTS:

DLA 1942-2: phpbb3 regression update
DLA 1948-1: ruby-mini-magick security update

DLA 1942-2: phpbb3 regression update
This is a follow-up to DLA-1942-1.

There was some confusion about the correct
fix for CVE-2019-13776.

The correct announcement for this DLA should have been:

Package : phpbb3
Version : 3.0.12-5+deb8u4
CVE ID : CVE-2019-13776 CVE-2019-16993

CVE-2019-16993

In phpBB, includes/acp/acp_bbcodes.php had improper verification of a
CSRF token on the BBCode page in the Administration Control Panel. An
actual CSRF attack was possible if an attacker also managed to retrieve
the session id of a reauthenticated administrator prior to targeting
them.

CVE-2019-13776

phpBB allowed the stealing of an Administration Control Panel session id
by leveraging CSRF in the Remote Avatar feature. The CSRF Token Hijacking
lead to stored XSS.

For Debian 8 "Jessie", these problems have been fixed in version
3.0.12-5+deb8u4.

We recommend that you upgrade your phpbb3 packages.

Further information about Debian LTS security advisories, how to apply
these updates to your system and frequently asked questions can be
found at: https://wiki.debian.org/LTS


DLA 1948-1: ruby-mini-magick security update
Package : ruby-mini-magick
Version : 3.8.1-1+deb8u1
CVE ID : CVE-2019-13574
Debian Bug : 931932


In lib/mini_magick/image.rb in ruby-mini-magick, a fetched remote
image filename could cause remote command execution because Image.open
input is directly passed to Kernel#open, which accepts a '|' character
followed by a command.

For Debian 8 "Jessie", this problem has been fixed in version
3.8.1-1+deb8u1.

We recommend that you upgrade your ruby-mini-magick packages.

Further information about Debian LTS security advisories, how to apply
these updates to your system and frequently asked questions can be
found at: https://wiki.debian.org/LTS




Printed from Linux Compatible (https://www.linuxcompatible.org/news/story/phpbb3_and_ruby_mini_magick_updates_for_debian_8_lts.html)