PHP (SSA:2018-257-01) Update for Slackware
Posted on: 09/15/2018 01:37 PM

New php packages are available for Slackware 14.0, 14.1, 14.2, and -current to fix security issues.

PHP (SSA:2018-257-01) Update for Slackware


Here are the details from the Slackware 14.2 ChangeLog:
+--------------------------+
patches/packages/php-5.6.38-i586-1_slack14.2.txz: Upgraded.
One security bug has been fixed in this release:
Apache2: XSS due to the header Transfer-Encoding: chunked
For more information, see:
https://php.net/ChangeLog-5.php#5.6.38
(* Security fix *)
+--------------------------+


Where to find the new packages:
+-----------------------------+

Thanks to the friendly folks at the OSU Open Source Lab
(http://osuosl.org) for donating FTP and rsync hosting
to the Slackware project! :-)

Also see the "Get Slack" section on http://slackware.com for
additional mirror sites near you.

Updated package for Slackware 14.0:
ftp://ftp.slackware.com/pub/slackware/slackware-14.0/patches/packages/php-5.6.38-i486-1_slack14.0.txz

Updated package for Slackware x86_64 14.0:
ftp://ftp.slackware.com/pub/slackware/slackware64-14.0/patches/packages/php-5.6.38-x86_64-1_slack14.0.txz

Updated package for Slackware 14.1:
ftp://ftp.slackware.com/pub/slackware/slackware-14.1/patches/packages/php-5.6.38-i486-1_slack14.1.txz

Updated package for Slackware x86_64 14.1:
ftp://ftp.slackware.com/pub/slackware/slackware64-14.1/patches/packages/php-5.6.38-x86_64-1_slack14.1.txz

Updated package for Slackware 14.2:
ftp://ftp.slackware.com/pub/slackware/slackware-14.2/patches/packages/php-5.6.38-i586-1_slack14.2.txz

Updated package for Slackware x86_64 14.2:
ftp://ftp.slackware.com/pub/slackware/slackware64-14.2/patches/packages/php-5.6.38-x86_64-1_slack14.2.txz

Updated package for Slackware -current:
ftp://ftp.slackware.com/pub/slackware/slackware-current/slackware/n/php-7.2.10-i586-1.txz

Updated package for Slackware x86_64 -current:
ftp://ftp.slackware.com/pub/slackware/slackware64-current/slackware64/n/php-7.2.10-x86_64-1.txz


MD5 signatures:
+-------------+

Slackware 14.0 package:
ad5fca90b02bfdaf0ec6dc4b75c119ee php-5.6.38-i486-1_slack14.0.txz

Slackware x86_64 14.0 package:
e1ae9acc6cbffe533d57ea18d06875bb php-5.6.38-x86_64-1_slack14.0.txz

Slackware 14.1 package:
d19e2d8131fab3808c14b827bc3a195f php-5.6.38-i486-1_slack14.1.txz

Slackware x86_64 14.1 package:
62d2e74591d5fc9ef6ab41dfe509fc43 php-5.6.38-x86_64-1_slack14.1.txz

Slackware 14.2 package:
4411520ef83c9cadd0eac17c9b33f8ef php-5.6.38-i586-1_slack14.2.txz

Slackware x86_64 14.2 package:
9dcbc800e62882d13dcedc1930a68911 php-5.6.38-x86_64-1_slack14.2.txz

Slackware -current package:
f4311e3990ee91fcd92269b26d6c3604 n/php-7.2.10-i586-1.txz

Slackware x86_64 -current package:
4d48395a12865252b5828cb046dcfc92 n/php-7.2.10-x86_64-1.txz


Installation instructions:
+------------------------+

Upgrade the package as root:
# upgradepkg php-5.6.38-i586-1_slack14.2.txz

Then, restart Apache httpd:
# /etc/rc.d/rc.httpd stop
# /etc/rc.d/rc.httpd start



Printed from Linux Compatible (https://www.linuxcompatible.org/news/story/php_(ssa2018_257_01)_update_for_slackware.html)