PHP5, Jackson-Databind, Linux, Ghostscript Updates for Debian
Posted on: 08/13/2019 06:17 AM

The following security updates has been released for Debian GNU/Linux:

Debian GNU/Linux 7 Extended LTS:
ELA-152-1 php5 security update

Debian GNU/Linux 8 LTS:
DLA 1878-1: php5 security update
DLA 1879-1: jackson-databind security update

Debian GNU/Linux 9 and 10:
DSA 4497-1: linux security update
DSA 4499-1: ghostscript security update


ELA-152-1: php5 security update
Package php5
Version 5.4.45-0+deb7u24
Related CVE CVE-2019-11041 CVE-2019-11042
Two heap buffer overflows were found in the EXIF parsing code of PHP, a widely-used open source general purpose scripting language.

For Debian 7 Wheezy, these problems have been fixed in version 5.4.45-0+deb7u24.

We recommend that you upgrade your php5 packages.

Further information about Extended LTS security advisories can be found at: https://deb.freexian.com/extended-lts/


DLA 1878-1: php5 security update
Package : php5
Version : 5.6.40+dfsg-0+deb8u5
CVE ID : CVE-2019-11041 CVE-2019-11042

Two heap buffer overflows were found in the EXIF parsing code of PHP,
a widely-used open source general purpose scripting language.

For Debian 8 "Jessie", these problems have been fixed in version
5.6.40+dfsg-0+deb8u5.

We recommend that you upgrade your php5 packages.

Further information about Debian LTS security advisories, how to apply
these updates to your system and frequently asked questions can be
found at: https://wiki.debian.org/LTS

DLA 1879-1: jackson-databind security update
Package : jackson-databind
Version : 2.4.2-2+deb8u8
CVE ID : CVE-2019-14379 CVE-2019-14439
Debian Bug : 933393


Deserialization flaws were discovered in jackson-databind relating to
EHCache and logback/jndi, which could allow an unauthenticated user to
perform remote code execution. The issue was resolved by extending the
blacklist and blocking more classes from polymorphic deserialization.

For Debian 8 "Jessie", these problems have been fixed in version
2.4.2-2+deb8u8.

We recommend that you upgrade your jackson-databind packages.

Further information about Debian LTS security advisories, how to apply
these updates to your system and frequently asked questions can be
found at: https://wiki.debian.org/LTS


DSA 4497-1: linux security update
- -------------------------------------------------------------------------
Debian Security Advisory DSA-4497-1 security@debian.org
https://www.debian.org/security/ Ben Hutchings
August 13, 2019 https://www.debian.org/security/faq
- -------------------------------------------------------------------------

Package : linux
CVE ID : CVE-2015-8553 CVE-2018-5995 CVE-2018-20836 CVE-2018-20856
CVE-2019-1125 CVE-2019-3882 CVE-2019-3900 CVE-2019-10207
CVE-2019-10638 CVE-2019-10639 CVE-2019-13631 CVE-2019-13648
CVE-2019-14283 CVE-2019-14284

Several vulnerabilities have been discovered in the Linux kernel that
may lead to a privilege escalation, denial of service or information
leaks.

CVE-2015-8553

Jan Beulich discovered that CVE-2015-2150 was not completely
addressed. If a PCI physical function is passed through to a
Xen guest, the guest is able to access its memory and I/O
regions before enabling decoding of those regions. This could
result in a denial-of-service (unexpected NMI) on the host.

The fix for this is incompatible with qemu versions before 2.5.

(CVE ID not yet assigned)

Denis Andzakovic reported a missing type check in the IPv4 multicast
routing implementation. A user with the CAP_NET_ADMIN capability (in
any user namespace) could use this for denial-of-service (memory
corruption or crash) or possibly for privilege escalation.

CVE-2018-5995

ADLab of VenusTech discovered that the kernel logged the virtual
addresses assigned to per-CPU data, which could make it easier to
exploit other vulnerabilities.

CVE-2018-20836

chenxiang reported a race condition in libsas, the kernel
subsystem supporting Serial Attached SCSI (SAS) devices, which
could lead to a use-after-free. It is not clear how this might be
exploited.

CVE-2018-20856

Xiao Jin reported a potential double-free in the block subsystem,
in case an error occurs while initialising the I/O scheduler for a
block device. It is not clear how this might be exploited.

CVE-2019-1125

It was discovered that most x86 processors could speculatively
skip a conditional SWAPGS instruction used when entering the
kernel from user mode, and/or could speculatively execute it when
it should be skipped. This is a subtype of Spectre variant 1,
which could allow local users to obtain sensitive information from
the kernel or other processes. It has been mitigated by using
memory barriers to limit speculative execution. Systems using an
i386 kernel are not affected as the kernel does not use SWAPGS.

CVE-2019-3882

It was found that the vfio implementation did not limit the number
of DMA mappings to device memory. A local user granted ownership
of a vfio device could use this to cause a denial of service
(out-of-memory condition).

CVE-2019-3900

It was discovered that vhost drivers did not properly control the
amount of work done to service requests from guest VMs. A
malicious guest could use this to cause a denial-of-service
(unbounded CPU usage) on the host.

CVE-2019-10207

The syzkaller tool found a potential null dereference in various
drivers for UART-attached Bluetooth adapters. A local user with
access to a pty device or other suitable tty device could use this
for denial-of-service (BUG/oops).

CVE-2019-10638

Amit Klein and Benny Pinkas discovered that the generation of IP
packet IDs used a weak hash function, "jhash". This could enable
tracking individual computers as they communicate with different
remote servers and from different networks. The "siphash"
function is now used instead.

CVE-2019-10639

Amit Klein and Benny Pinkas discovered that the generation of IP
packet IDs used a weak hash function that incorporated a kernel
virtual address. This hash function is no longer used for IP IDs,
although it is still used for other purposes in the network stack.

CVE-2019-13631

It was discovered that the gtco driver for USB input tablets could
overrun a stack buffer with constant data while parsing the device's
descriptor. A physically present user with a specially
constructed USB device could use this to cause a denial-of-service
(BUG/oops), or possibly for privilege escalation.

CVE-2019-13648

Praveen Pandey reported that on PowerPC (ppc64el) systems without
Transactional Memory (TM), the kernel would still attempt to
restore TM state passed to the sigreturn() system call. A local
user could use this for denial-of-service (oops).

CVE-2019-14283

The syzkaller tool found a missing bounds check in the floppy disk
driver. A local user with access to a floppy disk device, with a
disk present, could use this to read kernel memory beyond the
I/O buffer, possibly obtaining sensitive information.

CVE-2019-14284

The syzkaller tool found a potential division-by-zero in the
floppy disk driver. A local user with access to a floppy disk
device could use this for denial-of-service (oops).

(CVE ID not yet assigned)

Denis Andzakovic reported a possible use-after-free in the
TCP sockets implementation. A local user could use this for
denial-of-service (memory corruption or crash) or possibly
for privilege escalation.

(CVE ID not yet assigned)

The netfilter conntrack subsystem used kernel addresses as
user-visible IDs, which could make it easier to exploit other
security vulnerabilities.

XSA-300

Julien Grall reported that Linux does not limit the amount of memory
which a domain will attempt to baloon out, nor limits the amount of
"foreign / grant map" memory which any individual guest can consume,
leading to denial of service conditions (for host or guests).

For the oldstable distribution (stretch), these problems have been fixed
in version 4.9.168-1+deb9u5.

For the stable distribution (buster), these problems were mostly fixed
in version 4.19.37-5+deb10u2 or earlier.

We recommend that you upgrade your linux packages.

For the detailed security status of linux please refer to
its security tracker page at:
https://security-tracker.debian.org/tracker/linux

Further information about Debian Security Advisories, how to apply
these updates to your system and frequently asked questions can be
found at: https://www.debian.org/security/


DSA 4499-1: ghostscript security update
- -------------------------------------------------------------------------
Debian Security Advisory DSA-4499-1 security@debian.org
https://www.debian.org/security/ Salvatore Bonaccorso
August 12, 2019 https://www.debian.org/security/faq
- -------------------------------------------------------------------------

Package : ghostscript
CVE ID : CVE-2019-10216
Debian Bug : 934638

Netanel reported that the .buildfont1 procedure in Ghostscript, the GPL
PostScript/PDF interpreter, does not properly restrict privileged calls,
which could result in bypass of file system restrictions of the dSAFER
sandbox.

For the oldstable distribution (stretch), this problem has been fixed
in version 9.26a~dfsg-0+deb9u4.

For the stable distribution (buster), this problem has been fixed in
version 9.27~dfsg-2+deb10u1.

We recommend that you upgrade your ghostscript packages.

For the detailed security status of ghostscript please refer to its
security tracker page at:
https://security-tracker.debian.org/tracker/ghostscript

Further information about Debian Security Advisories, how to apply
these updates to your system and frequently asked questions can be
found at: https://www.debian.org/security/




Printed from Linux Compatible (https://www.linuxcompatible.org/news/story/php5jackson_databindlinuxghostscript_updates_for_debian.html)