OpenSSL, Subversion, Rsyslog, Python3 Updates for openSUSE
Posted on: 02/09/2019 08:55 AM

The following updates has been released for openSUSE:

openSUSE-SU-2019:0152-1: moderate: Security update for openssl-1_1
openSUSE-SU-2019:0153-1: moderate: Security update for subversion
openSUSE-SU-2019:0154-1: important: Security update for rsyslog
openSUSE-SU-2019:0155-1: important: Security update for python3

openSUSE-SU-2019:0152-1: moderate: Security update for openssl-1_1
openSUSE Security Update: Security update for openssl-1_1
______________________________________________________________________________

Announcement ID: openSUSE-SU-2019:0152-1
Rating: moderate
References: #1117951 #1118913
Cross-References: CVE-2018-0737
Affected Products:
openSUSE Leap 15.0
______________________________________________________________________________

An update that solves one vulnerability and has one errata
is now available.

Description:

This update for openssl-1_1 fixes the following issues:

Security issues fixed:

- The 9 Lives of Bleichenbacher's CAT: Cache Attacks on TLS
Implementations (bsc#1117951)
- Fix FIPS RSA generator (bsc#1118913)

This update was imported from the SUSE:SLE-15:Update update project.


Patch Instructions:

To install this openSUSE Security Update use the SUSE recommended installation methods
like YaST online_update or "zypper patch".

Alternatively you can run the command listed for your product:

- openSUSE Leap 15.0:

zypper in -t patch openSUSE-2019-152=1



Package List:

- openSUSE Leap 15.0 (i586 x86_64):

libopenssl-1_1-devel-1.1.0i-lp150.3.18.1
libopenssl1_1-1.1.0i-lp150.3.18.1
libopenssl1_1-debuginfo-1.1.0i-lp150.3.18.1
libopenssl1_1-hmac-1.1.0i-lp150.3.18.1
openssl-1_1-1.1.0i-lp150.3.18.1
openssl-1_1-debuginfo-1.1.0i-lp150.3.18.1
openssl-1_1-debugsource-1.1.0i-lp150.3.18.1

- openSUSE Leap 15.0 (noarch):

openssl-1_1-doc-1.1.0i-lp150.3.18.1

- openSUSE Leap 15.0 (x86_64):

libopenssl-1_1-devel-32bit-1.1.0i-lp150.3.18.1
libopenssl1_1-32bit-1.1.0i-lp150.3.18.1
libopenssl1_1-32bit-debuginfo-1.1.0i-lp150.3.18.1
libopenssl1_1-hmac-32bit-1.1.0i-lp150.3.18.1


References:

https://www.suse.com/security/cve/CVE-2018-0737.html
https://bugzilla.suse.com/1117951
https://bugzilla.suse.com/1118913

--



openSUSE-SU-2019:0153-1: moderate: Security update for subversion
openSUSE Security Update: Security update for subversion
______________________________________________________________________________

Announcement ID: openSUSE-SU-2019:0153-1
Rating: moderate
References: #1122842
Cross-References: CVE-2018-11803
Affected Products:
openSUSE Leap 15.0
______________________________________________________________________________

An update that fixes one vulnerability is now available.

Description:

This update for subversion fixes the following issues:

Security issue fixed:

- CVE-2018-11803: Fixed a vulnerability that allowed malicious SVN clients
to trigger a crash in mod_dav_svn by omitting the root path from a
recursive directory listing request (bsc#1122842)

This update was imported from the SUSE:SLE-15:Update update project.


Patch Instructions:

To install this openSUSE Security Update use the SUSE recommended installation methods
like YaST online_update or "zypper patch".

Alternatively you can run the command listed for your product:

- openSUSE Leap 15.0:

zypper in -t patch openSUSE-2019-153=1



Package List:

- openSUSE Leap 15.0 (i586 x86_64):

libsvn_auth_gnome_keyring-1-0-1.10.0-lp150.2.3.1
libsvn_auth_gnome_keyring-1-0-debuginfo-1.10.0-lp150.2.3.1
libsvn_auth_kwallet-1-0-1.10.0-lp150.2.3.1
libsvn_auth_kwallet-1-0-debuginfo-1.10.0-lp150.2.3.1
subversion-1.10.0-lp150.2.3.1
subversion-debuginfo-1.10.0-lp150.2.3.1
subversion-debugsource-1.10.0-lp150.2.3.1
subversion-devel-1.10.0-lp150.2.3.1
subversion-perl-1.10.0-lp150.2.3.1
subversion-perl-debuginfo-1.10.0-lp150.2.3.1
subversion-python-1.10.0-lp150.2.3.1
subversion-python-ctypes-1.10.0-lp150.2.3.1
subversion-python-debuginfo-1.10.0-lp150.2.3.1
subversion-ruby-1.10.0-lp150.2.3.1
subversion-ruby-debuginfo-1.10.0-lp150.2.3.1
subversion-server-1.10.0-lp150.2.3.1
subversion-server-debuginfo-1.10.0-lp150.2.3.1
subversion-tools-1.10.0-lp150.2.3.1
subversion-tools-debuginfo-1.10.0-lp150.2.3.1

- openSUSE Leap 15.0 (noarch):

subversion-bash-completion-1.10.0-lp150.2.3.1


References:

https://www.suse.com/security/cve/CVE-2018-11803.html
https://bugzilla.suse.com/1122842

--



openSUSE-SU-2019:0154-1: important: Security update for rsyslog
openSUSE Security Update: Security update for rsyslog
______________________________________________________________________________

Announcement ID: openSUSE-SU-2019:0154-1
Rating: important
References: #1123164
Cross-References: CVE-2018-16881
Affected Products:
openSUSE Leap 42.3
______________________________________________________________________________

An update that fixes one vulnerability is now available.

Description:

This update for rsyslog fixes the following issues:

Security issue fixed:

- CVE-2018-16881: Fixed a denial of service when both the imtcp module and
Octet-Counted TCP Framing is enabled (bsc#1123164).

This update was imported from the SUSE:SLE-12-SP3:Update update project.


Patch Instructions:

To install this openSUSE Security Update use the SUSE recommended installation methods
like YaST online_update or "zypper patch".

Alternatively you can run the command listed for your product:

- openSUSE Leap 42.3:

zypper in -t patch openSUSE-2019-154=1



Package List:

- openSUSE Leap 42.3 (i586 x86_64):

rsyslog-8.24.0-2.10.1
rsyslog-debuginfo-8.24.0-2.10.1
rsyslog-debugsource-8.24.0-2.10.1
rsyslog-diag-tools-8.24.0-2.10.1
rsyslog-diag-tools-debuginfo-8.24.0-2.10.1
rsyslog-doc-8.24.0-2.10.1
rsyslog-module-dbi-8.24.0-2.10.1
rsyslog-module-dbi-debuginfo-8.24.0-2.10.1
rsyslog-module-elasticsearch-8.24.0-2.10.1
rsyslog-module-elasticsearch-debuginfo-8.24.0-2.10.1
rsyslog-module-gcrypt-8.24.0-2.10.1
rsyslog-module-gcrypt-debuginfo-8.24.0-2.10.1
rsyslog-module-gssapi-8.24.0-2.10.1
rsyslog-module-gssapi-debuginfo-8.24.0-2.10.1
rsyslog-module-gtls-8.24.0-2.10.1
rsyslog-module-gtls-debuginfo-8.24.0-2.10.1
rsyslog-module-guardtime-8.24.0-2.10.1
rsyslog-module-guardtime-debuginfo-8.24.0-2.10.1
rsyslog-module-mmnormalize-8.24.0-2.10.1
rsyslog-module-mmnormalize-debuginfo-8.24.0-2.10.1
rsyslog-module-mysql-8.24.0-2.10.1
rsyslog-module-mysql-debuginfo-8.24.0-2.10.1
rsyslog-module-omamqp1-8.24.0-2.10.1
rsyslog-module-omamqp1-debuginfo-8.24.0-2.10.1
rsyslog-module-omhttpfs-8.24.0-2.10.1
rsyslog-module-omhttpfs-debuginfo-8.24.0-2.10.1
rsyslog-module-omtcl-8.24.0-2.10.1
rsyslog-module-omtcl-debuginfo-8.24.0-2.10.1
rsyslog-module-pgsql-8.24.0-2.10.1
rsyslog-module-pgsql-debuginfo-8.24.0-2.10.1
rsyslog-module-relp-8.24.0-2.10.1
rsyslog-module-relp-debuginfo-8.24.0-2.10.1
rsyslog-module-snmp-8.24.0-2.10.1
rsyslog-module-snmp-debuginfo-8.24.0-2.10.1
rsyslog-module-udpspoof-8.24.0-2.10.1
rsyslog-module-udpspoof-debuginfo-8.24.0-2.10.1


References:

https://www.suse.com/security/cve/CVE-2018-16881.html
https://bugzilla.suse.com/1123164

--



openSUSE-SU-2019:0155-1: important: Security update for python3
openSUSE Security Update: Security update for python3
______________________________________________________________________________

Announcement ID: openSUSE-SU-2019:0155-1
Rating: important
References: #1120644 #1122191
Cross-References: CVE-2018-20406 CVE-2019-5010
Affected Products:
openSUSE Leap 15.0
______________________________________________________________________________

An update that fixes two vulnerabilities is now available.

Description:

This update for python3 fixes the following issues:

Security issue fixed:

- CVE-2019-5010: Fixed a denial-of-service vulnerability in the X509
certificate parser (bsc#1122191)
- CVE-2018-20406: Fixed a integer overflow via a large LONG_BINPUT
(bsc#1120644)

This update was imported from the SUSE:SLE-15:Update update project.


Patch Instructions:

To install this openSUSE Security Update use the SUSE recommended installation methods
like YaST online_update or "zypper patch".

Alternatively you can run the command listed for your product:

- openSUSE Leap 15.0:

zypper in -t patch openSUSE-2019-155=1



Package List:

- openSUSE Leap 15.0 (i586 x86_64):

libpython3_6m1_0-3.6.5-lp150.2.6.1
libpython3_6m1_0-debuginfo-3.6.5-lp150.2.6.1
python3-3.6.5-lp150.2.6.1
python3-base-3.6.5-lp150.2.6.1
python3-base-debuginfo-3.6.5-lp150.2.6.1
python3-base-debugsource-3.6.5-lp150.2.6.1
python3-curses-3.6.5-lp150.2.6.1
python3-curses-debuginfo-3.6.5-lp150.2.6.1
python3-dbm-3.6.5-lp150.2.6.1
python3-dbm-debuginfo-3.6.5-lp150.2.6.1
python3-debuginfo-3.6.5-lp150.2.6.1
python3-debugsource-3.6.5-lp150.2.6.1
python3-devel-3.6.5-lp150.2.6.1
python3-devel-debuginfo-3.6.5-lp150.2.6.1
python3-idle-3.6.5-lp150.2.6.1
python3-testsuite-3.6.5-lp150.2.6.1
python3-testsuite-debuginfo-3.6.5-lp150.2.6.1
python3-tk-3.6.5-lp150.2.6.1
python3-tk-debuginfo-3.6.5-lp150.2.6.1
python3-tools-3.6.5-lp150.2.6.1

- openSUSE Leap 15.0 (x86_64):

libpython3_6m1_0-32bit-3.6.5-lp150.2.6.1
libpython3_6m1_0-32bit-debuginfo-3.6.5-lp150.2.6.1
python3-32bit-3.6.5-lp150.2.6.1
python3-32bit-debuginfo-3.6.5-lp150.2.6.1
python3-base-32bit-3.6.5-lp150.2.6.1
python3-base-32bit-debuginfo-3.6.5-lp150.2.6.1

- openSUSE Leap 15.0 (noarch):

python3-doc-3.6.5-lp150.2.6.1


References:

https://www.suse.com/security/cve/CVE-2018-20406.html
https://www.suse.com/security/cve/CVE-2019-5010.html
https://bugzilla.suse.com/1120644
https://bugzilla.suse.com/1122191

--






Printed from Linux Compatible (https://www.linuxcompatible.org/news/story/opensslsubversionrsyslogpython3_updates_for_opensuse.html)