OpenCV and Xen Updates for openSUSE
Posted on: 05/12/2018 06:48 AM

The following updates has been released for openSUSE:

openSUSE-SU-2018:1265-1: important: Security update for opencv
openSUSE-SU-2018:1271-1: important: Security update for opencv
openSUSE-SU-2018:1274-1: important: Security update for xen

openSUSE-SU-2018:1265-1: important: Security update for opencv
openSUSE Security Update: Security update for opencv
______________________________________________________________________________

Announcement ID: openSUSE-SU-2018:1265-1
Rating: important
References: #1033150 #1033152
Cross-References: CVE-2016-1516 CVE-2016-1517
Affected Products:
openSUSE Leap 42.3
______________________________________________________________________________

An update that fixes two vulnerabilities is now available.

Description:

This update for opencv fixes the following issues:

- CVE-2016-1517: Fixed a denial of service (segfault) via vectors
involving corrupt chunks (boo#1033150)
- CVE-2016-1516: Fixed a double free issue that allows attackers to
execute arbitrary code (boo#1033152).


Patch Instructions:

To install this openSUSE Security Update use the SUSE recommended installation methods
like YaST online_update or "zypper patch".

Alternatively you can run the command listed for your product:

- openSUSE Leap 42.3:

zypper in -t patch openSUSE-2018-455=1



Package List:

- openSUSE Leap 42.3 (x86_64):

libopencv-qt56_3-3.1.0-4.3.1
libopencv-qt56_3-debuginfo-3.1.0-4.3.1
libopencv3_1-3.1.0-4.3.1
libopencv3_1-debuginfo-3.1.0-4.3.1
opencv-3.1.0-4.3.1
opencv-debuginfo-3.1.0-4.3.1
opencv-debugsource-3.1.0-4.3.1
opencv-devel-3.1.0-4.3.1
opencv-doc-3.1.0-4.3.1
opencv-qt5-3.1.0-4.3.1
opencv-qt5-debuginfo-3.1.0-4.3.1
opencv-qt5-debugsource-3.1.0-4.3.1
opencv-qt5-devel-3.1.0-4.3.1
opencv-qt5-doc-3.1.0-4.3.1
python-opencv-3.1.0-4.3.1
python-opencv-debuginfo-3.1.0-4.3.1
python-opencv-qt5-3.1.0-4.3.1
python-opencv-qt5-debuginfo-3.1.0-4.3.1
python3-opencv-3.1.0-4.3.1
python3-opencv-debuginfo-3.1.0-4.3.1
python3-opencv-qt5-3.1.0-4.3.1
python3-opencv-qt5-debuginfo-3.1.0-4.3.1


References:

https://www.suse.com/security/cve/CVE-2016-1516.html
https://www.suse.com/security/cve/CVE-2016-1517.html
https://bugzilla.suse.com/1033150
https://bugzilla.suse.com/1033152

--



openSUSE-SU-2018:1271-1: important: Security update for opencv
openSUSE Security Update: Security update for opencv
______________________________________________________________________________

Announcement ID: openSUSE-SU-2018:1271-1
Rating: important
References: #1033150 #1033152
Cross-References: CVE-2016-1516 CVE-2016-1517
Affected Products:
SUSE Package Hub for SUSE Linux Enterprise 12
______________________________________________________________________________

An update that fixes two vulnerabilities is now available.

Description:

This update for opencv fixes the following issues:

- CVE-2016-1517: Fixed a denial of service (segfault) via vectors
involving corrupt chunks (boo#1033150)
- CVE-2016-1516: Fixed a double free issue that allows attackers to
execute arbitrary code (boo#1033152).


Patch Instructions:

To install this openSUSE Security Update use the SUSE recommended installation methods
like YaST online_update or "zypper patch".

Alternatively you can run the command listed for your product:

- SUSE Package Hub for SUSE Linux Enterprise 12:

zypper in -t patch openSUSE-2018-455=1



Package List:

- SUSE Package Hub for SUSE Linux Enterprise 12 (x86_64):

libopencv-qt56_3-3.1.0-5.1
libopencv-qt56_3-debuginfo-3.1.0-5.1
libopencv3_1-3.1.0-5.1
opencv-3.1.0-5.1
opencv-devel-3.1.0-5.1
opencv-doc-3.1.0-5.1
opencv-qt5-3.1.0-5.1
opencv-qt5-debuginfo-3.1.0-5.1
opencv-qt5-debugsource-3.1.0-5.1
opencv-qt5-devel-3.1.0-5.1
opencv-qt5-doc-3.1.0-5.1
python-opencv-3.1.0-5.1
python-opencv-qt5-3.1.0-5.1
python-opencv-qt5-debuginfo-3.1.0-5.1
python3-opencv-3.1.0-5.1
python3-opencv-qt5-3.1.0-5.1
python3-opencv-qt5-debuginfo-3.1.0-5.1


References:

https://www.suse.com/security/cve/CVE-2016-1516.html
https://www.suse.com/security/cve/CVE-2016-1517.html
https://bugzilla.suse.com/1033150
https://bugzilla.suse.com/1033152

--



openSUSE-SU-2018:1274-1: important: Security update for xen
openSUSE Security Update: Security update for xen
______________________________________________________________________________

Announcement ID: openSUSE-SU-2018:1274-1
Rating: important
References: #1027519 #1072834 #1080634 #1080635 #1080662
#1087251 #1087252 #1089152 #1089635 #1090820
#1090822 #1090823
Cross-References: CVE-2018-10471 CVE-2018-10472 CVE-2018-7540
CVE-2018-7541 CVE-2018-7542 CVE-2018-8897

Affected Products:
openSUSE Leap 42.3
______________________________________________________________________________

An update that solves 6 vulnerabilities and has 6 fixes is
now available.

Description:

This update for xen to version 4.9.2 fixes several issues.

This feature was added:

- Added script, udev rule and systemd service to watch for vcpu
online/offline events in a HVM domU. They are triggered via 'xl vcpu-set
domU N'

These security issues were fixed:

- CVE-2018-8897: Prevent mishandling of debug exceptions on x86 (XSA-260,
bsc#1090820)
- Handle HPET timers in IO-APIC mode correctly to prevent malicious or
buggy HVM guests from causing a hypervisor crash or potentially
privilege escalation/information leaks (XSA-261, bsc#1090822)
- Prevent unbounded loop, induced by qemu allowing an attacker to
permanently keep a physical CPU core busy (XSA-262, bsc#1090823)
- CVE-2018-10472: x86 HVM guest OS users (in certain configurations) were
able to read arbitrary dom0 files via QMP live insertion of a CDROM, in
conjunction with specifying the target file as the backing file of a
snapshot (bsc#1089152).
- CVE-2018-10471: x86 PV guest OS users were able to cause a denial of
service (out-of-bounds zero write and hypervisor crash) via unexpected
INT 80 processing, because of an incorrect fix for CVE-2017-5754
(bsc#1089635).
- CVE-2018-7540: x86 PV guest OS users were able to cause a denial of
service (host OS CPU hang) via non-preemptable L3/L4 pagetable freeing
(bsc#1080635).
- CVE-2018-7541: Guest OS users were able to cause a denial of service
(hypervisor crash) or gain privileges by triggering a grant-table
transition from v2 to v1 (bsc#1080662).
- CVE-2018-7542: x86 PVH guest OS users were able to cause a denial of
service (NULL pointer dereference and hypervisor crash) by leveraging
the mishandling
of configurations that lack a Local APIC (bsc#1080634).

These non-security issues were fixed:

- bsc#1087252: Update built-in defaults for xenstored in stubdom, keep
default to run xenstored as daemon in dom0
- bsc#1087251: Preserve xen-syms from xen-dbg.gz to allow processing
vmcores with crash(1)
- bsc#1072834: Prevent unchecked MSR access error

This update was imported from the SUSE:SLE-12-SP3:Update update project.


Patch Instructions:

To install this openSUSE Security Update use the SUSE recommended installation methods
like YaST online_update or "zypper patch".

Alternatively you can run the command listed for your product:

- openSUSE Leap 42.3:

zypper in -t patch openSUSE-2018-454=1



Package List:

- openSUSE Leap 42.3 (x86_64):

xen-4.9.2_04-19.2
xen-debugsource-4.9.2_04-19.2
xen-devel-4.9.2_04-19.2
xen-doc-html-4.9.2_04-19.2
xen-libs-4.9.2_04-19.2
xen-libs-debuginfo-4.9.2_04-19.2
xen-tools-4.9.2_04-19.2
xen-tools-debuginfo-4.9.2_04-19.2
xen-tools-domU-4.9.2_04-19.2
xen-tools-domU-debuginfo-4.9.2_04-19.2


References:

https://www.suse.com/security/cve/CVE-2018-10471.html
https://www.suse.com/security/cve/CVE-2018-10472.html
https://www.suse.com/security/cve/CVE-2018-7540.html
https://www.suse.com/security/cve/CVE-2018-7541.html
https://www.suse.com/security/cve/CVE-2018-7542.html
https://www.suse.com/security/cve/CVE-2018-8897.html
https://bugzilla.suse.com/1027519
https://bugzilla.suse.com/1072834
https://bugzilla.suse.com/1080634
https://bugzilla.suse.com/1080635
https://bugzilla.suse.com/1080662
https://bugzilla.suse.com/1087251
https://bugzilla.suse.com/1087252
https://bugzilla.suse.com/1089152
https://bugzilla.suse.com/1089635
https://bugzilla.suse.com/1090820
https://bugzilla.suse.com/1090822
https://bugzilla.suse.com/1090823

--






Printed from Linux Compatible (https://www.linuxcompatible.org/news/story/opencv_and_xen_updates_for_opensuse.html)