Ming/Poco Updates for Debian 7 LTS
Posted on: 01/11/2018 02:28 PM

The following updates has been released for Debian GNU/Linux:

Debian GNU/Linux 7 LTS:
DLA 1240-1: ming security update

Debian GNU/Linux 8 and 9:
DSA 4083-1: poco security update

DLA 1240-1: ming security update



Package : ming
Version : 1:0.4.4-1.1+deb7u6
CVE ID : CVE-2017-11732 CVE-2017-16883 CVE-2017-16898

Multiple vulnerabilities have been discovered in Ming:

CVE-2017-11732

heap-based buffer overflow vulnerability in the function dcputs
(util/decompile.c) in Ming



DSA 4083-1: poco security update



- -------------------------------------------------------------------------
Debian Security Advisory DSA-4083-1 security@debian.org
https://www.debian.org/security/ Sebastien Delafond
January 11, 2018 https://www.debian.org/security/faq
- -------------------------------------------------------------------------

Package : poco
CVE ID : CVE-2017-1000472

Stephan Zeisberg discovered that poco, a collection of open source C++
class libraries, did not correctly validate file paths in ZIP
archives. An attacker could leverage this flaw to create or overwrite
arbitrary files.

For the oldstable distribution (jessie), this problem has been fixed
in version 1.3.6p1-5+deb8u1.

For the stable distribution (stretch), this problem has been fixed in
version 1.7.6+dfsg1-5+deb9u1.

We recommend that you upgrade your poco packages.

For the detailed security status of poco please refer to
its security tracker page at:
https://security-tracker.debian.org/tracker/poco

Further information about Debian Security Advisories, how to apply
these updates to your system and frequently asked questions can be
found at: https://www.debian.org/security/







Printed from Linux Compatible (https://www.linuxcompatible.org/news/story/mingpoco_updates_for_debian_7_lts.html)