Mbedtls Security Update for Arch Linux
Posted on: 02/28/2018 09:58 AM

Updated mbedtls packages are available for Arch Linux to address a vulnerable to arbitrary code execution

Mbedtls Security Update for Arch Linux


Arch Linux Security Advisory ASA-201802-15
==========================================

Severity: High
Date : 2018-02-24
CVE-ID : CVE-2018-0487 CVE-2018-0488
Package : mbedtls
Type : arbitrary code execution
Remote : Yes
Link : https://security.archlinux.org/AVG-617

Summary
=======

The package mbedtls before version 2.7.0-1 is vulnerable to arbitrary
code execution.

Resolution
==========

Upgrade to 2.7.0-1.

# pacman -Syu "mbedtls>=2.7.0-1"

The problems have been fixed upstream in version 2.7.0.

Workaround
==========

None.

Description
===========

- CVE-2018-0487 (arbitrary code execution)

ARM mbed TLS before 2.7.0 allows remote attackers to execute arbitrary
code or cause a denial of service (buffer overflow) via a crafted
certificate chain that is mishandled during RSASSA-PSS signature
verification within a TLS or DTLS session.

- CVE-2018-0488 (arbitrary code execution)

ARM mbed TLS before 2.7.0, when the truncated HMAC extension and CBC
are used, allows remote attackers to execute arbitrary code or cause a
denial of service (heap corruption) via a crafted application packet
within a TLS or DTLS session.

Impact
======

A remote attacker is able to execute arbitrary code on the affected
host.

References
==========

https://tls.mbed.org/tech-updates/security-advisories/mbedtls-security-advisory-2018-01
https://security.archlinux.org/CVE-2018-0487
https://security.archlinux.org/CVE-2018-0488



Printed from Linux Compatible (https://www.linuxcompatible.org/news/story/mbedtls_security_update_for_arch_linux.html)