Lucene-Solr/Wavpack/Xmltooling Updates for Debian
Posted on: 02/28/2018 09:55 AM

The following updates has been released for Debian GNU/Linux:

Debian GNU/Linux 8 and 9:
DSA 4124-1: lucene-solr security update
DSA 4126-1: xmltooling security update

Debian GNU/Linux 9:
DSA 4125-1: wavpack security update

DSA 4124-1: lucene-solr security update



- -------------------------------------------------------------------------
Debian Security Advisory DSA-4124-1 security@debian.org
https://www.debian.org/security/ Moritz Muehlenhoff
February 27, 2018 https://www.debian.org/security/faq
- -------------------------------------------------------------------------

Package : lucene-solr
CVE ID : CVE-2017-3163 CVE-2017-12629

Two vulnerabilities have been found in Solr, a search server based on
Lucene, which could result in the execution of arbitrary code or
path traversal.

For the oldstable distribution (jessie), these problems have been fixed
in version 3.6.2+dfsg-5+deb8u1.

For the stable distribution (stretch), these problems have been fixed in
version 3.6.2+dfsg-10+deb9u1.

We recommend that you upgrade your lucene-solr packages.

For the detailed security status of lucene-solr please refer to
its security tracker page at:
https://security-tracker.debian.org/tracker/lucene-solr

Further information about Debian Security Advisories, how to apply
these updates to your system and frequently asked questions can be
found at: https://www.debian.org/security/




DSA 4125-1: wavpack security update



- -------------------------------------------------------------------------
Debian Security Advisory DSA-4125-1 security@debian.org
https://www.debian.org/security/ Sebastien Delafond
February 27, 2018 https://www.debian.org/security/faq
- -------------------------------------------------------------------------

Package : wavpack
CVE ID : CVE-2018-6767 CVE-2018-7253 CVE-2018-7254
Debian Bug : 889274 889276 889559

Joonun Jang discovered several problems in wavpack, an audio
compression format suite. Incorrect processing of input resulted in
several heap- and stack-based buffer overflows, leading to application
crash or potential code execution.

For the stable distribution (stretch), these problems have been fixed
in version 5.0.0-2+deb9u1.

We recommend that you upgrade your wavpack packages.

For the detailed security status of wavpack please refer to
its security tracker page at:
https://security-tracker.debian.org/tracker/wavpack

Further information about Debian Security Advisories, how to apply
these updates to your system and frequently asked questions can be
found at: https://www.debian.org/security/




DSA 4126-1: xmltooling security update



- -------------------------------------------------------------------------
Debian Security Advisory DSA-4126-1 security@debian.org
https://www.debian.org/security/ Salvatore Bonaccorso
February 27, 2018 https://www.debian.org/security/faq
- -------------------------------------------------------------------------

Package : xmltooling
CVE ID : CVE-2018-0489

Kelby Ludwig and Scott Cantor discovered that the Shibboleth service
provider is vulnerable to impersonation attacks and information
disclosure due to incorrect XML parsing. For additional details please
refer to the upstream advisory at
https://shibboleth.net/community/advisories/secadv_20180227.txt

For the oldstable distribution (jessie), this problem has been fixed
in version 1.5.3-2+deb8u3.

For the stable distribution (stretch), this problem has been fixed in
version 1.6.0-4+deb9u1.

We recommend that you upgrade your xmltooling packages.

For the detailed security status of xmltooling please refer to its
security tracker page at:
https://security-tracker.debian.org/tracker/xmltooling

Further information about Debian Security Advisories, how to apply
these updates to your system and frequently asked questions can be
found at: https://www.debian.org/security/







Printed from Linux Compatible (https://www.linuxcompatible.org/news/story/lucene_solrwavpackxmltooling_updates_for_debian.html)